summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2003-04-16 23:02:01 +0000
committerTavis Ormandy <taviso@gentoo.org>2003-04-16 23:02:01 +0000
commit4e34b979974949a5431a548061db6a729c43f7a4 (patch)
tree88a7ba5f6c4844823f9c97679d8d6038d620935f /dev-libs
parentcleaned out old ebuilds (diff)
downloadgentoo-2-4e34b979974949a5431a548061db6a729c43f7a4.tar.gz
gentoo-2-4e34b979974949a5431a548061db6a729c43f7a4.tar.bz2
gentoo-2-4e34b979974949a5431a548061db6a729c43f7a4.zip
Initial import: Compaq eXtended Maths Library, marked ~alpha
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libcxml/libcxml-5.2.0.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/dev-libs/libcxml/libcxml-5.2.0.ebuild b/dev-libs/libcxml/libcxml-5.2.0.ebuild
new file mode 100644
index 000000000000..2fa0eb4890ce
--- /dev/null
+++ b/dev-libs/libcxml/libcxml-5.2.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libcxml/libcxml-5.2.0.ebuild,v 1.1 2003/04/16 23:02:01 taviso Exp $
+
+S=${WORKDIR}/usr
+SRC_URI=""
+DESCRIPTION="Compaqs eXtended Math Library for linux alpha"
+HOMEPAGE="http://h18000.www1.hp.com/math/index.html"
+DEPEND="virtual/glibc
+ app-arch/rpm2targz
+ dev-libs/libots
+ dev-libs/libcpml"
+RDEPEND="dev-libs/libots
+ dev-libs/libcpml"
+LICENSE="compaq-sdla"
+SLOT="0"
+KEYWORDS="-* ~alpha"
+IUSE="ev6 doc"
+
+# non portage variable
+RELEASE="5.2.0-2"
+
+src_unpack() {
+ local EV; use ev6 && EV=ev6 || EV=ev5
+ At="cxml_${EV}-${RELEASE}.alpha.rpm"
+ if [ ! -f ${DISTDIR}/${At} ] ; then
+ die "Please download ${At} from ${HOMEPAGE}"
+ fi
+
+ # agriffis' improved method for rpm extraction
+ #
+ i=${DISTDIR}/${At}
+ dd ibs=`rpmoffset < ${i}` skip=1 if=$i 2>/dev/null \
+ | gzip -dc | cpio -idmu 2>/dev/null \
+ && find usr -type d -print0 | xargs -0 chmod a+rx \
+ && chown -R root:root usr
+ eend ${?}
+ assert "Failed to extract ${At%.rpm}.tar.gz"
+
+ if ! use doc >/dev/null ; then
+ einfo "Removing unwanted documentation (USE=\"-doc\")..."
+ rm -rf usr/doc
+ else
+ einfo "Reorganising Documentation..."
+ mkdir usr/share
+ mv usr/doc usr/share/
+ fi
+
+}
+
+src_compile () {
+ local EV; use ev6 && EV=ev6 || EV=ev5
+ cd ${WORKDIR}/usr/lib/compaq/cxml-${RELEASE%*-2}
+
+ # http://h18000.www1.hp.com/math/faq/cxml.html#EmptySharedLib
+ ld -shared -o libcxml_${EV}.so -soname libcxml.so \
+ -whole-archive libcxml_${EV}.a -no-whole-archive -lots -lcpml
+}
+
+src_install () {
+ mv ${WORKDIR}/usr ${D}
+ prepalldocs
+ einfo "Please wait while portage strips the libraries..."
+ einfo "This may take a minute..."
+}
+