summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2008-05-10 03:36:35 +0000
committerMark Loeser <halcy0n@gentoo.org>2008-05-10 03:36:35 +0000
commit49389e09f30a46ef5b2bbce70a922c4159ece452 (patch)
tree9a44c7eae535c9218a2da12491743703738a0a90 /dev-libs
parentAdd patch to fix compilation with gcc-4.3 by Peter Alfredsen <peter DOT alfre... (diff)
downloadgentoo-2-49389e09f30a46ef5b2bbce70a922c4159ece452.tar.gz
gentoo-2-49389e09f30a46ef5b2bbce70a922c4159ece452.tar.bz2
gentoo-2-49389e09f30a46ef5b2bbce70a922c4159ece452.zip
Patch to fix compilation with gcc-4.3 by Peter Alfredsen <peter DOT alfredsen AT gmail DOT com>; bug #217667
(Portage version: 2.1.5_rc7)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/gmetadom/ChangeLog7
-rw-r--r--dev-libs/gmetadom/files/gmetadom-0.2.6-gcc43.patch18
-rw-r--r--dev-libs/gmetadom/gmetadom-0.2.6.ebuild3
3 files changed, 26 insertions, 2 deletions
diff --git a/dev-libs/gmetadom/ChangeLog b/dev-libs/gmetadom/ChangeLog
index 0d45358ad8bb..85cd025d19bd 100644
--- a/dev-libs/gmetadom/ChangeLog
+++ b/dev-libs/gmetadom/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/gmetadom
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmetadom/ChangeLog,v 1.29 2008/01/18 00:32:35 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmetadom/ChangeLog,v 1.30 2008/05/10 03:36:34 halcy0n Exp $
+
+ 10 May 2008; Mark Loeser <halcy0n@gentoo.org>
+ +files/gmetadom-0.2.6-gcc43.patch, gmetadom-0.2.6.ebuild:
+ Patch to fix compilation with gcc-4.3 by Peter Alfredsen <peter DOT
+ alfredsen AT gmail DOT com>; bug #217667
18 Jan 2008; MATSUU Takuto <matsuu@gentoo.org>
files/gmetadom-0.2.6-gentoo.patch:
diff --git a/dev-libs/gmetadom/files/gmetadom-0.2.6-gcc43.patch b/dev-libs/gmetadom/files/gmetadom-0.2.6-gcc43.patch
new file mode 100644
index 000000000000..c16c3d6baba5
--- /dev/null
+++ b/dev-libs/gmetadom/files/gmetadom-0.2.6-gcc43.patch
@@ -0,0 +1,18 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 01_gcc43-fix.dpatch by Michael Bienia <geser@ubuntu.com>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: No description.
+
+@DPATCH@
+diff -urNad gmetadom-0.2.5-3ubuntu1~/src/gdome_cpp_smart/include/GdomeSmartDOMTraits.hh gmetadom-0.2.5-3ubuntu1/src/gdome_cpp_smart/include/GdomeSmartDOMTraits.hh
+--- gmetadom-0.2.5-3ubuntu1~/src/gdome_cpp_smart/include/GdomeSmartDOMTraits.hh 2007-11-21 18:27:08.000000000 +0100
++++ gmetadom-0.2.5-3ubuntu1/src/gdome_cpp_smart/include/GdomeSmartDOMTraits.hh 2007-11-28 12:16:00.000000000 +0100
+@@ -26,6 +26,7 @@
+ */
+
+ #include <string>
++#include <cstring>
+
+ #include "GdomeSmartDOMChar.hh"
+
diff --git a/dev-libs/gmetadom/gmetadom-0.2.6.ebuild b/dev-libs/gmetadom/gmetadom-0.2.6.ebuild
index 1911f01e5c75..3b95acb9055b 100644
--- a/dev-libs/gmetadom/gmetadom-0.2.6.ebuild
+++ b/dev-libs/gmetadom/gmetadom-0.2.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmetadom/gmetadom-0.2.6.ebuild,v 1.1 2008/01/17 15:08:30 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmetadom/gmetadom-0.2.6.ebuild,v 1.2 2008/05/10 03:36:34 halcy0n Exp $
WANT_AUTOCONF=latest
WANT_AUTOMAKE=latest
@@ -31,6 +31,7 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}"/${P}-gentoo.patch
+ epatch "${FILESDIR}"/${P}-gcc43.patch
eautoreconf
}