summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSlawek Lis <slis@gentoo.org>2015-02-02 07:04:32 +0000
committerSlawek Lis <slis@gentoo.org>2015-02-02 07:04:32 +0000
commit466b7522492e47ab2b8ea036864cb134b742cb61 (patch)
tree14abcca7ba51b513b0627aea024b0ed67acb1e81 /dev-libs
parentVersion bump. (diff)
downloadgentoo-2-466b7522492e47ab2b8ea036864cb134b742cb61.tar.gz
gentoo-2-466b7522492e47ab2b8ea036864cb134b742cb61.tar.bz2
gentoo-2-466b7522492e47ab2b8ea036864cb134b742cb61.zip
version bump
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 0x55265D89)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/papi/ChangeLog9
-rw-r--r--dev-libs/papi/papi-5.4.0.ebuild39
2 files changed, 46 insertions, 2 deletions
diff --git a/dev-libs/papi/ChangeLog b/dev-libs/papi/ChangeLog
index de2d6d66c131..6d34f597a587 100644
--- a/dev-libs/papi/ChangeLog
+++ b/dev-libs/papi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/papi
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/papi/ChangeLog,v 1.2 2014/11/28 20:26:33 slis Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/papi/ChangeLog,v 1.3 2015/02/02 07:04:32 slis Exp $
+
+*papi-5.4.0 (02 Feb 2015)
+
+ 02 Feb 2015; Sławek Lis <slis@gentoo.org> +papi-5.4.0.ebuild:
+ version bump
28 Nov 2014; Sławek Lis <slis@gentoo.org> papi-5.3.0.ebuild:
Fixed bug 531024
diff --git a/dev-libs/papi/papi-5.4.0.ebuild b/dev-libs/papi/papi-5.4.0.ebuild
new file mode 100644
index 000000000000..2428db044194
--- /dev/null
+++ b/dev-libs/papi/papi-5.4.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/papi/papi-5.4.0.ebuild,v 1.1 2015/02/02 07:04:32 slis Exp $
+
+EAPI=5
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+inherit autotools-utils fortran-2 versionator
+
+DESCRIPTION="Performance Application Programming Interface"
+HOMEPAGE="http://icl.cs.utk.edu/papi/"
+SRC_URI="http://icl.cs.utk.edu/projects/${PN}/downloads/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+DEPEND="
+ dev-libs/libpfm[static-libs]
+ virtual/mpi
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-$(get_version_component_range 1-3)/src"
+
+src_configure() {
+ local myeconfargs=(
+ --with-shlib
+ --with-perf-events
+ --with-pfm-prefix="${EPREFIX}/usr"
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ dodoc ../RE*
+}