summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2012-04-13 05:04:04 +0000
committerRyan Hill <dirtyepic@gentoo.org>2012-04-13 05:04:04 +0000
commit453e4d670bf2d5da7487a8bf3bf34972cf5e00fa (patch)
tree27a39291a11aed58c5e5264af69cc86814d48472 /dev-libs
parentMake DESCRIPTION more descriptive; thanks to ralda for reporting. (diff)
downloadgentoo-2-453e4d670bf2d5da7487a8bf3bf34972cf5e00fa.tar.gz
gentoo-2-453e4d670bf2d5da7487a8bf3bf34972cf5e00fa.tar.bz2
gentoo-2-453e4d670bf2d5da7487a8bf3bf34972cf5e00fa.zip
Version bump.
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/ppl/ChangeLog7
-rw-r--r--dev-libs/ppl/ppl-0.12.ebuild83
2 files changed, 89 insertions, 1 deletions
diff --git a/dev-libs/ppl/ChangeLog b/dev-libs/ppl/ChangeLog
index c834b26b902e..b905b7c82fa2 100644
--- a/dev-libs/ppl/ChangeLog
+++ b/dev-libs/ppl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/ppl
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/ppl/ChangeLog,v 1.47 2012/02/20 07:20:33 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ppl/ChangeLog,v 1.48 2012/04/13 05:04:04 dirtyepic Exp $
+
+*ppl-0.12 (13 Apr 2012)
+
+ 13 Apr 2012; Ryan Hill <dirtyepic@gentoo.org> +ppl-0.12.ebuild:
+ Version bump.
20 Feb 2012; Ryan Hill <dirtyepic@gentoo.org> -ppl-0.11.2.ebuild:
Remove old.
diff --git a/dev-libs/ppl/ppl-0.12.ebuild b/dev-libs/ppl/ppl-0.12.ebuild
new file mode 100644
index 000000000000..d8014f42694e
--- /dev/null
+++ b/dev-libs/ppl/ppl-0.12.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ppl/ppl-0.12.ebuild,v 1.1 2012/04/13 05:04:04 dirtyepic Exp $
+
+EAPI="3"
+
+inherit eutils
+
+DESCRIPTION="The Parma Polyhedra Library provides numerical abstractions for analysis of complex systems"
+HOMEPAGE="http://bugseng.com/products/ppl"
+SRC_URI="http://bugseng.com/products/ppl/download/ftp/releases/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~amd64-linux ~sparc-solaris"
+IUSE="doc lpsol pch static-libs test"
+
+RDEPEND=">=dev-libs/gmp-4.1.3[cxx]
+ lpsol? ( sci-mathematics/glpk )
+ !<dev-libs/cloog-ppl-0.15.10"
+DEPEND="${RDEPEND}
+ sys-devel/m4"
+
+pkg_setup() {
+ if use test; then
+ ewarn "The PPL testsuite will be run."
+ ewarn "Note that this can take several hours to complete on a fast machine."
+ epause 3
+ fi
+}
+
+src_configure() {
+ # --disable-check doesn't work
+ use test && want_check="--enable-check=quick"
+ econf \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --disable-debugging \
+ --disable-optimization \
+ $(use_enable doc documentation) \
+ $(use_enable lpsol ppl_lpsol) \
+ $(use_enable pch) \
+ $(use_enable static-libs static) \
+ --enable-interfaces="c cxx" \
+ $(use test && echo --enable-check=quick)
+}
+
+src_test() {
+ # default src_test runs with -j1, overriding it here saves about
+ # 30 minutes and is recommended by upstream
+ if emake -j1 check -n &> /dev/null; then
+ emake check || die "tests failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ use static-libs || rm -f "${D}"/usr/lib*/libppl*.la
+
+ local docsdir="${ED}/usr/share/doc/${PF}"
+ rm "${docsdir}"/gpl* "${docsdir}"/fdl* || die
+
+ if ! use doc; then
+ rm -r "${docsdir}"/*-html/ || die
+ fi
+
+ dodoc NEWS README* STANDARDS TODO
+}
+
+pkg_postinst() {
+ echo
+ ewarn "After an upgrade of PPL it is important that you rebuild"
+ ewarn "dev-libs/cloog-ppl."
+ ewarn
+ ewarn "If you use gcc-config to switch to an older compiler version than"
+ ewarn "the one PPL was built with, PPL must be rebuilt with that version."
+ ewarn
+ ewarn "In both cases failure to do this will get you this error when"
+ ewarn "graphite flags are used:"
+ ewarn
+ ewarn " sorry, unimplemented: Graphite loop optimizations cannot be used"
+ ewarn
+ echo
+}