summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-03-09 02:33:57 +0000
committerMike Frysinger <vapier@gentoo.org>2005-03-09 02:33:57 +0000
commit3a7cd53db24ed0c5568984c7bbf7bc21bc794525 (patch)
tree31e3e8856dbab5ddab6764a4023f1e567f401797 /dev-libs
parentUSE=sysfs (diff)
downloadgentoo-2-3a7cd53db24ed0c5568984c7bbf7bc21bc794525.tar.gz
gentoo-2-3a7cd53db24ed0c5568984c7bbf7bc21bc794525.tar.bz2
gentoo-2-3a7cd53db24ed0c5568984c7bbf7bc21bc794525.zip
fix i830 detection and add support for USE=sysfs #84477
(Portage version: 2.0.51.19)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/DirectFB/DirectFB-0.9.22.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/dev-libs/DirectFB/DirectFB-0.9.22.ebuild b/dev-libs/DirectFB/DirectFB-0.9.22.ebuild
index 2654ed6a7c85..2a1980dba83f 100644
--- a/dev-libs/DirectFB/DirectFB-0.9.22.ebuild
+++ b/dev-libs/DirectFB/DirectFB-0.9.22.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/DirectFB-0.9.22.ebuild,v 1.1 2005/03/02 01:07:00 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/DirectFB-0.9.22.ebuild,v 1.2 2005/03/09 02:33:57 vapier Exp $
inherit eutils 64-bit flag-o-matic gcc
@@ -13,13 +13,14 @@ SRC_URI="http://www.directfb.org/download/DirectFB/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 -mips ~ppc -sparc ~x86"
-IUSE="sdl jpeg gif png truetype mpeg mmx sse fusion debug fbcon static"
+IUSE="debug fbcon fusion gif jpeg mmx mpeg png sdl sse static sysfs truetype"
DEPEND="sdl? ( media-libs/libsdl )
gif? ( media-libs/giflib )
png? ( media-libs/libpng )
jpeg? ( media-libs/jpeg )
mpeg? ( media-libs/libmpeg3 )
+ sysfs? ( sys-fs/sysfsutils )
truetype? ( >=media-libs/freetype-2.0.1 )"
pkg_setup() {
@@ -34,12 +35,14 @@ src_unpack() {
unpack ${A}
cd "${S}"
- #36924
+ # Make sure i830 is detected
+ # force disable wm97xx #36924
sed -i \
- -e 's:wm97xx_ts=yes:wm97xx_ts=no:' configure \
+ -e 's:^//::' \
+ -e 's:wm97xx_ts=yes:wm97xx_ts=no:' \
+ configure \
|| die "sed configure failed"
-
# This patch enables simd optimisations for amd64. Since mmx and sse are
# masked USE flags on amd64 due to their enabling x86 specific asm more
# often than not, we'll just enable them by default. All x86_64 cpus
@@ -80,6 +83,7 @@ src_compile() {
$(use_enable fusion multi) \
$(use_enable debug) \
$(use_enable static) \
+ $(use_enable sysfs) \
${sdlconf} \
--with-gfxdrivers="${vidcards}" \
|| die