summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-03-15 10:26:06 +0000
committerTim Harder <radhermit@gentoo.org>2014-03-15 10:26:06 +0000
commit34eb806c2a7fb4f0c083567995d47507e6fbc311 (patch)
tree9bdc2a9176eeb85644d404ffef3685909145996e /dev-libs
parentVersion bump, bug #497436. Fixes bugs #406783 and #399087. Symlink docs from ... (diff)
downloadgentoo-2-34eb806c2a7fb4f0c083567995d47507e6fbc311.tar.gz
gentoo-2-34eb806c2a7fb4f0c083567995d47507e6fbc311.tar.bz2
gentoo-2-34eb806c2a7fb4f0c083567995d47507e6fbc311.zip
Version bumps.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/userspace-rcu/ChangeLog9
-rw-r--r--dev-libs/userspace-rcu/userspace-rcu-0.7.12.ebuild28
-rw-r--r--dev-libs/userspace-rcu/userspace-rcu-0.8.4.ebuild28
3 files changed, 64 insertions, 1 deletions
diff --git a/dev-libs/userspace-rcu/ChangeLog b/dev-libs/userspace-rcu/ChangeLog
index 46aa108edc63..fe237dbf7279 100644
--- a/dev-libs/userspace-rcu/ChangeLog
+++ b/dev-libs/userspace-rcu/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/userspace-rcu
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/userspace-rcu/ChangeLog,v 1.14 2014/03/04 19:00:47 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/userspace-rcu/ChangeLog,v 1.15 2014/03/15 10:26:06 radhermit Exp $
+
+*userspace-rcu-0.8.4 (15 Mar 2014)
+*userspace-rcu-0.7.12 (15 Mar 2014)
+
+ 15 Mar 2014; Tim Harder <radhermit@gentoo.org> +userspace-rcu-0.7.12.ebuild,
+ +userspace-rcu-0.8.4.ebuild:
+ Version bumps.
*userspace-rcu-0.7.11 (04 Mar 2014)
diff --git a/dev-libs/userspace-rcu/userspace-rcu-0.7.12.ebuild b/dev-libs/userspace-rcu/userspace-rcu-0.7.12.ebuild
new file mode 100644
index 000000000000..fc489c535de6
--- /dev/null
+++ b/dev-libs/userspace-rcu/userspace-rcu-0.7.12.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/userspace-rcu/userspace-rcu-0.7.12.ebuild,v 1.1 2014/03/15 10:26:06 radhermit Exp $
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="userspace RCU (read-copy-update) library"
+HOMEPAGE="http://lttng.org/urcu"
+SRC_URI="http://lttng.org/files/urcu/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs test"
+
+DEPEND="test? ( sys-process/time )"
+
+# tests fail with separate build dir
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_configure() {
+ local myeconfargs=(
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+ )
+ autotools-utils_src_configure
+}
diff --git a/dev-libs/userspace-rcu/userspace-rcu-0.8.4.ebuild b/dev-libs/userspace-rcu/userspace-rcu-0.8.4.ebuild
new file mode 100644
index 000000000000..5b5d6479cd57
--- /dev/null
+++ b/dev-libs/userspace-rcu/userspace-rcu-0.8.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/userspace-rcu/userspace-rcu-0.8.4.ebuild,v 1.1 2014/03/15 10:26:06 radhermit Exp $
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="userspace RCU (read-copy-update) library"
+HOMEPAGE="http://lttng.org/urcu"
+SRC_URI="http://lttng.org/files/urcu/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0/2" # subslot = soname version
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs test"
+
+DEPEND="test? ( sys-process/time )"
+
+# tests fail with separate build dir
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_configure() {
+ local myeconfargs=(
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+ )
+ autotools-utils_src_configure
+}