summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-04 18:29:00 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-04 18:29:00 +0000
commit3490e9be9e89758a974b640a9b9729b123a54d4c (patch)
tree1e97c85d8156f6d41994b33b2a8af75b932940ff /dev-libs
parentVersion bump by Pavel. (diff)
downloadgentoo-2-3490e9be9e89758a974b640a9b9729b123a54d4c.tar.gz
gentoo-2-3490e9be9e89758a974b640a9b9729b123a54d4c.tar.bz2
gentoo-2-3490e9be9e89758a974b640a9b9729b123a54d4c.zip
Restrict Jython ABIs. Call some functions only with USE="python".
(Portage version: 2.2.0_alpha26_p6/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/tre/tre-0.8.0.ebuild14
1 files changed, 12 insertions, 2 deletions
diff --git a/dev-libs/tre/tre-0.8.0.ebuild b/dev-libs/tre/tre-0.8.0.ebuild
index cb5f11c02f71..972d195ca7c4 100644
--- a/dev-libs/tre/tre-0.8.0.ebuild
+++ b/dev-libs/tre/tre-0.8.0.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/tre/tre-0.8.0.ebuild,v 1.13 2011/03/04 18:13:40 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/tre/tre-0.8.0.ebuild,v 1.14 2011/03/04 18:29:00 arfrever Exp $
EAPI=2
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
inherit distutils eutils
@@ -28,6 +28,10 @@ DEPEND="${RDEPEND}
DISTUTILS_SETUP_FILES=("python/setup.py")
+pkg_setup() {
+ use python && python_pkg_setup
+}
+
src_prepare() {
epatch "${FILESDIR}"/${PV}-python.patch
}
@@ -71,4 +75,10 @@ pkg_postinst() {
ewarn "If this causes any unforeseen incompatibilities please file a bug"
ewarn "on http://bugs.gentoo.org."
echo
+
+ use python && distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ use python && distutils_pkg_postrm
}