summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-09-12 08:59:31 +0000
committerPacho Ramos <pacho@gentoo.org>2011-09-12 08:59:31 +0000
commit30573c153e0b59f5c1d6d00c5b08e76bffc6eaa3 (patch)
tree4466d79bd0d0d340daf0fbcdf722458383cc1c56 /dev-libs
parentApply multiple fixes for tests, also a one to prevent hangs by Markos Chandra... (diff)
downloadgentoo-2-30573c153e0b59f5c1d6d00c5b08e76bffc6eaa3.tar.gz
gentoo-2-30573c153e0b59f5c1d6d00c5b08e76bffc6eaa3.tar.bz2
gentoo-2-30573c153e0b59f5c1d6d00c5b08e76bffc6eaa3.zip
Build tests only on make check, bug #379929 by Dave Kemper and patch by Alexandre Rostovtsev.
(Portage version: 2.1.10.14/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/gobject-introspection/ChangeLog8
-rw-r--r--dev-libs/gobject-introspection/files/gobject-introspection-0.10.8-build-tests.patch104
-rw-r--r--dev-libs/gobject-introspection/gobject-introspection-0.10.8.ebuild13
3 files changed, 120 insertions, 5 deletions
diff --git a/dev-libs/gobject-introspection/ChangeLog b/dev-libs/gobject-introspection/ChangeLog
index 2c5244290415..be167942addd 100644
--- a/dev-libs/gobject-introspection/ChangeLog
+++ b/dev-libs/gobject-introspection/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/gobject-introspection
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/gobject-introspection/ChangeLog,v 1.41 2011/08/16 18:05:40 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gobject-introspection/ChangeLog,v 1.42 2011/09/12 08:59:31 pacho Exp $
+
+ 12 Sep 2011; Pacho Ramos <pacho@gentoo.org>
+ gobject-introspection-0.10.8.ebuild,
+ +files/gobject-introspection-0.10.8-build-tests.patch:
+ Build tests only on make check, bug #379929 by Dave Kemper and patch by
+ Alexandre Rostovtsev.
16 Aug 2011; Nirbheek Chauhan <nirbheek@gentoo.org>
gobject-introspection-0.10.8.ebuild:
diff --git a/dev-libs/gobject-introspection/files/gobject-introspection-0.10.8-build-tests.patch b/dev-libs/gobject-introspection/files/gobject-introspection-0.10.8-build-tests.patch
new file mode 100644
index 000000000000..53bf485379ab
--- /dev/null
+++ b/dev-libs/gobject-introspection/files/gobject-introspection-0.10.8-build-tests.patch
@@ -0,0 +1,104 @@
+From 3a308bb438246f7d6e87ebe2f6efeb1795fdcd1e Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gmail.com>
+Date: Mon, 22 Aug 2011 06:49:51 +0000
+Subject: tests: build tests only on make check
+
+Use automake's check_ prefix and avoid putting anything nontrivial in
+BUILT_SOURCES so that tests are build only on make check.
+
+The dummy -rpath in AM_LDFLAGS in tests/scanner/Makefile.am is needed to
+force libtool to build shared libraries for check_LTLIBRARIESS targets
+(automake builds check_LTLIBRARIES as static by default); see
+http://lists.gnu.org/archive/html/automake/2005-10/msg00107.html
+
+https://bugzilla.gnome.org/show_bug.cgi?id=657066
+---
+diff --git a/tests/Makefile.am b/tests/Makefile.am
+index 20ecc17..2d395a3 100644
+--- a/tests/Makefile.am
++++ b/tests/Makefile.am
+@@ -16,16 +16,14 @@ tests_DATA = \
+ gimarshallingtests.c \
+ gimarshallingtests.h
+
+-testlib_LTLIBRARIES = libeverything-1.0.la libgimarshallingtests-1.0.la
+-testlibdir=$(prefix)/unused
+-install-testlibLTLIBRARIES: # prevent it from being installed
++check_LTLIBRARIES = libeverything-1.0.la libgimarshallingtests-1.0.la
+
+ libeverything_1_0_la_SOURCES = everything.c
+ libgimarshallingtests_1_0_la_SOURCES = gimarshallingtests.c
+
+ EXTRA_DIST += gimarshallingtests.h
+
+-BUILT_SOURCES += everything.c everything.h Everything-1.0.gir GIMarshallingTests-1.0.gir
++BUILT_SOURCES += everything.c everything.h
+
+ CLEANFILES += \
+ $(BUILT_SOURCES) \
+diff --git a/tests/repository/Makefile.am b/tests/repository/Makefile.am
+index 268d9f9..ffc635f 100644
+--- a/tests/repository/Makefile.am
++++ b/tests/repository/Makefile.am
+@@ -2,7 +2,7 @@ AM_CFLAGS = $(GOBJECT_CFLAGS)
+ AM_LDFLAGS = -module -avoid-version
+ LIBS = $(GOBJECT_LIBS)
+
+-noinst_PROGRAMS = gitestrepo gitestthrows gitypelibtest
++check_PROGRAMS = gitestrepo gitestthrows gitypelibtest
+
+ gitestrepo_SOURCES = $(srcdir)/gitestrepo.c
+ gitestrepo_CPPFLAGS = $(GIREPO_CFLAGS) -I$(top_srcdir)/girepository
+diff --git a/tests/scanner/Makefile.am b/tests/scanner/Makefile.am
+index 6b78ee7..fc2e260 100644
+--- a/tests/scanner/Makefile.am
++++ b/tests/scanner/Makefile.am
+@@ -3,24 +3,21 @@ include $(top_srcdir)/Makefile.introspection
+
+ INTROSPECTION_SCANNER_ARGS += --warn-all --warn-error -I.
+
+-# We need to build a shared library, which can be dlopened
+-# it does not work with noinst_LTLIBRARIES
+-testlib_LTLIBRARIES = \
++check_LTLIBRARIES = \
+ libannotation.la \
+ libtestinherit.la \
+ libfoo.la \
+ libutility.la \
+ libgtkfrob.la
+ if HAVE_CAIRO
+-testlib_LTLIBRARIES += libregress.la
++check_LTLIBRARIES += libregress.la
+ endif
+
+-testlibdir = $(prefix)/unused
+-install-testlibLTLIBRARIES: # prevent it from being installed
+-
+ AM_CPPFLAGS = -I$(top_srcdir)/girepository
+ AM_CFLAGS = $(GIO_CFLAGS) $(GOBJECT_CFLAGS) $(GTHREAD_CFLAGS)
+-AM_LDFLAGS = -avoid-version
++# -rpath needed to force libtool to build a shared library for a check_LTLIBRARIES
++# target. See http://lists.gnu.org/archive/html/automake/2005-10/msg00107.html
++AM_LDFLAGS = -rpath /unused -avoid-version
+ LIBS = $(GOBJECT_LIBS) $(GTHREAD_LIBS)
+
+ libannotation_la_SOURCES = $(srcdir)/annotation.c $(srcdir)/annotation.h
+@@ -49,7 +46,6 @@ CHECKGIRS = $(GIRS:.gir=.gir.check)
+ EXPECTEDGIRS = $(GIRS:.gir=-expected.gir)
+ INTROSPECTION_GIRS = $(GIRS)
+ CLEANFILES = $(TYPELIBS) $(GIRS)
+-BUILT_SOURCES = $(TYPELIBS) $(GIRS)
+ EXTRA_DIST = $(EXPECTEDGIRS)
+
+ Regress-1.0.gir: $(top_builddir)/Gio-2.0.gir libregress.la
+@@ -102,7 +98,7 @@ GtkFrob_1_0_gir_FILES = $(libgtkfrob_la_SOURCES)
+ GtkFrob_1_0_gir_SCANNERFLAGS = --identifier-prefix=Gtk --symbol-prefix=gtk_frob
+ GIRS += GtkFrob-1.0.gir
+
+-noinst_PROGRAMS = barapp
++check_PROGRAMS = barapp
+
+ barapp_SOURCES = $(srcdir)/barapp.c $(srcdir)/barapp.h
+ barapp_LDADD = $(top_builddir)/libgirepository-1.0.la
+--
+cgit v0.9.0.2
diff --git a/dev-libs/gobject-introspection/gobject-introspection-0.10.8.ebuild b/dev-libs/gobject-introspection/gobject-introspection-0.10.8.ebuild
index 71c466feb13b..afd24e517c60 100644
--- a/dev-libs/gobject-introspection/gobject-introspection-0.10.8.ebuild
+++ b/dev-libs/gobject-introspection/gobject-introspection-0.10.8.ebuild
@@ -1,12 +1,13 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/gobject-introspection/gobject-introspection-0.10.8.ebuild,v 1.14 2011/08/16 18:05:40 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gobject-introspection/gobject-introspection-0.10.8.ebuild,v 1.15 2011/09/12 08:59:31 pacho Exp $
EAPI="3"
GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
PYTHON_DEPEND="2:2.5"
-inherit gnome2 python libtool
+inherit gnome2 python libtool eutils autotools
DESCRIPTION="Introspection infrastructure for generating gobject library bindings for various languages"
HOMEPAGE="http://live.gnome.org/GObjectIntrospection/"
@@ -41,15 +42,19 @@ src_prepare() {
# Don't pre-compile .py
ln -sf $(type -P true) py-compile
+ # tests: build tests only on make check
+ epatch "${FILESDIR}/${P}-build-tests.patch"
+ eautoreconf
+
+ # Uncomment the following once we don't need full eautoreconf
# Fix Darwin bundles
- elibtoolize
+# elibtoolize
}
src_install() {
gnome2_src_install
python_convert_shebangs 2 "${ED}"usr/bin/g-ir-scanner
python_convert_shebangs 2 "${ED}"usr/bin/g-ir-annotation-tool
- find "${ED}" -name "*.la" -delete || die "la files removal failed"
}
pkg_postinst() {