summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2009-03-03 09:00:34 +0000
committerTiziano Müller <dev-zero@gentoo.org>2009-03-03 09:00:34 +0000
commit28a62422a93b2d3578af9002960bddd6011fd3fe (patch)
tree627883a14f12037a809fe311832c1cada235610c /dev-libs
parentAdded ~amd64 keyword, Bug #260342 (diff)
downloadgentoo-2-28a62422a93b2d3578af9002960bddd6011fd3fe.tar.gz
gentoo-2-28a62422a93b2d3578af9002960bddd6011fd3fe.tar.bz2
gentoo-2-28a62422a93b2d3578af9002960bddd6011fd3fe.zip
Version bump. Dropped old versions.
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/xqilla/ChangeLog8
-rw-r--r--dev-libs/xqilla/xqilla-2.1.2.ebuild46
-rw-r--r--dev-libs/xqilla/xqilla-2.2.0.ebuild (renamed from dev-libs/xqilla/xqilla-2.1.3.ebuild)30
3 files changed, 24 insertions, 60 deletions
diff --git a/dev-libs/xqilla/ChangeLog b/dev-libs/xqilla/ChangeLog
index 7acf7e5f793e..38a1cd85311e 100644
--- a/dev-libs/xqilla/ChangeLog
+++ b/dev-libs/xqilla/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/xqilla
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xqilla/ChangeLog,v 1.4 2009/03/01 13:23:54 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xqilla/ChangeLog,v 1.5 2009/03/03 09:00:34 dev-zero Exp $
+
+*xqilla-2.2.0 (03 Mar 2009)
+
+ 03 Mar 2009; Tiziano Müller <dev-zero@gentoo.org> -xqilla-2.1.2.ebuild,
+ -xqilla-2.1.3.ebuild, +xqilla-2.2.0.ebuild:
+ Version bump. Dropped old versions.
*xqilla-2.1.3-r1 (01 Mar 2009)
diff --git a/dev-libs/xqilla/xqilla-2.1.2.ebuild b/dev-libs/xqilla/xqilla-2.1.2.ebuild
deleted file mode 100644
index 85b140b404e7..000000000000
--- a/dev-libs/xqilla/xqilla-2.1.2.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xqilla/xqilla-2.1.2.ebuild,v 1.1 2008/05/23 06:09:55 dev-zero Exp $
-
-inherit eutils
-
-MY_P="XQilla-${PV}"
-
-DESCRIPTION="An XQuery and XPath 2 library and command line utility written in C++."
-HOMEPAGE="http://xqilla.sourceforge.net/HomePage"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-LICENSE="Sleepycat BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc"
-
-RDEPEND="~dev-libs/xerces-c-2.8.0"
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
- if ! built_with_use dev-libs/xerces-c xqilla ; then
- eerror "dev-libs/xerces-c has to be built with the xqilla USE-flag"
- die "missing xqilla USE-flag for dev-libs/xerces-c"
- fi
-}
-
-src_compile() {
- econf --with-xerces="/usr" || die "econf failed"
- emake || die "emake failed"
-
- if use doc; then
- emake docs || die "emake docs failed"
- fi
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die "emake docs failed"
-
- if use doc; then
- cd docs
- dohtml -r dom3-api simple-api
- fi
-}
diff --git a/dev-libs/xqilla/xqilla-2.1.3.ebuild b/dev-libs/xqilla/xqilla-2.2.0.ebuild
index 25500d7102fc..f888c0df54d2 100644
--- a/dev-libs/xqilla/xqilla-2.1.3.ebuild
+++ b/dev-libs/xqilla/xqilla-2.2.0.ebuild
@@ -1,42 +1,46 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xqilla/xqilla-2.1.3.ebuild,v 1.1 2008/08/15 08:59:50 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xqilla/xqilla-2.2.0.ebuild,v 1.1 2009/03/03 09:00:34 dev-zero Exp $
-inherit eutils
+EAPI="2"
MY_P="XQilla-${PV}"
DESCRIPTION="An XQuery and XPath 2 library and command line utility written in C++."
HOMEPAGE="http://xqilla.sourceforge.net/HomePage"
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-LICENSE="Sleepycat BSD"
+LICENSE="Apache-2.0 BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug doc faxpp htmltidy"
-RDEPEND="faxpp? ( dev-libs/faxpp )
- ~dev-libs/xerces-c-2.8.0
+# XQilla bundles two libraries:
+# - mapm, heavily patched
+# - yajl, moderately patched
+# There's currently no way to unbundle those
+
+RDEPEND=">=dev-libs/xerces-c-3.0.1
+ faxpp? ( dev-libs/faxpp )
htmltidy? ( app-text/htmltidy )"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )"
S="${WORKDIR}/${MY_P}"
-pkg_setup() {
- if ! built_with_use dev-libs/xerces-c xqilla ; then
- eerror "dev-libs/xerces-c has to be built with the xqilla USE-flag"
- die "missing xqilla USE-flag for dev-libs/xerces-c"
- fi
+src_prepare() {
+ sed -i -e 's|^LDFLAGS =|LDFLAGS +=|' Makefile.in || die "sed failed"
}
-src_compile() {
+src_configure() {
econf \
--with-xerces=/usr \
$(use_enable debug) \
$(use_with htmltidy tidy) \
$(use_with faxpp faxpp /usr)
+}
- emake || die "emake failed"
+src_compile() {
+ default
if use doc; then
emake docs || die "emake docs failed"