summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-07-14 10:06:40 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-07-14 10:06:40 +0000
commit2682bb00f508538a6f737bd4013896541d6c9a46 (patch)
treeca72ee4daef72b5e653bc03b4ddd0ed8d163608b /dev-libs
parentre-enable xf86-input-fpit, ABI issues have been fixed, not revbumping for now... (diff)
downloadgentoo-2-2682bb00f508538a6f737bd4013896541d6c9a46.tar.gz
gentoo-2-2682bb00f508538a6f737bd4013896541d6c9a46.tar.bz2
gentoo-2-2682bb00f508538a6f737bd4013896541d6c9a46.zip
Fix building with BerkDB 5.0 wrt #319421 by Diego E. Pettenò.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/apr-util/ChangeLog6
-rw-r--r--dev-libs/apr-util/apr-util-1.3.9.ebuild6
-rw-r--r--dev-libs/apr-util/files/apr-util-1.3.9-support_berkeley_db-5.0.patch162
3 files changed, 170 insertions, 4 deletions
diff --git a/dev-libs/apr-util/ChangeLog b/dev-libs/apr-util/ChangeLog
index dbd363ee9e7a..0bd145190065 100644
--- a/dev-libs/apr-util/ChangeLog
+++ b/dev-libs/apr-util/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/apr-util
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/ChangeLog,v 1.146 2010/06/17 20:11:16 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/ChangeLog,v 1.147 2010/07/14 10:06:40 ssuominen Exp $
+
+ 14 Jul 2010; Samuli Suominen <ssuominen@gentoo.org> apr-util-1.3.9.ebuild,
+ +files/apr-util-1.3.9-support_berkeley_db-5.0.patch:
+ Fix building with BerkDB 5.0 wrt #319421 by Diego E. Pettenò.
17 Jun 2010; Patrick Lauer <patrick@gentoo.org> apr-util-1.3.9.ebuild:
Migrating away from deprecated postgres virtuals
diff --git a/dev-libs/apr-util/apr-util-1.3.9.ebuild b/dev-libs/apr-util/apr-util-1.3.9.ebuild
index 55af09b717ef..5be51c77fd36 100644
--- a/dev-libs/apr-util/apr-util-1.3.9.ebuild
+++ b/dev-libs/apr-util/apr-util-1.3.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/apr-util-1.3.9.ebuild,v 1.13 2010/06/17 20:11:16 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/apr-util-1.3.9.ebuild,v 1.14 2010/07/14 10:06:40 ssuominen Exp $
EAPI="2"
@@ -22,7 +22,7 @@ RESTRICT="test"
RDEPEND="dev-libs/expat
>=dev-libs/apr-${APR_PV}:1
- berkdb? ( =sys-libs/db-4* )
+ berkdb? ( >=sys-libs/db-4 )
freetds? ( dev-db/freetds )
gdbm? ( sys-libs/gdbm )
ldap? ( =net-nds/openldap-2* )
@@ -35,7 +35,7 @@ DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )"
src_prepare() {
- epatch "${FILESDIR}/${P}-support_berkeley_db-4.8.patch"
+ epatch "${FILESDIR}"/${P}-support_berkeley_db-{4.8,5.0}.patch
eautoreconf
elibtoolize
diff --git a/dev-libs/apr-util/files/apr-util-1.3.9-support_berkeley_db-5.0.patch b/dev-libs/apr-util/files/apr-util-1.3.9-support_berkeley_db-5.0.patch
new file mode 100644
index 000000000000..e819c339fc02
--- /dev/null
+++ b/dev-libs/apr-util/files/apr-util-1.3.9-support_berkeley_db-5.0.patch
@@ -0,0 +1,162 @@
+http://bugs.gentoo.org/319421
+http://svn.apache.org/viewvc/apr/apr-util/branches/1.3.x/dbm/apr_dbm_berkeleydb.c?r1=719535&r2=938146&view=patch
+http://cvs.pld-linux.org/cgi-bin/cvsweb.cgi/~checkout~/packages/apr-util/apr-util-db.patch?rev=1.1;content-type=text%2Fplain
+
+--- build/dbm.m4
++++ build/dbm.m4
+@@ -112,7 +112,7 @@
+ changequote([,])
+ unset $cache_id
+ AC_CHECK_HEADER([$bdb_header], [
+- if test "$1" = "3" -o "$1" = "4"; then
++ if test "$1" = "3" -o "$1" = "4" -o "$1" = "5"; then
+ # We generate a separate cache variable for each prefix and libname
+ # we search under. That way, we avoid caching information that
+ # changes if the user runs `configure' with a different set of
+@@ -541,6 +541,26 @@
+ apu_db_version=4
+ fi
+ ])
++dnl
++dnl APU_CHECK_DB50: is DB5.0 present?
++dnl
++dnl if present: sets apu_db_header, apu_db_lib, and apu_db_version
++dnl
++dnl
++AC_DEFUN([APU_CHECK_DB50], [
++ places=$1
++ if test -z "$places"; then
++ places="std /usr/local/BerkeleyDB.5.0 /boot/home/config"
++ fi
++ APU_CHECK_BERKELEY_DB("5", "0", "-1",
++ "$places",
++ "db50/db.h db5/db.h db.h",
++ "db-5.0 db5-5.0 db50 db5 db"
++ )
++ if test "$apu_have_db" = "1"; then
++ apu_db_version=5
++ fi
++])
+
+ AC_DEFUN([APU_CHECK_DB], [
+ requested=$1
+@@ -631,6 +651,12 @@
+ AC_MSG_ERROR(Berkeley db4 not found)
+ fi
+ ;;
++ db50)
++ APU_CHECK_DB50("$check_places")
++ if test "$apu_db_version" != "5"; then
++ AC_MSG_ERROR(Berkeley db5 not found)
++ fi
++ ;;
+ default)
+ APU_CHECK_DB_ALL("$check_places")
+ ;;
+@@ -638,36 +664,39 @@
+ ])
+
+ dnl
+-dnl APU_CHECK_DB_ALL: Try all Berkeley DB versions, from 4.8 to 1.
++dnl APU_CHECK_DB_ALL: Try all Berkeley DB versions, from 5.0 to 1.
+ dnl
+ AC_DEFUN([APU_CHECK_DB_ALL], [
+ all_places=$1
+-
+- APU_CHECK_DB48("$all_places")
+- if test "$apu_db_version" != "4"; then
+- APU_CHECK_DB47("$all_places")
++
++ APU_CHECK_DB50("$all_places")
++ if test "$apu_db_version" != "5"; then
++ APU_CHECK_DB48("$all_places")
+ if test "$apu_db_version" != "4"; then
+- APU_CHECK_DB46("$all_places")
++ APU_CHECK_DB47("$all_places")
+ if test "$apu_db_version" != "4"; then
+- APU_CHECK_DB45("$all_places")
++ APU_CHECK_DB46("$all_places")
+ if test "$apu_db_version" != "4"; then
+- APU_CHECK_DB44("$all_places")
++ APU_CHECK_DB45("$all_places")
+ if test "$apu_db_version" != "4"; then
+- APU_CHECK_DB43("$all_places")
++ APU_CHECK_DB44("$all_places")
+ if test "$apu_db_version" != "4"; then
+- APU_CHECK_DB42("$all_places")
++ APU_CHECK_DB43("$all_places")
+ if test "$apu_db_version" != "4"; then
+- APU_CHECK_DB41("$all_places")
++ APU_CHECK_DB42("$all_places")
+ if test "$apu_db_version" != "4"; then
+- APU_CHECK_DB4("$all_places")
++ APU_CHECK_DB41("$all_places")
+ if test "$apu_db_version" != "4"; then
+- APU_CHECK_DB3("$all_places")
+- if test "$apu_db_version" != "3"; then
+- APU_CHECK_DB2("$all_places")
+- if test "$apu_db_version" != "2"; then
+- APU_CHECK_DB1("$all_places")
+- if test "$apu_db_version" != "1"; then
+- APU_CHECK_DB185("$all_places")
++ APU_CHECK_DB4("$all_places")
++ if test "$apu_db_version" != "4"; then
++ APU_CHECK_DB3("$all_places")
++ if test "$apu_db_version" != "3"; then
++ APU_CHECK_DB2("$all_places")
++ if test "$apu_db_version" != "2"; then
++ APU_CHECK_DB1("$all_places")
++ if test "$apu_db_version" != "1"; then
++ APU_CHECK_DB185("$all_places")
++ fi
+ fi
+ fi
+ fi
+@@ -707,7 +736,7 @@
+ apu_db_version=0
+
+ AC_ARG_WITH(dbm, [APR_HELP_STRING([--with-dbm=DBM], [choose the DBM type to use.
+- DBM={sdbm,gdbm,ndbm,db,db1,db185,db2,db3,db4,db41,db42,db43,db44,db45,db46,db47,db48}])],
++ DBM={sdbm,gdbm,ndbm,db,db1,db185,db2,db3,db4,db41,db42,db43,db44,db45,db46,db47,db48,db50}])],
+ [
+ if test "$withval" = "yes"; then
+ AC_MSG_ERROR([--with-dbm needs to specify a DBM type to use.
+@@ -914,6 +943,10 @@
+ apu_use_db=1
+ apu_default_dbm=db4
+ ;;
++ db50)
++ apu_use_db=1
++ apu_default_dbm=db5
++ ;;
+ default)
+ dnl ### use more sophisticated DBMs for the default?
+ apu_default_dbm="sdbm (default)"
+@@ -921,7 +954,7 @@
+ ;;
+ *)
+ AC_MSG_ERROR([--with-dbm=$look_for is an unknown DBM type.
+- Use one of: sdbm, gdbm, ndbm, db, db1, db185, db2, db3, db4, db41, db42, db43, db44, db45, db46, db47, db48])
++ Use one of: sdbm, gdbm, ndbm, db, db1, db185, db2, db3, db4, db41, db42, db43, db44, db45, db46, db47, db48, db50])
+ ;;
+ esac
+
+--- dbm/apr_dbm_berkeleydb.c
++++ dbm/apr_dbm_berkeleydb.c
+@@ -37,13 +37,13 @@
+ * DB_185, DB2, DB3, and DB4.
+ */
+
+-#if defined(DB_VERSION_MAJOR) && (DB_VERSION_MAJOR == 4)
++#if defined(DB_VERSION_MAJOR) && (DB_VERSION_MAJOR >= 4)
+ /* We will treat anything greater than 4.1 as DB4.
+ * We can treat 4.0 as DB3.
+ */
+-#if defined(DB_VERSION_MINOR) && (DB_VERSION_MINOR >= 1)
++#if DB_VERSION_MAJOR > 4 || (defined(DB_VERSION_MINOR) && (DB_VERSION_MINOR >= 1))
+ #define DB_VER 4
+-#else
++#elif DB_VERSION_MAJOR == 4
+ #define DB_VER 3
+ #endif
+ #elif defined(DB_VERSION_MAJOR) && (DB_VERSION_MAJOR == 3)