summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2008-12-14 11:56:46 +0000
committerAlin Năstac <mrness@gentoo.org>2008-12-14 11:56:46 +0000
commit2589ba363dc25c63fd6db13e7cc558297c06917d (patch)
tree225b629f387f2f0cd650cd1cf136ed6f8869e5f5 /dev-libs
parentVersion bump (diff)
downloadgentoo-2-2589ba363dc25c63fd6db13e7cc558297c06917d.tar.gz
gentoo-2-2589ba363dc25c63fd6db13e7cc558297c06917d.tar.bz2
gentoo-2-2589ba363dc25c63fd6db13e7cc558297c06917d.zip
Remove PACKAGE_* definitions from installed config.h (#192676).
(Portage version: 2.1.4.5)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/ace/ChangeLog7
-rw-r--r--dev-libs/ace/ace-5.6.5-r2.ebuild81
2 files changed, 87 insertions, 1 deletions
diff --git a/dev-libs/ace/ChangeLog b/dev-libs/ace/ChangeLog
index 40b9de64badd..c8f39194bc82 100644
--- a/dev-libs/ace/ChangeLog
+++ b/dev-libs/ace/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/ace
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/ace/ChangeLog,v 1.56 2008/11/04 13:36:07 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ace/ChangeLog,v 1.57 2008/12/14 11:56:46 mrness Exp $
+
+*ace-5.6.5-r2 (14 Dec 2008)
+
+ 14 Dec 2008; Alin Năstac <mrness@gentoo.org> +ace-5.6.5-r2.ebuild:
+ Remove PACKAGE_* definitions from installed config.h (#192676).
04 Nov 2008; Daniel Black <dragonheart@gentoo.org>
+files/ace-missing-refcountable-header.patch, ace-5.6.5-r1.ebuild:
diff --git a/dev-libs/ace/ace-5.6.5-r2.ebuild b/dev-libs/ace/ace-5.6.5-r2.ebuild
new file mode 100644
index 000000000000..7b3f580f7e28
--- /dev/null
+++ b/dev-libs/ace/ace-5.6.5-r2.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ace/ace-5.6.5-r2.ebuild,v 1.1 2008/12/14 11:56:46 mrness Exp $
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="The Adaptive Communications Environment"
+HOMEPAGE="http://www.cs.wustl.edu/~schmidt/ACE.html"
+SRC_URI="!tao? ( http://download.dre.vanderbilt.edu/previous_versions/ACE-${PV}.tar.bz2 )
+ tao? (
+ !ciao? ( http://download.dre.vanderbilt.edu/previous_versions/ACE+TAO-${PV}.tar.bz2 )
+ ciao? ( http://download.dre.vanderbilt.edu/previous_versions/ACE+TAO+CIAO-${PV}.tar.bz2 )
+ )"
+LICENSE="BSD as-is"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc ~alpha ~amd64"
+IUSE="X ipv6 tao ciao"
+
+COMMON_DEPEND="dev-libs/openssl"
+# TODO probably more
+RDEPEND="${COMMON_DEPEND}
+ X? ( x11-libs/libXt x11-libs/libXaw )"
+
+DEPEND="${COMMON_DEPEND}
+ X? ( x11-proto/xproto )"
+
+S="${WORKDIR}/ACE_wrappers"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/ace-missing-refcountable-header.patch
+}
+
+src_compile() {
+ export ACE_ROOT="${S}"
+ mkdir build
+ cd build
+
+ ECONF_SOURCE="${S}"
+ econf \
+ --enable-lib-all \
+ $(use_with X) \
+ $(use_enable ipv6) \
+ || die "econf died"
+ # --with-qos needs ACE_HAS_RAPI
+ emake static_libs=1 || die "emake failed"
+}
+
+src_install() {
+ cd build
+ emake ACE_ROOT="${S}" DESTDIR="${D}" install || die "failed to install"
+ insinto /usr/include/ace
+ doins \
+ "${S}/ace/Svc_Conf_Token_Table.h" \
+ "${S}/ace/Unbounded_Set_Ex.inl" \
+ "${S}/ace/Unbounded_Set_Ex.h" \
+ "${S}/ace/Unbounded_Set_Ex.cpp"
+ # punt gperf stuff
+ rm -rf "${D}/usr/bin" "${D}/usr/share"
+ # remove PACKAGE_* definitions from installed config.h (#192676)
+ sed -i -e "s:^[ \t]*#define[ \t]\+PACKAGE_.*$:/\* & \*/:g" "${D}/usr/include/ace/config.h"
+}
+
+src_test() {
+ cd "${S}/build"
+ emake ACE_ROOT="${S}" check || die "self test failed"
+}
+
+pkg_postinst() {
+
+ local CC_MACHINE=$($(tc-getCC) -dumpmachine)
+ if [ -d "/usr/$(get_libdir)/gcc-lib/${CC_MACHINE}/$(gcc-fullversion)/include/ace" ]; then
+ ewarn "moving /usr/$(get_libdir)/gcc-lib/${CC_MACHINE}/$(gcc-fullversion)/include/ace to"
+ ewarn "ace.old"
+ ewarn "This is required, as anything trying to compile against ACE will"
+ ewarn "have problems with conflicting OS.h files if this is not done."
+ mv "/usr/$(get_libdir)/gcc-lib/${CC_MACHINE}/$(gcc-fullversion)/include/ace" \
+ "/usr/$(get_libdir)/gcc-lib/${CC_MACHINE}/$(gcc-fullversion)/include/ace.old"
+ fi
+}