summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2014-07-02 05:51:34 +0000
committerYixun Lan <dlan@gentoo.org>2014-07-02 05:51:34 +0000
commit256d6966b989eeddbee1b695d9b41cb47d7589c0 (patch)
tree8f7ac2768ab3af0050a0a92c89490da4211b67a3 /dev-libs
parentold (diff)
downloadgentoo-2-256d6966b989eeddbee1b695d9b41cb47d7589c0.tar.gz
gentoo-2-256d6966b989eeddbee1b695d9b41cb47d7589c0.tar.bz2
gentoo-2-256d6966b989eeddbee1b695d9b41cb47d7589c0.zip
bump, fix bug #500490, thanks Johan Bergström
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xAABEFD55)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/uthash/ChangeLog9
-rw-r--r--dev-libs/uthash/uthash-1.9.9.ebuild33
2 files changed, 40 insertions, 2 deletions
diff --git a/dev-libs/uthash/ChangeLog b/dev-libs/uthash/ChangeLog
index 47b7c1c68c08..072feab2debc 100644
--- a/dev-libs/uthash/ChangeLog
+++ b/dev-libs/uthash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/uthash
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/uthash/ChangeLog,v 1.11 2013/06/26 17:08:12 blueness Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/uthash/ChangeLog,v 1.12 2014/07/02 05:51:34 dlan Exp $
+
+*uthash-1.9.9 (02 Jul 2014)
+
+ 02 Jul 2014; Yixun Lan <dlan@gentoo.org> +uthash-1.9.9.ebuild:
+ bump, fix bug #500490, thanks Johan Bergström
26 Jun 2013; Anthony G. Basile <blueness@gentoo.org> uthash-1.9.7.ebuild:
Keyword ~arm for bfgminer
diff --git a/dev-libs/uthash/uthash-1.9.9.ebuild b/dev-libs/uthash/uthash-1.9.9.ebuild
new file mode 100644
index 000000000000..2d44b8107dce
--- /dev/null
+++ b/dev-libs/uthash/uthash-1.9.9.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/uthash/uthash-1.9.9.ebuild,v 1.1 2014/07/02 05:51:34 dlan Exp $
+
+EAPI="5"
+
+inherit toolchain-funcs
+
+DESCRIPTION="An easy-to-use hash implementation for C programmers"
+HOMEPAGE="http://troydhanson.github.io/uthash/index.html"
+SRC_URI="https://github.com/troydhanson/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+DEPEND="sys-apps/sed
+ test? ( dev-lang/perl )"
+RDEPEND=""
+
+src_test() {
+ cd tests || die
+ sed -i "/CFLAGS/s/-O3/${CFLAGS}/" Makefile || die
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ insinto /usr/include
+ doins src/*.h
+
+ dodoc doc/{ChangeLog,todo,userguide,ut*}.txt
+}