summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-06-29 20:36:06 +0000
committerTim Harder <radhermit@gentoo.org>2013-06-29 20:36:06 +0000
commit1fbae8cf71d42d78de10eb7435386fa805722cc7 (patch)
treec95d4dab01f730c6faae52bc1e1c035cf1aabb82 /dev-libs
parentBlock <media-video/ffmpeg-1.2.1, which Handbrake 0.9.9 does not build against... (diff)
downloadgentoo-2-1fbae8cf71d42d78de10eb7435386fa805722cc7.tar.gz
gentoo-2-1fbae8cf71d42d78de10eb7435386fa805722cc7.tar.bz2
gentoo-2-1fbae8cf71d42d78de10eb7435386fa805722cc7.zip
Make python deps optional (bug #475242 by Diego Elio Pettenò).
(Portage version: 2.2.0_alpha184/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/protobuf/ChangeLog5
-rw-r--r--dev-libs/protobuf/protobuf-2.5.0.ebuild13
2 files changed, 12 insertions, 6 deletions
diff --git a/dev-libs/protobuf/ChangeLog b/dev-libs/protobuf/ChangeLog
index ec9a6b7ce3da..96a330850963 100644
--- a/dev-libs/protobuf/ChangeLog
+++ b/dev-libs/protobuf/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-libs/protobuf
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/protobuf/ChangeLog,v 1.48 2013/06/29 19:40:40 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/protobuf/ChangeLog,v 1.49 2013/06/29 20:36:06 radhermit Exp $
+
+ 29 Jun 2013; Tim Harder <radhermit@gentoo.org> protobuf-2.5.0.ebuild:
+ Make python deps optional (bug #475242 by Diego Elio Pettenò).
29 Jun 2013; Agostino Sarubbo <ago@gentoo.org> protobuf-2.4.1.ebuild:
Stable for ppc64, wrt bug #474922
diff --git a/dev-libs/protobuf/protobuf-2.5.0.ebuild b/dev-libs/protobuf/protobuf-2.5.0.ebuild
index 81c3fa359430..e7e78101ef37 100644
--- a/dev-libs/protobuf/protobuf-2.5.0.ebuild
+++ b/dev-libs/protobuf/protobuf-2.5.0.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/protobuf/protobuf-2.5.0.ebuild,v 1.2 2013/06/15 11:26:56 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/protobuf/protobuf-2.5.0.ebuild,v 1.3 2013/06/29 20:36:06 radhermit Exp $
EAPI=5
JAVA_PKG_IUSE="source"
PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+DISTUTILS_OPTIONAL=1
inherit autotools eutils distutils-r1 java-pkg-opt-2 elisp-common
@@ -17,10 +18,12 @@ SLOT="0/8" # subslot = soname major version
KEYWORDS="~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~x64-macos x86-macos"
IUSE="emacs examples java python static-libs vim-syntax"
-DEPEND="java? ( >=virtual/jdk-1.5 )
- emacs? ( virtual/emacs )"
-RDEPEND="java? ( >=virtual/jre-1.5 )
- emacs? ( virtual/emacs )"
+CDEPEND="emacs? ( virtual/emacs )
+ python? ( ${PYTHON_DEPS} )"
+DEPEND="${CDEPEND}
+ java? ( >=virtual/jdk-1.5 )"
+RDEPEND="${CDEPEND}
+ java? ( >=virtual/jre-1.5 )"
src_prepare() {
if [[ ${CHOST} != *-darwin* ]] ; then