summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2009-08-01 05:10:04 +0000
committerRyan Hill <dirtyepic@gentoo.org>2009-08-01 05:10:04 +0000
commit1d751757cb2e87a0ab837dca009ba37e6e8761af (patch)
tree070bc86511eb996ebf5f8aa2742b95f58463b9be /dev-libs
parentAdd toolchain to metadata.xml (diff)
downloadgentoo-2-1d751757cb2e87a0ab837dca009ba37e6e8761af.tar.gz
gentoo-2-1d751757cb2e87a0ab837dca009ba37e6e8761af.tar.bz2
gentoo-2-1d751757cb2e87a0ab837dca009ba37e6e8761af.zip
Move into main tree
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/mpc/ChangeLog19
-rw-r--r--dev-libs/mpc/files/mpc-0.6-fortify.patch50
-rw-r--r--dev-libs/mpc/metadata.xml9
-rw-r--r--dev-libs/mpc/mpc-0.6.ebuild31
4 files changed, 109 insertions, 0 deletions
diff --git a/dev-libs/mpc/ChangeLog b/dev-libs/mpc/ChangeLog
new file mode 100644
index 000000000000..9c75f39841dc
--- /dev/null
+++ b/dev-libs/mpc/ChangeLog
@@ -0,0 +1,19 @@
+# ChangeLog for dev-libs/mpc
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/mpc/ChangeLog,v 1.1 2009/08/01 05:10:04 dirtyepic Exp $
+
+ 01 Aug 2009; Ryan Hill <dirtyepic@gentoo.org> +mpc-0.6.ebuild,
+ +files/mpc-0.6-fortify.patch, +metadata.xml:
+ Move into main tree
+
+ 01 Aug 2009; Ryan Hill <dirtyepic@gentoo.org> mpc-0.6.ebuild,
+ +files/mpc-0.6-fortify.patch:
+ Fix testsuite failure w/ -D_FORTIFY_SOURCE=2.
+ Revert EAPI to 0 since this package will be a hard dependency of GCC 4.5.
+
+*mpc-0.6 (31 May 2009)
+
+ 31 May 2009; Ryan Hill <dirtyepic@gentoo.org> +mpc-0.6.ebuild,
+ +metadata.xml:
+ Initial import.
+
diff --git a/dev-libs/mpc/files/mpc-0.6-fortify.patch b/dev-libs/mpc/files/mpc-0.6-fortify.patch
new file mode 100644
index 000000000000..50582f765fba
--- /dev/null
+++ b/dev-libs/mpc/files/mpc-0.6-fortify.patch
@@ -0,0 +1,50 @@
+Fix testsuite failure w/ -D_FORTIFY_SOURCE=2
+http://lists.gforge.inria.fr/pipermail/mpc-discuss/2009-April/000404.html
+
+--- mpc-0.6-orig/src/inp_str.c
++++ mpc-0.6/src/inp_str.c
+@@ -1,6 +1,6 @@
+ /* mpc_inp_str -- Input a complex number from a given stream.
+
+-Copyright (C) 2009 Andreas Enge, Philippe Th\'eveny, Paul Zimmermann.
++Copyright (C) 2009 Andreas Enge, Philippe Th\'eveny, Paul Zimmermann
+
+ This file is part of the MPC Library.
+
+@@ -80,6 +80,7 @@ extract_string (FILE *stream)
+ size_t nread = 0;
+ size_t strsize = 100;
+ char *str = mpc_alloc_str (strsize);
++ size_t lenstr;
+
+ c = getc (stream);
+ while (c != EOF && c != '\n'
+@@ -101,6 +102,8 @@ extract_string (FILE *stream)
+ if (nread == 0)
+ return str;
+
++ lenstr = nread;
++
+ if (c == '(') {
+ size_t n;
+ char *suffix;
+@@ -127,7 +130,7 @@ extract_string (FILE *stream)
+ strsize = nread + 1;
+ }
+
+- n = sprintf (str, "%s(%s", str, suffix);
++ n = lenstr + sprintf (str + lenstr, "(%s", suffix);
+ MPC_ASSERT (n == nread);
+
+ c = getc (stream);
+@@ -151,7 +154,9 @@ extract_string (FILE *stream)
+
+
+ int
+-mpc_inp_str (mpc_ptr rop, FILE *stream, size_t *read, int base, mpc_rnd_t rnd_mode) {
++mpc_inp_str (mpc_ptr rop, FILE *stream, size_t *read, int base,
++mpc_rnd_t rnd_mode)
++{
+ size_t white, nread = 0;
+ int inex = -1;
+ int c;
diff --git a/dev-libs/mpc/metadata.xml b/dev-libs/mpc/metadata.xml
new file mode 100644
index 000000000000..f99a53352da7
--- /dev/null
+++ b/dev-libs/mpc/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>toolchain</herd>
+ <maintainer>
+ <email>dirtyepic@gentoo.org</email>
+ <name>Ryan Hill</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-libs/mpc/mpc-0.6.ebuild b/dev-libs/mpc/mpc-0.6.ebuild
new file mode 100644
index 000000000000..40c52a969503
--- /dev/null
+++ b/dev-libs/mpc/mpc-0.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/mpc/mpc-0.6.ebuild,v 1.1 2009/08/01 05:10:04 dirtyepic Exp $
+
+EAPI=0
+
+inherit eutils
+
+DESCRIPTION="A library for multiprecision complex arithmetic with exact rounding."
+HOMEPAGE="http://mpc.multiprecision.org/"
+SRC_URI="http://www.multiprecision.org/mpc/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=dev-libs/gmp-4.1.3
+ >=dev-libs/mpfr-2.3.1"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-fortify.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc "${S}"/{ChangeLog,NEWS,README,TODO}
+}