summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-01-13 23:39:07 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-01-13 23:39:07 +0000
commit192efedb45c0137791e5d04f59e60418659e5382 (patch)
tree4e6b41cc4c23a712d897e5505d4cd936b7de5d73 /dev-libs
parentRemove old (diff)
downloadgentoo-2-192efedb45c0137791e5d04f59e60418659e5382.tar.gz
gentoo-2-192efedb45c0137791e5d04f59e60418659e5382.tar.bz2
gentoo-2-192efedb45c0137791e5d04f59e60418659e5382.zip
Version bump; some of the patches have been merged in but we still have two to apply until next version.
(Portage version: 2.2.0_alpha15/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/opencryptoki/ChangeLog9
-rw-r--r--dev-libs/opencryptoki/opencryptoki-2.3.3.ebuild82
2 files changed, 90 insertions, 1 deletions
diff --git a/dev-libs/opencryptoki/ChangeLog b/dev-libs/opencryptoki/ChangeLog
index 75b50ebdf986..309712489c49 100644
--- a/dev-libs/opencryptoki/ChangeLog
+++ b/dev-libs/opencryptoki/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/opencryptoki
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/opencryptoki/ChangeLog,v 1.10 2011/01/07 22:53:33 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/opencryptoki/ChangeLog,v 1.11 2011/01/13 23:39:07 flameeyes Exp $
+
+*opencryptoki-2.3.3 (13 Jan 2011)
+
+ 13 Jan 2011; Diego E. Pettenò <flameeyes@gentoo.org>
+ +opencryptoki-2.3.3.ebuild:
+ Version bump; some of the patches have been merged in but we still have two
+ to apply until next version.
07 Jan 2011; Diego E. Pettenò <flameeyes@gentoo.org>
-files/opencryptoki-2.2.4.1-tpm_util.c.patch,
diff --git a/dev-libs/opencryptoki/opencryptoki-2.3.3.ebuild b/dev-libs/opencryptoki/opencryptoki-2.3.3.ebuild
new file mode 100644
index 000000000000..261b4138b5f8
--- /dev/null
+++ b/dev-libs/opencryptoki/opencryptoki-2.3.3.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/opencryptoki/opencryptoki-2.3.3.ebuild,v 1.1 2011/01/13 23:39:07 flameeyes Exp $
+
+EAPI="2"
+
+# backports are maintained as tags on Diego's repository on gitorious:
+# http://gitorious.org/~flameeyes/opencryptoki/flameeyess-opencryptoki
+BACKPORTS=1
+
+inherit autotools eutils multilib
+
+DESCRIPTION="PKCS#11 provider for IBM cryptographic hardware"
+HOMEPAGE="http://sourceforge.net/projects/opencryptoki"
+SRC_URI="mirror://sourceforge/opencryptoki/${P}.tar.bz2
+ ${BACKPORTS:+
+ http://dev.gentoo.org/~flameeyes/${PN}/${P}-backports-${BACKPORTS}.tar.bz2}"
+
+LICENSE="CPL-0.5"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="tpm? ( app-crypt/trousers )
+ dev-libs/openssl"
+DEPEND="${RDEPEND}"
+
+IUSE="+tpm debug"
+
+pkg_setup() {
+ enewgroup pkcs11
+}
+
+src_prepare() {
+ [[ -n ${BACKPORTS} ]] && \
+ EPATCH_MULTI_MSG="Applying backports patches #${BACKPORTS} ..." \
+ EPATCH_FORCE=yes EPATCH_SUFFIX="patch" EPATCH_SOURCE="${S}/patches" \
+ epatch
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-fast-install \
+ --disable-dependency-tracking \
+ $(use_enable debug) \
+ --enable-daemon \
+ --enable-library \
+ --disable-icatok \
+ --enable-swtok \
+ $(use_enable tpm tpmtok) \
+ --disable-icctok \
+ --disable-aeptok \
+ --disable-bcomtok \
+ --disable-crtok \
+ --disable-pkcscca_migrate
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+
+ # We replace their ld.so and init files (mostly designed for RedHat
+ # as far as I can tell) with our own replacements.
+ rm -rf "${D}"/etc/ld.so.conf.d "${D}"/etc/rc.d
+
+ # make sure that we don't modify the init script if the USE flags
+ # are enabled for the needed services.
+ sed -n \
+ $(use tpm || echo '-e /use tcsd/d') \
+ -e 'p' \
+ "${FILESDIR}/pkcsslotd.init.2" \
+ > "${T}"/pkcsslotd.init || die
+
+ newinitd "${T}/pkcsslotd.init" pkcsslotd
+
+ dodir /etc/env.d
+ cat - > "${D}"/etc/env.d/50${PN} <<EOF
+LDPATH=/usr/$(get_libdir)/opencryptoki:/usr/$(get_libdir)/opencryptoki/stdll
+EOF
+
+ dodoc README AUTHORS FAQ TODO doc/openCryptoki-HOWTO.pdf || die
+}