summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-06-29 18:42:07 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-06-29 18:42:07 +0000
commit18ee48d77f89a44408ee88e9c4c4da737e6d5ebd (patch)
treeb2f28924089da2235dde6b4aa141187bcf1850bc /dev-libs
parentFix building with -Wl,--as-needed wrt #313369 by Kacper Kowalik. (diff)
downloadgentoo-2-18ee48d77f89a44408ee88e9c4c4da737e6d5ebd.tar.gz
gentoo-2-18ee48d77f89a44408ee88e9c4c4da737e6d5ebd.tar.bz2
gentoo-2-18ee48d77f89a44408ee88e9c4c4da737e6d5ebd.zip
old, cleanup
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/log4cpp/files/0.3.5_rc3-namespace_semikolon.patch9
-rw-r--r--dev-libs/log4cpp/log4cpp-0.3.4b.ebuild43
-rw-r--r--dev-libs/log4cpp/log4cpp-0.3.5_rc3.ebuild52
-rw-r--r--dev-libs/log4cpp/log4cpp-1.0.ebuild32
4 files changed, 12 insertions, 124 deletions
diff --git a/dev-libs/log4cpp/files/0.3.5_rc3-namespace_semikolon.patch b/dev-libs/log4cpp/files/0.3.5_rc3-namespace_semikolon.patch
deleted file mode 100644
index b46e59fe2183..000000000000
--- a/dev-libs/log4cpp/files/0.3.5_rc3-namespace_semikolon.patch
+++ /dev/null
@@ -1,9 +0,0 @@
---- log4cpp-0.3.5rc3/include/log4cpp/Manipulator.hh.orig 2006-10-18 22:13:48.000000000 +0200
-+++ log4cpp-0.3.5rc3/include/log4cpp/Manipulator.hh 2006-10-18 22:13:52.000000000 +0200
-@@ -26,5 +26,5 @@
- inline tab(unsigned int i) : size(i) {}
- friend LOG4CPP_EXPORT std::ostream& operator<< (std::ostream& os, const tab& w);
- };
--};
-+}
- #endif
diff --git a/dev-libs/log4cpp/log4cpp-0.3.4b.ebuild b/dev-libs/log4cpp/log4cpp-0.3.4b.ebuild
deleted file mode 100644
index 52808192da8f..000000000000
--- a/dev-libs/log4cpp/log4cpp-0.3.4b.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/log4cpp/log4cpp-0.3.4b.ebuild,v 1.15 2006/10/18 16:57:47 dev-zero Exp $
-
-KEYWORDS="x86 ppc amd64 s390"
-
-DESCRIPTION="library of C++ classes for flexible logging to files, syslog, IDSA and other destinations"
-HOMEPAGE="http://log4cpp.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-LICENSE="LGPL-2.1"
-SLOT="0"
-IUSE="doc threads"
-
-DEPEND="doc? ( app-doc/doxygen )"
-RDEPEND=""
-
-src_unpack() {
- unpack ${A}
-
- # We have to fix it directly in Makefile.in to avoid
- # loosing configuration-options
- cd "${S}/doc"
- sed -i \
- -e 's#$(man3dir)#$(DESTDIR)/$(man3dir)#' \
- -e 's#$(docdir)#$(DESTDIR)/$(docdir)/html#' \
- -e 's#$(prefix)#$(datadir)#' \
- Makefile.in || die "sed failed"
-}
-
-src_compile() {
- econf \
- --without-omnithreads \
- --without-idsa \
- $(use_with threads pthreads) \
- $(use_enable doc doxygen) \
- || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog NEWS README THANKS TODO
-}
diff --git a/dev-libs/log4cpp/log4cpp-0.3.5_rc3.ebuild b/dev-libs/log4cpp/log4cpp-0.3.5_rc3.ebuild
deleted file mode 100644
index ca2c8e732506..000000000000
--- a/dev-libs/log4cpp/log4cpp-0.3.5_rc3.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/log4cpp/log4cpp-0.3.5_rc3.ebuild,v 1.1 2006/10/18 19:45:22 dev-zero Exp $
-
-inherit eutils
-
-KEYWORDS="~x86 ~ppc ~amd64 ~s390"
-
-MY_P=${P/_}
-
-DESCRIPTION="library of C++ classes for flexible logging to files, syslog, IDSA and other destinations"
-HOMEPAGE="http://log4cpp.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-LICENSE="LGPL-2.1"
-SLOT="0"
-IUSE="doc threads"
-
-DEPEND="doc? ( app-doc/doxygen )"
-RDEPEND=""
-
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
- unpack ${A}
-
- cd "${S}"
- epatch "${FILESDIR}/${PV}-namespace_semikolon.patch"
-
- # We have to fix it directly in Makefile.in to avoid
- # loosing configuration-options
- cd "${S}/doc"
- sed -i \
- -e 's#$(man3dir)#$(DESTDIR)/$(man3dir)#' \
- -e 's#$(docdir)#$(DESTDIR)/$(docdir)/html#' \
- -e "s#^docdir =.*#docdir = /usr/share/doc/${PF}#" \
- Makefile.in || die "sed failed"
-}
-
-src_compile() {
- econf \
- --without-omnithreads \
- --without-idsa \
- $(use_with threads pthreads) \
- $(use_enable doc doxygen) \
- || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog NEWS README THANKS TODO
-}
diff --git a/dev-libs/log4cpp/log4cpp-1.0.ebuild b/dev-libs/log4cpp/log4cpp-1.0.ebuild
index 15541ca2c36b..89f37205cc25 100644
--- a/dev-libs/log4cpp/log4cpp-1.0.ebuild
+++ b/dev-libs/log4cpp/log4cpp-1.0.ebuild
@@ -1,44 +1,36 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/log4cpp/log4cpp-1.0.ebuild,v 1.5 2008/12/07 12:08:21 vapier Exp $
-
-NEED_AUTOCONF="latest"
-NEED_AUTOMAKE="latest"
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/log4cpp/log4cpp-1.0.ebuild,v 1.6 2010/06/29 18:42:06 ssuominen Exp $
+EAPI=2
inherit autotools eutils
-KEYWORDS="amd64 ppc s390 x86"
-
DESCRIPTION="Library of C++ classes for flexible logging to files, syslog and other destinations."
HOMEPAGE="http://log4cpp.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
LICENSE="LGPL-2.1"
SLOT="0"
+KEYWORDS="amd64 ppc s390 x86"
IUSE="doc"
DEPEND="doc? ( app-doc/doxygen )"
RDEPEND=""
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}/${PV}-doc_install_path.patch" \
- "${FILESDIR}/${PV}-gcc43.patch"
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-doc_install_path.patch \
+ "${FILESDIR}"/${PV}-gcc43.patch
- AT_M4DIR=m4
- eautoreconf
+ AT_M4DIR="m4" eautoreconf
}
-src_compile() {
+src_configure() {
econf \
--without-idsa \
- $(use_enable doc doxygen) \
- || die "econf failed"
- emake || die "emake failed"
+ $(use_enable doc doxygen)
}
src_install () {
- emake DESTDIR="${D}" install || die "emake install failed"
+ emake DESTDIR="${D}" install || die
dodoc AUTHORS ChangeLog NEWS README THANKS TODO
}