summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-03-17 08:48:25 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-03-17 08:48:25 +0000
commit0983e758fadb867cc6a227ed1c94d3319e921bec (patch)
treef2c6e4494237c091701eb94f9ce568df5dbfda25 /dev-libs
parentRemove old. (diff)
downloadgentoo-2-0983e758fadb867cc6a227ed1c94d3319e921bec.tar.gz
gentoo-2-0983e758fadb867cc6a227ed1c94d3319e921bec.tar.bz2
gentoo-2-0983e758fadb867cc6a227ed1c94d3319e921bec.zip
Version bump wrt #394763 by Michael Cordingley. This will fix building with GCC >= 4.6.0 wrt #364779 by Diego Elio Pettenò.
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/quantlib/ChangeLog10
-rw-r--r--dev-libs/quantlib/quantlib-1.2.ebuild83
2 files changed, 91 insertions, 2 deletions
diff --git a/dev-libs/quantlib/ChangeLog b/dev-libs/quantlib/ChangeLog
index d9c88713c10d..c1de8d93da70 100644
--- a/dev-libs/quantlib/ChangeLog
+++ b/dev-libs/quantlib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/quantlib
-# Copyright 2002-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/quantlib/ChangeLog,v 1.34 2011/11/22 17:51:14 pacho Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/quantlib/ChangeLog,v 1.35 2012/03/17 08:48:25 ssuominen Exp $
+
+*quantlib-1.2 (17 Mar 2012)
+
+ 17 Mar 2012; Samuli Suominen <ssuominen@gentoo.org> +quantlib-1.2.ebuild:
+ Version bump wrt #394763 by Michael Cordingley. This will fix building with
+ GCC >= 4.6.0 wrt #364779 by Diego Elio Pettenò.
22 Nov 2011; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Drop maintainer due retirement, bug #82110
diff --git a/dev-libs/quantlib/quantlib-1.2.ebuild b/dev-libs/quantlib/quantlib-1.2.ebuild
new file mode 100644
index 000000000000..e5f15be1d047
--- /dev/null
+++ b/dev-libs/quantlib/quantlib-1.2.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/quantlib/quantlib-1.2.ebuild,v 1.1 2012/03/17 08:48:25 ssuominen Exp $
+
+EAPI=4
+inherit elisp-common
+
+MY_P=QuantLib-${PV}
+
+DESCRIPTION="A comprehensive software framework for quantitative finance"
+HOMEPAGE="http://quantlib.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="doc emacs examples static-libs"
+
+RDEPEND="dev-libs/boost"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ emacs? ( virtual/emacs )"
+
+DOCS="*.txt"
+
+SITEFILE=50${PN}-gentoo.el
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ # NOTE: Too fragile for single .pdf or .ps document
+ local prog
+ for prog in DVIPS LATEX MAKEINDEX PDFLATEX; do
+ export ac_cv_path_${prog}=no
+ done
+
+ use doc || export ac_cv_path_DOXYGEN=no
+ use emacs || export ac_cv_prog_EMACS=no
+
+ # NOTE: --enable-examples will only change noinst_PROGRAMS to bin_PROGRAMS
+ econf \
+ $(use_enable static-libs static) \
+ --enable-examples \
+ --with-lispdir="${SITELISP}"/${PN}
+}
+
+src_compile() {
+ emake
+
+ if use doc; then
+ pushd Docs >/dev/null
+ nonfatal emake docs-html
+ popd >/dev/null
+ fi
+}
+
+src_install(){
+ default
+
+ rm -f "${ED}"/usr/lib*/*.la
+
+ if use doc; then
+ find Docs \( -name '.time-stamp*' -o -name '*.doxy' -o -name 'Makefile*' \) -delete
+ insinto /usr/share/doc/${PF}
+ nonfatal doins -r Docs
+ fi
+
+ if use examples; then
+ find Examples \( -name '*vc*proj*' -o -name '*.dev' -o -name 'Makefile*' -o -name '.libs' -o -name '*.o' \) -delete
+ insinto /usr/share/doc/${PF}
+ nonfatal doins -r Examples
+ fi
+
+ use emacs && elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}