summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-04-24 16:31:43 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-04-24 16:31:43 +0000
commit091541ec548ebbd0947f22f6e5c8ceba26d0e7bf (patch)
tree63c94dcf6903c6cab0eb2eee215d454d5e60077b /dev-libs
parentDrop keywords on hppa/mips w.r.t. KEYWORDREQ bug 364693 (diff)
downloadgentoo-2-091541ec548ebbd0947f22f6e5c8ceba26d0e7bf.tar.gz
gentoo-2-091541ec548ebbd0947f22f6e5c8ceba26d0e7bf.tar.bz2
gentoo-2-091541ec548ebbd0947f22f6e5c8ceba26d0e7bf.zip
Drop keywords on hppa/mips w.r.t. KEYWORDREQ bug 364693
(Portage version: 2.1.9.46/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/atk/ChangeLog7
-rw-r--r--dev-libs/atk/atk-1.32.0-r1.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-libs/atk/ChangeLog b/dev-libs/atk/ChangeLog
index 2e2880e53d51..e88a2ec364ba 100644
--- a/dev-libs/atk/ChangeLog
+++ b/dev-libs/atk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/atk
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/atk/ChangeLog,v 1.217 2011/04/07 14:15:29 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/atk/ChangeLog,v 1.218 2011/04/24 16:31:43 nirbheek Exp $
+
+*atk-1.32.0-r1 (24 Apr 2011)
+
+ 24 Apr 2011; Nirbheek Chauhan <nirbheek@gentoo.org> +atk-1.32.0-r1.ebuild:
+ Drop keywords on hppa/mips w.r.t. KEYWORDREQ bug 364693
07 Apr 2011; Gilles Dartiguelongue <eva@gentoo.org> -atk-1.28.0.ebuild,
-atk-1.30.0.ebuild:
diff --git a/dev-libs/atk/atk-1.32.0-r1.ebuild b/dev-libs/atk/atk-1.32.0-r1.ebuild
new file mode 100644
index 000000000000..8c6f632e1ab1
--- /dev/null
+++ b/dev-libs/atk/atk-1.32.0-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/atk/atk-1.32.0-r1.ebuild,v 1.1 2011/04/24 16:31:43 nirbheek Exp $
+
+EAPI="3"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="GTK+ & GNOME Accessibility Toolkit"
+HOMEPAGE="http://projects.gnome.org/accessibility/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE="doc +introspection nls"
+
+RDEPEND="dev-libs/glib:2
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7 )"
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5
+ dev-util/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1 )
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ G2CONF="${G2CONF} $(use_enable introspection)"
+ DOCS="AUTHORS ChangeLog NEWS README"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ if ! use test; then
+ # don't waste time building tests (bug #226353)
+ sed 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' -i Makefile.am Makefile.in \
+ || die "sed failed"
+ fi
+
+ # Remove DEPRECATED flags
+ sed -e '/-D[A-Z_]*DISABLE_DEPRECATED/d' -i atk/Makefile.am atk/Makefile.in \
+ tests/Makefile.am tests/Makefile.in || die "sed 2 failed"
+}