summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-07-08 12:08:05 +0000
committerPacho Ramos <pacho@gentoo.org>2012-07-08 12:08:05 +0000
commit058e402ffe10c6c4f16d4344814817a58cfe2c27 (patch)
treee42916b7b51b6ac210ca1aa666b943ae7c64acc7 /dev-libs
parentVersion bump. (diff)
downloadgentoo-2-058e402ffe10c6c4f16d4344814817a58cfe2c27.tar.gz
gentoo-2-058e402ffe10c6c4f16d4344814817a58cfe2c27.tar.bz2
gentoo-2-058e402ffe10c6c4f16d4344814817a58cfe2c27.zip
Version bump.
(Portage version: 2.1.11.5/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/librep/ChangeLog7
-rw-r--r--dev-libs/librep/librep-0.92.2.1.ebuild67
2 files changed, 73 insertions, 1 deletions
diff --git a/dev-libs/librep/ChangeLog b/dev-libs/librep/ChangeLog
index bdd1d4d7e52e..07d03d31fbd1 100644
--- a/dev-libs/librep/ChangeLog
+++ b/dev-libs/librep/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/librep
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/librep/ChangeLog,v 1.70 2012/05/24 13:42:27 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/librep/ChangeLog,v 1.71 2012/07/08 12:08:05 pacho Exp $
+
+*librep-0.92.2.1 (08 Jul 2012)
+
+ 08 Jul 2012; Pacho Ramos <pacho@gentoo.org> +librep-0.92.2.1.ebuild:
+ Version bump.
24 May 2012; Samuli Suominen <ssuominen@gentoo.org> librep-0.92.2.ebuild:
ppc/ppc64 stable wrt #410611
diff --git a/dev-libs/librep/librep-0.92.2.1.ebuild b/dev-libs/librep/librep-0.92.2.1.ebuild
new file mode 100644
index 000000000000..7c92827dd630
--- /dev/null
+++ b/dev-libs/librep/librep-0.92.2.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/librep/librep-0.92.2.1.ebuild,v 1.1 2012/07/08 12:08:05 pacho Exp $
+
+EAPI="4"
+
+inherit eutils multilib elisp-common
+
+DESCRIPTION="Shared library implementing a Lisp dialect"
+HOMEPAGE="http://librep.sourceforge.net/"
+SRC_URI="http://download.tuxfamily.org/librep/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="emacs readline"
+
+RDEPEND=">=sys-libs/gdbm-1.8.0
+ emacs? ( virtual/emacs )
+ readline? ( sys-libs/readline )"
+DEPEND="${RDEPEND}
+ sys-apps/texinfo
+ app-arch/xz-utils"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.92.0-disable-elisp.patch
+}
+
+src_configure() {
+ econf \
+ --libexecdir=/usr/$(get_libdir) \
+ --without-gmp \
+ --without-ffi \
+ --disable-static \
+ $(use_with readline)
+}
+
+src_compile() {
+ emake
+
+ if use emacs; then
+ elisp-compile rep-debugger.el || die "elisp-compile failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ find "${D}" -name '*.la' -exec rm -f {} + || die "la file removal failed"
+
+ dodoc ChangeLog MAINTAINERS NEWS README TODO
+ docinto doc
+ dodoc doc/*
+
+ if use emacs; then
+ elisp-install ${PN} rep-debugger.{el,elc} || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/50${PN}-gentoo.el" \
+ || die "elisp-site-file-install failed"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}