summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-11-06 00:17:14 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-11-06 00:17:14 +0000
commit02747c001f764c45c2f05972879a0cf8710cf370 (patch)
treeb53d1a25ee091e08e971dd62a1607229893a899e /dev-libs
parentnew version (diff)
downloadgentoo-2-02747c001f764c45c2f05972879a0cf8710cf370.tar.gz
gentoo-2-02747c001f764c45c2f05972879a0cf8710cf370.tar.bz2
gentoo-2-02747c001f764c45c2f05972879a0cf8710cf370.zip
Added GNU Portable Threads
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/pth/files/digest-pth-1.4.01
-rw-r--r--dev-libs/pth/pth-1.4.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/pth/files/digest-pth-1.4.0 b/dev-libs/pth/files/digest-pth-1.4.0
new file mode 100644
index 000000000000..61b66a9aa1dc
--- /dev/null
+++ b/dev-libs/pth/files/digest-pth-1.4.0
@@ -0,0 +1 @@
+MD5 146314a4c90067f20bc807e0e261fc31 pth-1.4.0.tar.gz 446464
diff --git a/dev-libs/pth/pth-1.4.0.ebuild b/dev-libs/pth/pth-1.4.0.ebuild
new file mode 100644
index 000000000000..6cb8c1064aec
--- /dev/null
+++ b/dev-libs/pth/pth-1.4.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Mikael Hallendal <hallski@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/pth/pth-1.4.0.ebuild,v 1.1 2001/11/06 00:17:14 hallski Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="GNU Portable Threads"
+SRC_URI="ftp://ftp.gnu.org/gnu/pth/pth-1.4.0.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/pth/"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ assert
+
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ dodoc ANNOUNCE AUTHORS COPYING ChangeLog NEWS README THANKS USERS
+}
+
+
+
+
+
+
+