summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2012-06-23 11:48:56 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2012-06-23 11:48:56 +0000
commit042af7d6affc5187177a19395f087dbef1da745e (patch)
tree0f950f0cf752fb6243e2dc6599c602c285596c0a /dev-libs/zthread
parentVersion bump, remove old. (diff)
downloadgentoo-2-042af7d6affc5187177a19395f087dbef1da745e.tar.gz
gentoo-2-042af7d6affc5187177a19395f087dbef1da745e.tar.bz2
gentoo-2-042af7d6affc5187177a19395f087dbef1da745e.zip
Fix building with gcc4.7 wrt #414133 by David Kredba <nheghathivhistha@gmail.com>
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/zthread')
-rw-r--r--dev-libs/zthread/ChangeLog7
-rw-r--r--dev-libs/zthread/files/zthread-2.3.2-gcc47.patch25
-rw-r--r--dev-libs/zthread/zthread-2.3.2-r2.ebuild3
3 files changed, 33 insertions, 2 deletions
diff --git a/dev-libs/zthread/ChangeLog b/dev-libs/zthread/ChangeLog
index 6c3506b8d980..f6a49626c1e5 100644
--- a/dev-libs/zthread/ChangeLog
+++ b/dev-libs/zthread/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/zthread
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/zthread/ChangeLog,v 1.31 2012/01/13 03:23:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/zthread/ChangeLog,v 1.32 2012/06/23 11:48:56 xarthisius Exp $
+
+ 23 Jun 2012; Kacper Kowalik <xarthisius.kk@gmail.com>
+ +files/zthread-2.3.2-gcc47.patch, zthread-2.3.2-r2.ebuild:
+ Fix building with gcc4.7 wrt #414133 by David Kredba
+ <nheghathivhistha@gmail.com>
*zthread-2.3.2-r2 (13 Jan 2012)
diff --git a/dev-libs/zthread/files/zthread-2.3.2-gcc47.patch b/dev-libs/zthread/files/zthread-2.3.2-gcc47.patch
new file mode 100644
index 000000000000..57b122d22c5f
--- /dev/null
+++ b/dev-libs/zthread/files/zthread-2.3.2-gcc47.patch
@@ -0,0 +1,25 @@
+Description: Make sure to use qualified lookups.
+http://bugs.debian.org/667430
+https://bugs.gentoo.org/show_bug.cgi?id=414133
+
+Author: Cyril Brulebois <kibi@debian.org>
+--- a/include/zthread/Guard.h
++++ b/include/zthread/Guard.h
+@@ -428,7 +428,7 @@
+ template <class U, class V>
+ Guard(Guard<U, V>& g) : LockHolder<LockType>(g) {
+
+- LockingPolicy::shareScope(*this, extract(g));
++ LockingPolicy::shareScope(*this, this->extract(g));
+
+ }
+
+@@ -458,7 +458,7 @@
+ template <class U, class V>
+ Guard(Guard<U, V>& g, LockType& lock) : LockHolder<LockType>(lock) {
+
+- LockingPolicy::transferScope(*this, extract(g));
++ LockingPolicy::transferScope(*this, this->extract(g));
+
+ }
+
diff --git a/dev-libs/zthread/zthread-2.3.2-r2.ebuild b/dev-libs/zthread/zthread-2.3.2-r2.ebuild
index b531b620503f..143eff7ddcf4 100644
--- a/dev-libs/zthread/zthread-2.3.2-r2.ebuild
+++ b/dev-libs/zthread/zthread-2.3.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/zthread/zthread-2.3.2-r2.ebuild,v 1.1 2012/01/13 03:23:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/zthread/zthread-2.3.2-r2.ebuild,v 1.2 2012/06/23 11:48:56 xarthisius Exp $
EAPI="4"
@@ -26,6 +26,7 @@ src_prepare() {
epatch "${FILESDIR}"/${P}-no-fpermissive.diff
epatch "${FILESDIR}"/${P}-m4-quote.patch
epatch "${FILESDIR}"/${P}-automake.patch
+ epatch "${FILESDIR}"/${P}-gcc47.patch
AT_M4DIR="share" eautoreconf
}