summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-07-19 20:48:38 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-07-19 20:48:38 +0000
commitf6c55a8ea3bec24b25dc11629fb37c325b224ffa (patch)
treee85efde1c8e6bd11e8e08eb2320c3c77f24f702d /dev-libs/yaz++/yaz++-0.9.ebuild
parentStable on alpha. (diff)
downloadgentoo-2-f6c55a8ea3bec24b25dc11629fb37c325b224ffa.tar.gz
gentoo-2-f6c55a8ea3bec24b25dc11629fb37c325b224ffa.tar.bz2
gentoo-2-f6c55a8ea3bec24b25dc11629fb37c325b224ffa.zip
Initial commit. Based on ebuild submitted by Paul Berens <pjb8774@rit.edu>, bug #97767.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'dev-libs/yaz++/yaz++-0.9.ebuild')
-rw-r--r--dev-libs/yaz++/yaz++-0.9.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-libs/yaz++/yaz++-0.9.ebuild b/dev-libs/yaz++/yaz++-0.9.ebuild
new file mode 100644
index 000000000000..891a142a33de
--- /dev/null
+++ b/dev-libs/yaz++/yaz++-0.9.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/yaz++/yaz++-0.9.ebuild,v 1.1 2005/07/19 20:48:38 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="C++ addon for the yaz development libraries"
+HOMEPAGE="http://www.indexdata.dk/yazplusplus"
+SRC_URI="http://ftp.indexdata.dk/pub/${PN}/${P}.tar.gz"
+
+LICENSE="YAZ"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+RDEPEND="dev-libs/yaz"
+DEPEND="${RDEPEND}
+ sys-devel/autoconf"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ autoconf || die "autoconf failed"
+}
+
+src_compile() {
+ econf --enable-shared || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ #einstall || die "einstall failed"
+ make DESTDIR="${D}" docdir="/usr/share/doc/${PF}" install || die "make install failed"
+}