summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2008-01-17 19:33:13 +0000
committerRyan Hill <dirtyepic@gentoo.org>2008-01-17 19:33:13 +0000
commit52d1ac2ea870cc5b88da9c783c8ba2209a9fb76a (patch)
tree2298c0a5d020bb0d56e0d39a473802b2f223b6c1 /dev-libs/xxl
parentold (diff)
downloadgentoo-2-52d1ac2ea870cc5b88da9c783c8ba2209a9fb76a.tar.gz
gentoo-2-52d1ac2ea870cc5b88da9c783c8ba2209a9fb76a.tar.bz2
gentoo-2-52d1ac2ea870cc5b88da9c783c8ba2209a9fb76a.zip
Add patch by Grigory Dorokhov fixing test failure and adding support for
more than two nested try blocks. Bug #165558. (Portage version: 2.1.4)
Diffstat (limited to 'dev-libs/xxl')
-rw-r--r--dev-libs/xxl/ChangeLog9
-rw-r--r--dev-libs/xxl/files/xxl-1.0.1-nested-exception.patch12
-rw-r--r--dev-libs/xxl/xxl-1.0.1.ebuild13
3 files changed, 30 insertions, 4 deletions
diff --git a/dev-libs/xxl/ChangeLog b/dev-libs/xxl/ChangeLog
index ce971f556fce..2eedf47e2cc1 100644
--- a/dev-libs/xxl/ChangeLog
+++ b/dev-libs/xxl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/xxl
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xxl/ChangeLog,v 1.7 2007/03/19 00:56:19 kloeri Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xxl/ChangeLog,v 1.8 2008/01/17 19:33:12 dirtyepic Exp $
+
+ 17 Jan 2008; Ryan Hill <dirtyepic@gentoo.org>
+ +files/xxl-1.0.1-nested-exception.patch, xxl-1.0.1.ebuild:
+ Add patch by Grigory Dorokhov fixing test failure and adding support for
+ more than two nested try blocks. Bug #165558.
19 Mar 2007; Bryan Østergaard <kloeri@gentoo.org> metadata.xml:
Remove ka0ttic from metadata.xml due to retirement.
diff --git a/dev-libs/xxl/files/xxl-1.0.1-nested-exception.patch b/dev-libs/xxl/files/xxl-1.0.1-nested-exception.patch
new file mode 100644
index 000000000000..c6d52c5a09d4
--- /dev/null
+++ b/dev-libs/xxl/files/xxl-1.0.1-nested-exception.patch
@@ -0,0 +1,12 @@
+diff -Naur xxl-1.0.1-orig/xxl.c xxl-1.0.1/xxl.c
+--- xxl-1.0.1-orig/xxl.c 2004-12-22 03:42:52.000000000 -0600
++++ xxl-1.0.1/xxl.c 2008-01-17 13:25:18.000000000 -0600
+@@ -380,6 +380,8 @@
+ if (!tsd->contexts)
+ die("XXL: Exception thrown with no handler to catch it!\n");
+ tsd->contexts->exception = *exception;
++ how=XXL_SETJMP_TRY;
++ tsd->contexts->state |= XXL_STATE_THROWN;
+ xxl_leave_handler(how);
+ return;
+ }
diff --git a/dev-libs/xxl/xxl-1.0.1.ebuild b/dev-libs/xxl/xxl-1.0.1.ebuild
index 572733489cd4..e08f71afd6b1 100644
--- a/dev-libs/xxl/xxl-1.0.1.ebuild
+++ b/dev-libs/xxl/xxl-1.0.1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xxl/xxl-1.0.1.ebuild,v 1.3 2007/11/17 23:06:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xxl/xxl-1.0.1.ebuild,v 1.4 2008/01/17 19:33:12 dirtyepic Exp $
+
+inherit eutils
DESCRIPTION="C/C++ library that provides exception handling and asset management"
HOMEPAGE="http://www.zork.org/xxl/"
@@ -11,6 +13,13 @@ SLOT="0"
KEYWORDS="x86"
IUSE=""
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-nested-exception.patch
+}
+
src_install() {
emake DESTDIR="${D}" install || die "make install failed"
dodoc README