summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-03-16 09:09:51 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-03-16 09:09:51 +0000
commitb63b594e90a1efd4f77a6f315457f856dc4759d9 (patch)
tree846e8c124749b184b1a0137f5f0e6549abee3c90 /dev-libs/xapian
parentmigration revbump (diff)
downloadgentoo-2-b63b594e90a1efd4f77a6f315457f856dc4759d9.tar.gz
gentoo-2-b63b594e90a1efd4f77a6f315457f856dc4759d9.tar.bz2
gentoo-2-b63b594e90a1efd4f77a6f315457f856dc4759d9.zip
Version bump
(Portage version: 2.1.11.52/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'dev-libs/xapian')
-rw-r--r--dev-libs/xapian/ChangeLog7
-rw-r--r--dev-libs/xapian/xapian-1.2.14.ebuild63
2 files changed, 69 insertions, 1 deletions
diff --git a/dev-libs/xapian/ChangeLog b/dev-libs/xapian/ChangeLog
index 8bc6850233b6..ce1ffac86f87 100644
--- a/dev-libs/xapian/ChangeLog
+++ b/dev-libs/xapian/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/xapian
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xapian/ChangeLog,v 1.97 2013/02/15 22:02:33 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xapian/ChangeLog,v 1.98 2013/03/16 09:09:51 blueness Exp $
+
+*xapian-1.2.14 (16 Mar 2013)
+
+ 16 Mar 2013; Anthony G. Basile <blueness@gentoo.org> +xapian-1.2.14.ebuild:
+ Version bump
15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> xapian-1.2.13.ebuild:
Stable for arm, wrt bug #457296
diff --git a/dev-libs/xapian/xapian-1.2.14.ebuild b/dev-libs/xapian/xapian-1.2.14.ebuild
new file mode 100644
index 000000000000..e3546027d608
--- /dev/null
+++ b/dev-libs/xapian/xapian-1.2.14.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xapian/xapian-1.2.14.ebuild,v 1.1 2013/03/16 09:09:51 blueness Exp $
+
+EAPI="5"
+
+MY_P="${PN}-core-${PV}"
+
+DESCRIPTION="Xapian Probabilistic Information Retrieval library"
+HOMEPAGE="http://www.xapian.org/"
+SRC_URI="http://oligarchy.co.uk/xapian/${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc static-libs -sse +sse2 +brass +chert +inmemory"
+
+DEPEND="sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ local myconf=""
+
+ ewarn
+ if use sse2; then
+ ewarn "Using sse2"
+ myconf="${myconf} --enable-sse=sse2"
+ else
+ if use sse; then
+ ewarn "Using sse"
+ myconf="${myconf} --enable-sse=sse"
+ else
+ ewarn "Disabling sse and sse2"
+ myconf="${myconf} --disable-sse"
+ fi
+ fi
+ ewarn
+
+ myconf="${myconf} $(use_enable static-libs static)"
+
+ use brass || myconf="${myconf} --disable-backend-brass"
+ use chert || myconf="${myconf} --disable-backend-chert"
+ use inmemory || myconf="${myconf} --disable-backend-inmemory"
+
+ myconf="${myconf} --enable-backend-flint --enable-backend-remote"
+
+ econf $myconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ mv "${D}usr/share/doc/xapian-core" "${D}usr/share/doc/${PF}"
+ use doc || rm -rf "${D}usr/share/doc/${PF}"
+
+ dodoc AUTHORS HACKING PLATFORMS README NEWS
+}
+
+src_test() {
+ emake check VALGRIND=
+}