summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2013-12-20 20:51:04 +0000
committerSebastian Pipping <sping@gentoo.org>2013-12-20 20:51:04 +0000
commit0e0a2c8e62c485cc55655209514c6b1be4aedd57 (patch)
tree642f2ac2c1ab231883180354d5653ee5f62e0798 /dev-libs/uriparser
parentBump (diff)
downloadgentoo-2-0e0a2c8e62c485cc55655209514c6b1be4aedd57.tar.gz
gentoo-2-0e0a2c8e62c485cc55655209514c6b1be4aedd57.tar.bz2
gentoo-2-0e0a2c8e62c485cc55655209514c6b1be4aedd57.zip
dev-libs/uriparser: 0.8.0
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x401A1600)
Diffstat (limited to 'dev-libs/uriparser')
-rw-r--r--dev-libs/uriparser/ChangeLog7
-rw-r--r--dev-libs/uriparser/uriparser-0.8.0.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-libs/uriparser/ChangeLog b/dev-libs/uriparser/ChangeLog
index d54926368ed0..95b40386635b 100644
--- a/dev-libs/uriparser/ChangeLog
+++ b/dev-libs/uriparser/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/uriparser
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/uriparser/ChangeLog,v 1.40 2013/08/24 19:54:09 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/uriparser/ChangeLog,v 1.41 2013/12/20 20:51:04 sping Exp $
+
+*uriparser-0.8.0 (20 Dec 2013)
+
+ 20 Dec 2013; Sebastian Pipping <sping@gentoo.org> +uriparser-0.8.0.ebuild:
+ Bump to 0.8.0
*uriparser-0.7.9 (24 Aug 2013)
diff --git a/dev-libs/uriparser/uriparser-0.8.0.ebuild b/dev-libs/uriparser/uriparser-0.8.0.ebuild
new file mode 100644
index 000000000000..4cf4c996f5a4
--- /dev/null
+++ b/dev-libs/uriparser/uriparser-0.8.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/uriparser/uriparser-0.8.0.ebuild,v 1.1 2013/12/20 20:51:04 sping Exp $
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="Uriparser is a strictly RFC 3986 compliant URI parsing library in C"
+HOMEPAGE="http://uriparser.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="doc qt4 test unicode"
+
+RDEPEND=""
+DEPEND="virtual/pkgconfig
+ doc? ( >=app-doc/doxygen-1.5.8
+ qt4? ( dev-qt/qthelp:4 ) )
+ test? ( >=dev-util/cpptest-1.1.1 )"
+
+REQUIRED_USE="test? ( unicode )"
+
+src_configure() {
+ econf \
+ --disable-sizedown \
+ $(use_enable test) \
+ --enable-char \
+ $(use_enable unicode wchar_t) \
+ $(use_enable doc) \
+ --disable-dependency-tracking \
+ --docdir=/usr/share/doc/${PF}/
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog THANKS doc/*.txt || die
+
+ if use doc && use qt4; then
+ insinto /usr/share/doc/${PF}/
+ doins doc/*.qch || die # Using doins to avoid dodoc's compression
+ fi
+}