summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2010-05-12 14:13:01 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2010-05-12 14:13:01 +0000
commit01b8037e92f91339b195592773a5cf43ee5e4744 (patch)
tree82990c93bf3db1633d42a1479d79929446b68e24 /dev-libs/udis86/files
parentnew snapshot (diff)
downloadgentoo-2-01b8037e92f91339b195592773a5cf43ee5e4744.tar.gz
gentoo-2-01b8037e92f91339b195592773a5cf43ee5e4744.tar.bz2
gentoo-2-01b8037e92f91339b195592773a5cf43ee5e4744.zip
Don't fail tests if dev-lang/yasm is not installed, bug #318805
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/udis86/files')
-rw-r--r--dev-libs/udis86/files/udis86-1.7-yasm.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-libs/udis86/files/udis86-1.7-yasm.patch b/dev-libs/udis86/files/udis86-1.7-yasm.patch
new file mode 100644
index 000000000000..3d3eecdf8283
--- /dev/null
+++ b/dev-libs/udis86/files/udis86-1.7-yasm.patch
@@ -0,0 +1,35 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -25,6 +25,9 @@
+ AC_DISABLE_SHARED
+ AC_PROG_LIBTOOL
+
++AC_PATH_PROG([YASM], yasm,)
++AC_SUBST(YASM)
++
+ # If this is a gnu compiler, pass -Wall
+ if test "$ac_cv_c_compiler_gnu" = "yes"; then
+ CFLAGS="$CFLAGS -Wall"
+--- a/tests/Makefile.am
++++ b/tests/Makefile.am
+@@ -10,7 +10,7 @@
+ ovrrun_LDADD = ../libudis86/libudis86.la
+ ovrrun_CFLAGS = -I$(top_srcdir)/libudis86 -I$(top_srcdir)
+
+-YASM = yasm
++YASM = @YASM@
+
+ dist_check_DATA = test16.asm test32.asm test64.asm testjmp.asm testobscure.asm \
+ testjmp.ref testobscure.ref randtest.raw randtest16.ref \
+@@ -18,7 +18,10 @@
+
+ check-local: tests
+
+-tests: test16 test32 test64 testjmp bufovrrun randraw
++yasm_tests: test16 test32 test64 testjmp
++no_yasm_tests: bufovrrun randraw
++
++tests: $(if $(YASM), yasm_tests) no_yasm_tests
+
+ test16: gen
+ $(YASM) -f bin -o test16.bin $(top_srcdir)/tests/test16.asm