summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-10-25 02:56:11 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-10-25 02:56:11 +0000
commit8a56f578942842b0bce046e176d226809fa0e03f (patch)
tree93525c373dbb81a2633d099192a57fc4b4f86a3e /dev-libs/ucommon/ucommon-5.2.2-r3.ebuild
parentclean unused license (diff)
downloadgentoo-2-8a56f578942842b0bce046e176d226809fa0e03f.tar.gz
gentoo-2-8a56f578942842b0bce046e176d226809fa0e03f.tar.bz2
gentoo-2-8a56f578942842b0bce046e176d226809fa0e03f.zip
QA: fix handling of ssl/gnutls USE flags that were completely broken.
(Portage version: 2.2.0_alpha141/cvs/Linux x86_64, signed Manifest commit with key 1CD13C8AD4301342)
Diffstat (limited to 'dev-libs/ucommon/ucommon-5.2.2-r3.ebuild')
-rw-r--r--dev-libs/ucommon/ucommon-5.2.2-r3.ebuild26
1 files changed, 9 insertions, 17 deletions
diff --git a/dev-libs/ucommon/ucommon-5.2.2-r3.ebuild b/dev-libs/ucommon/ucommon-5.2.2-r3.ebuild
index e394750c5b38..074b1996d391 100644
--- a/dev-libs/ucommon/ucommon-5.2.2-r3.ebuild
+++ b/dev-libs/ucommon/ucommon-5.2.2-r3.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/ucommon/ucommon-5.2.2-r3.ebuild,v 1.5 2012/10/22 16:44:30 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ucommon/ucommon-5.2.2-r3.ebuild,v 1.6 2012/10/25 02:56:11 flameeyes Exp $
EAPI="4"
-inherit autotools-utils
+inherit autotools-utils eutils
DESCRIPTION="Portable C++ runtime for threads and sockets"
HOMEPAGE="http://www.gnu.org/software/commoncpp"
@@ -15,8 +15,10 @@ SLOT="0"
KEYWORDS="amd64 ppc ppc64 ~x86 ~amd64-linux"
IUSE="doc static-libs socks +cxx debug ssl gnutls"
-RDEPEND="ssl? ( dev-libs/openssl )
- gnutls? ( net-libs/gnutls )"
+RDEPEND="ssl? (
+ !gnutls? ( dev-libs/openssl )
+ gnutls? ( net-libs/gnutls )
+ )"
DEPEND="virtual/pkgconfig
doc? ( app-doc/doxygen )
@@ -27,22 +29,12 @@ PATCHES=( "${FILESDIR}"/disable_rtf_gen_doxy.patch
"${FILESDIR}/${P}-address.patch")
AUTOTOOLS_IN_SOURCE_BUILD=1
-REQUIRED_USE="^^ ( ssl gnutls )"
-
src_configure() {
local myconf=""
- if ! use ssl && ! use gnutls; then
- myconf=" --with-sslstack=nossl "
- fi
-
if use ssl; then
- myconf=" --with-sslstack=ssl "
- ewarn "Using openssl for ssl stack"
- fi
-
- if use gnutls; then
- myconf=" --with-sslstack=gnu "
- ewarn "Using gnutls for ssl stack"
+ myconf+=" --with-sslstack=$(usex gnutls gnu ssl) "
+ else
+ myconf+=" --with-sslstack=nossl ";
fi
local myeconfargs=(