summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Bornkessel <hd_brummy@gentoo.org>2011-01-19 19:10:13 +0000
committerJörg Bornkessel <hd_brummy@gentoo.org>2011-01-19 19:10:13 +0000
commitf4f90d6c956278924505b21d135136c6a4cf71a1 (patch)
tree6c7d7895b8555e9b0826f2c18061f6f073d2795f /dev-libs/tntnet
parentRemove old version. (diff)
downloadgentoo-2-f4f90d6c956278924505b21d135136c6a4cf71a1.tar.gz
gentoo-2-f4f90d6c956278924505b21d135136c6a4cf71a1.tar.bz2
gentoo-2-f4f90d6c956278924505b21d135136c6a4cf71a1.zip
version bump
(Portage version: 2.1.9.25/cvs/Linux i686)
Diffstat (limited to 'dev-libs/tntnet')
-rw-r--r--dev-libs/tntnet/ChangeLog7
-rw-r--r--dev-libs/tntnet/tntnet-2.0.ebuild69
2 files changed, 75 insertions, 1 deletions
diff --git a/dev-libs/tntnet/ChangeLog b/dev-libs/tntnet/ChangeLog
index 03fbd46f3292..2c60963eed05 100644
--- a/dev-libs/tntnet/ChangeLog
+++ b/dev-libs/tntnet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/tntnet
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/tntnet/ChangeLog,v 1.13 2011/01/19 15:50:49 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/tntnet/ChangeLog,v 1.14 2011/01/19 19:10:13 hd_brummy Exp $
+
+*tntnet-2.0 (19 Jan 2011)
+
+ 19 Jan 2011; Joerg Bornkessel <hd_brummy@gentoo.org> +tntnet-2.0.ebuild:
+ version bump
19 Jan 2011; Joerg Bornkessel <hd_brummy@gentoo.org> tntnet-1.6.3.ebuild:
eapi=2, stable x86 amd64
diff --git a/dev-libs/tntnet/tntnet-2.0.ebuild b/dev-libs/tntnet/tntnet-2.0.ebuild
new file mode 100644
index 000000000000..462fb3055717
--- /dev/null
+++ b/dev-libs/tntnet/tntnet-2.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/tntnet/tntnet-2.0.ebuild,v 1.1 2011/01/19 19:10:13 hd_brummy Exp $
+
+EAPI="2"
+
+inherit autotools eutils
+
+DESCRIPTION="A modular, multithreaded webapplicationserver extensible with C++."
+HOMEPAGE="http://www.tntnet.org/index.hms"
+SRC_URI="http://www.tntnet.org/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE="ssl gnutls examples"
+
+RDEPEND=">=dev-libs/cxxtools-2.0
+ ssl? (
+ gnutls? ( >=net-libs/gnutls-1.2.0 )
+ !gnutls? ( dev-libs/openssl )
+ )"
+DEPEND="${RDEPEND}
+ app-arch/zip
+ ssl? ( gnutls? ( dev-util/pkgconfig ) )"
+
+src_prepare() {
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=""
+ if use ssl; then
+ if use gnutls; then
+ einfo "Using gnutls for ssl support."
+ myconf="${myconf} --with-ssl=gnutls"
+ else
+ einfo "Using openssl for ssl support."
+ myconf="${myconf} --with-ssl=openssl"
+ fi
+ else
+ einfo "Disabled ssl"
+ myconf="${myconf} --with-ssl=no"
+ fi
+ if use examples; then
+ myconf="${myconf} --with-demos=yes"
+ else
+ myconf="${myconf} --with-demos=no"
+ fi
+
+ econf ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+ dodoc AUTHORS ChangeLog README TODO doc/*.pdf
+
+ if use examples; then
+ cd "${S}/sdk/demos"
+ make clean
+ rm -rf .deps */.deps .libs */.libs
+
+ local dir="/usr/share/doc/${PF}/examples"
+ dodir "${dir}"
+ cp -r "${S}"/sdk/demos/* "${D}${dir}"
+ fi
+}