summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2014-11-29 22:43:11 +0000
committerPatrice Clement <monsieurp@gentoo.org>2014-11-29 22:43:11 +0000
commit21fac30571757a84d93af3d457b0ebc7c2f7339a (patch)
treeef0c40f7ba24f0a07459209286804a1d0e5db40b /dev-libs/syck
parentVersion bump. (diff)
downloadgentoo-2-21fac30571757a84d93af3d457b0ebc7c2f7339a.tar.gz
gentoo-2-21fac30571757a84d93af3d457b0ebc7c2f7339a.tar.bz2
gentoo-2-21fac30571757a84d93af3d457b0ebc7c2f7339a.zip
Replace einstall with emake install and revbump the ebuild. See #521434.
(Portage version: 2.2.8-r2/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-libs/syck')
-rw-r--r--dev-libs/syck/ChangeLog8
-rw-r--r--dev-libs/syck/syck-0.55-r5.ebuild58
2 files changed, 65 insertions, 1 deletions
diff --git a/dev-libs/syck/ChangeLog b/dev-libs/syck/ChangeLog
index 07f31c10184c..ecbc8179045a 100644
--- a/dev-libs/syck/ChangeLog
+++ b/dev-libs/syck/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/syck
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/syck/ChangeLog,v 1.32 2014/08/10 20:39:40 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/syck/ChangeLog,v 1.33 2014/11/29 22:43:11 monsieurp Exp $
+
+*syck-0.55-r5 (29 Nov 2014)
+
+ 29 Nov 2014; Patrice Clement <monsieurp@gentoo.org> +syck-0.55-r5.ebuild,
+ syck-0.55-r4.ebuild:
+ Replace einstall with emake install and revbump the ebuild. See #521434.
10 Aug 2014; Sergei Trofimovich <slyfox@gentoo.org> syck-0.55-r4.ebuild:
QA: drop trailing '.' from DESCRIPTION
diff --git a/dev-libs/syck/syck-0.55-r5.ebuild b/dev-libs/syck/syck-0.55-r5.ebuild
new file mode 100644
index 000000000000..3d81bacd78e8
--- /dev/null
+++ b/dev-libs/syck/syck-0.55-r5.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/syck/syck-0.55-r5.ebuild,v 1.1 2014/11/29 22:43:11 monsieurp Exp $
+
+EAPI="3"
+PYTHON_DEPEND="python? 2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit distutils eutils flag-o-matic
+
+DESCRIPTION="Syck is an extension for reading and writing YAML swiftly in popular scripting languages"
+HOMEPAGE="http://whytheluckystiff.net/syck/"
+SRC_URI="http://rubyforge.org/frs/download.php/4492/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="php python"
+
+DEPEND="python? ( !dev-python/pysyck )"
+RDEPEND="${DEPEND}"
+PDEPEND="php? ( dev-php/pecl-syck
+ !=dev-libs/syck-0.55-r1 )"
+
+DISTUTILS_SETUP_FILES=("ext/python|setup.py")
+PYTHON_MODNAME="yaml2xml.py ydump.py ypath.py"
+
+pkg_setup() {
+ use python && python_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/syck-0.55-64bit.patch"
+}
+
+src_configure() {
+ append-flags -fPIC
+ econf
+}
+
+src_compile() {
+ emake
+ use python && distutils_src_compile
+}
+
+src_install() {
+ emake DESTDIR=${D} install
+ use python && distutils_src_install
+}
+
+pkg_postinst() {
+ use python && distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ use python && distutils_pkg_postrm
+}