summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-02-21 10:12:33 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-02-21 10:12:33 +0000
commit038d805c50beca76e0dea5b358c5f6a4e7fed380 (patch)
tree957c773b81222e30a84b37289cbaafdc70cc4bd2 /dev-libs/sord
parentReplace pngquant with rwpng license in the MISC-FREE group. (diff)
downloadgentoo-2-038d805c50beca76e0dea5b358c5f6a4e7fed380.tar.gz
gentoo-2-038d805c50beca76e0dea5b358c5f6a4e7fed380.tar.bz2
gentoo-2-038d805c50beca76e0dea5b358c5f6a4e7fed380.zip
version bump
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-libs/sord')
-rw-r--r--dev-libs/sord/ChangeLog9
-rw-r--r--dev-libs/sord/sord-0.12.0.ebuild39
2 files changed, 46 insertions, 2 deletions
diff --git a/dev-libs/sord/ChangeLog b/dev-libs/sord/ChangeLog
index 5c847351c14d..d237c8fa5beb 100644
--- a/dev-libs/sord/ChangeLog
+++ b/dev-libs/sord/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/sord
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/sord/ChangeLog,v 1.10 2012/12/11 19:14:01 ago Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/sord/ChangeLog,v 1.11 2013/02/21 10:12:33 aballier Exp $
+
+*sord-0.12.0 (21 Feb 2013)
+
+ 21 Feb 2013; Alexis Ballier <aballier@gentoo.org> +sord-0.12.0.ebuild:
+ version bump
11 Dec 2012; Agostino Sarubbo <ago@gentoo.org> sord-0.10.4.ebuild:
Add ~ppc, wrt bug #421061
diff --git a/dev-libs/sord/sord-0.12.0.ebuild b/dev-libs/sord/sord-0.12.0.ebuild
new file mode 100644
index 000000000000..7a400d41ef36
--- /dev/null
+++ b/dev-libs/sord/sord-0.12.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/sord/sord-0.12.0.ebuild,v 1.1 2013/02/21 10:12:33 aballier Exp $
+
+EAPI=4
+
+inherit waf-utils
+
+DESCRIPTION="Library for storing RDF data in memory"
+HOMEPAGE="http://drobilla.net/software/sord/"
+SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc static-libs test"
+
+RDEPEND=">=dev-libs/serd-0.14.0"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig"
+
+DOCS=( "AUTHORS" "NEWS" "README" )
+
+src_prepare() {
+ sed -i -e 's/^.*run_ldconfig/#\0/' wscript || die
+}
+
+src_configure() {
+ waf-utils_src_configure \
+ --docdir=/usr/share/doc/${PF} \
+ $(use test && echo "--test") \
+ $(use doc && echo "--docs") \
+ $(use static-libs && echo "--static")
+}
+
+src_test() {
+ ./waf test || die
+}