summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-04-25 13:33:34 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-04-25 13:33:34 +0000
commit6c971aaded036f6526ee299856a7756ae2fb1c37 (patch)
tree8d3985bb92e771ffade7140dbc9a049465a855e8 /dev-libs/rasqal
parentUse tc-arch to select between amd64 and x86 optimization wrt #317069. (diff)
downloadgentoo-2-6c971aaded036f6526ee299856a7756ae2fb1c37.tar.gz
gentoo-2-6c971aaded036f6526ee299856a7756ae2fb1c37.tar.bz2
gentoo-2-6c971aaded036f6526ee299856a7756ae2fb1c37.zip
version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/rasqal')
-rw-r--r--dev-libs/rasqal/ChangeLog7
-rw-r--r--dev-libs/rasqal/rasqal-0.9.19.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/dev-libs/rasqal/ChangeLog b/dev-libs/rasqal/ChangeLog
index 6f574e1510c7..1f417c97dd92 100644
--- a/dev-libs/rasqal/ChangeLog
+++ b/dev-libs/rasqal/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/rasqal
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/rasqal/ChangeLog,v 1.41 2010/04/18 13:58:20 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/rasqal/ChangeLog,v 1.42 2010/04/25 13:33:34 aballier Exp $
+
+*rasqal-0.9.19 (25 Apr 2010)
+
+ 25 Apr 2010; Alexis Ballier <aballier@gentoo.org> +rasqal-0.9.19.ebuild:
+ version bump
18 Apr 2010; Samuli Suominen <ssuominen@gentoo.org> rasqal-0.9.17.ebuild:
amd64 stable wrt #301306
diff --git a/dev-libs/rasqal/rasqal-0.9.19.ebuild b/dev-libs/rasqal/rasqal-0.9.19.ebuild
new file mode 100644
index 000000000000..7bbbdc0023a9
--- /dev/null
+++ b/dev-libs/rasqal/rasqal-0.9.19.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/rasqal/rasqal-0.9.19.ebuild,v 1.1 2010/04/25 13:33:34 aballier Exp $
+
+EAPI=2
+inherit libtool
+
+DESCRIPTION="library that handles Resource Description Framework (RDF)"
+HOMEPAGE="http://librdf.org/rasqal/"
+SRC_URI="http://download.librdf.org/source/${P}.tar.gz"
+
+LICENSE="Apache-2.0 GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos"
+IUSE="gmp pcre test xml"
+
+RDEPEND=">=media-libs/raptor-1.4.18
+ pcre? ( dev-libs/libpcre )
+ xml? ( dev-libs/libxml2 )
+ !gmp? ( dev-libs/mpfr )
+ gmp? ( dev-libs/gmp )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/flex
+ test? ( dev-perl/XML-DOM )"
+
+src_prepare() {
+ elibtoolize
+}
+
+src_configure() {
+ use prefix || EPREFIX=
+ local regex="posix"
+ local decimal="mpfr"
+
+ use pcre && regex="pcre"
+ use gmp && decimal="gmp"
+
+ econf \
+ --disable-dependency-tracking \
+ --with-raptor=system \
+ $(use_enable pcre) \
+ $(use_enable xml xml2) \
+ --with-regex-library=${regex} \
+ --with-decimal=${decimal} \
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README
+ dohtml {NEWS,README,RELEASE}.html
+}