summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-03-13 14:22:22 +0000
committerJohannes Huber <johu@gentoo.org>2014-03-13 14:22:22 +0000
commitecf8212f6d11422ba0910753bec40af6a4755441 (patch)
treee91899511ce445191b0d6a243a44a18345a19f4e /dev-libs/qtkeychain
parentStable for amd64 wrt bug #503386 (diff)
downloadgentoo-2-ecf8212f6d11422ba0910753bec40af6a4755441.tar.gz
gentoo-2-ecf8212f6d11422ba0910753bec40af6a4755441.tar.bz2
gentoo-2-ecf8212f6d11422ba0910753bec40af6a4755441.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'dev-libs/qtkeychain')
-rw-r--r--dev-libs/qtkeychain/ChangeLog10
-rw-r--r--dev-libs/qtkeychain/qtkeychain-0.3.0.ebuild38
2 files changed, 45 insertions, 3 deletions
diff --git a/dev-libs/qtkeychain/ChangeLog b/dev-libs/qtkeychain/ChangeLog
index aa0fde0a67de..8f3f925b9988 100644
--- a/dev-libs/qtkeychain/ChangeLog
+++ b/dev-libs/qtkeychain/ChangeLog
@@ -1,10 +1,14 @@
# ChangeLog for dev-libs/qtkeychain
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/qtkeychain/ChangeLog,v 1.1 2013/05/29 23:20:33 johu Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/qtkeychain/ChangeLog,v 1.2 2014/03/13 14:22:22 johu Exp $
+
+*qtkeychain-0.3.0 (13 Mar 2014)
+
+ 13 Mar 2014; Johannes Huber <johu@gentoo.org> +qtkeychain-0.3.0.ebuild:
+ Version bump.
*qtkeychain-0.1.0 (29 May 2013)
29 May 2013; Johannes Huber <johu@gentoo.org> +qtkeychain-0.1.0.ebuild,
+files/qtkeychain-0.1.0-qt5.patch, +metadata.xml:
New package. Ebuild by me.
-
diff --git a/dev-libs/qtkeychain/qtkeychain-0.3.0.ebuild b/dev-libs/qtkeychain/qtkeychain-0.3.0.ebuild
new file mode 100644
index 000000000000..6db124d6e41c
--- /dev/null
+++ b/dev-libs/qtkeychain/qtkeychain-0.3.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/qtkeychain/qtkeychain-0.3.0.ebuild,v 1.1 2014/03/13 14:22:22 johu Exp $
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Qt API for storing passwords securely"
+HOMEPAGE="https://github.com/frankosterfeld/qtkeychain"
+SRC_URI="https://github.com/frankosterfeld/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="qt5"
+
+DEPEND="
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ )
+ !qt5? (
+ dev-qt/qtcore:4
+ dev-qt/qtdbus:4
+ )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( ChangeLog ReadMe.txt )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_build !qt5 WITH_QT4)
+ )
+
+ cmake-utils_src_configure
+}