summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPrzemyslaw Maciag <troll@gentoo.org>2007-03-14 21:40:21 +0000
committerPrzemyslaw Maciag <troll@gentoo.org>2007-03-14 21:40:21 +0000
commitcb53a15ec1137956b8572ef189f23b8fb2560657 (patch)
tree99448232110b8195d7b621521a795848cf86f2cb /dev-libs/qsa/qsa-1.0.1.ebuild
parentFix broken init script syntax (#170916). (diff)
downloadgentoo-2-cb53a15ec1137956b8572ef189f23b8fb2560657.tar.gz
gentoo-2-cb53a15ec1137956b8572ef189f23b8fb2560657.tar.bz2
gentoo-2-cb53a15ec1137956b8572ef189f23b8fb2560657.zip
Ebuild cleanup - moved patching to src_unpack. Version bump to 1.1.5
(Portage version: 2.1.2.2)
Diffstat (limited to 'dev-libs/qsa/qsa-1.0.1.ebuild')
-rw-r--r--dev-libs/qsa/qsa-1.0.1.ebuild18
1 files changed, 13 insertions, 5 deletions
diff --git a/dev-libs/qsa/qsa-1.0.1.ebuild b/dev-libs/qsa/qsa-1.0.1.ebuild
index 0247b7ac216c..093ad9832b71 100644
--- a/dev-libs/qsa/qsa-1.0.1.ebuild
+++ b/dev-libs/qsa/qsa-1.0.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/qsa/qsa-1.0.1.ebuild,v 1.6 2005/07/25 15:40:59 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/qsa/qsa-1.0.1.ebuild,v 1.7 2007/03/14 21:40:21 troll Exp $
inherit eutils qt3
@@ -12,13 +12,21 @@ LICENSE="GPL-2"
KEYWORDS="x86 ppc amd64"
SRC_URI="ftp://ftp.trolltech.com/qsa/source/${PN}-x11-free-${PV}.tar.gz"
HOMEPAGE="http://www.trolltech.com/"
+
DEPEND="$(qt_min_version 3.2)"
+RDEPEND="${DEPEND}"
-src_compile() {
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
epatch ${FILESDIR}/${P}-no-examples.diff
epatch ${FILESDIR}/${P}-sandbox-fix.diff
- ./configure -prefix ${D}${QTDIR} -no-ide || die
- emake || die
+}
+
+src_compile() {
+ ./configure -prefix ${D}${QTDIR} -no-ide || die "configure failed"
+ emake || die "make failed"
}
src_install() {