summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2003-08-28 03:41:03 +0000
committerCaleb Tennis <caleb@gentoo.org>2003-08-28 03:41:03 +0000
commit905f9bd9d73d0abba8d05c16740df41ad6eb9e95 (patch)
tree30b5afc49903a1bb2f70605664a7663a2da60d66 /dev-libs/qsa/qsa-1.0.0.ebuild
parenttry a fix (diff)
downloadgentoo-2-905f9bd9d73d0abba8d05c16740df41ad6eb9e95.tar.gz
gentoo-2-905f9bd9d73d0abba8d05c16740df41ad6eb9e95.tar.bz2
gentoo-2-905f9bd9d73d0abba8d05c16740df41ad6eb9e95.zip
Fix a .qmake.cache problem
Diffstat (limited to 'dev-libs/qsa/qsa-1.0.0.ebuild')
-rw-r--r--dev-libs/qsa/qsa-1.0.0.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/dev-libs/qsa/qsa-1.0.0.ebuild b/dev-libs/qsa/qsa-1.0.0.ebuild
index 37b123baa358..47c5dda9e25e 100644
--- a/dev-libs/qsa/qsa-1.0.0.ebuild
+++ b/dev-libs/qsa/qsa-1.0.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/qsa/qsa-1.0.0.ebuild,v 1.2 2003/07/03 16:31:46 brain Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/qsa/qsa-1.0.0.ebuild,v 1.3 2003/08/28 03:40:55 caleb Exp $
inherit eutils kde-functions
@@ -9,7 +9,7 @@ S="${WORKDIR}/${PN}-x11-free-${PV}"
DESCRIPTION="QSA version ${PV}"
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~x86 ~ppc"
+KEYWORDS="x86 ~ppc"
SRC_URI="ftp://ftp.trolltech.com/qsa/source/${PN}-x11-free-${PV}.tar.gz"
HOMEPAGE="http://www.trolltech.com/"
DEPEND=">=x11-libs/qt-3.1.2-r3"
@@ -24,6 +24,9 @@ src_compile() {
}
src_install() {
- make install
+
+ sed -e "s:${S}:${QTBASE}:g" ${S}/.qmake.cache > ${D}/${QTBASE}/.qmake.cache
+
+ make install
dodoc INSTALL README LICENSE.GPL
}