summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2008-01-30 12:09:52 +0000
committerChristian Faulhammer <opfer@gentoo.org>2008-01-30 12:09:52 +0000
commit988f8ac8f073be5a7a11708ee733957996a5ee6f (patch)
tree40bde50f4fea3af924e23b0908ff878279150173 /dev-libs/qof
parentMake audacious functionality optional, as requested by Arvid Norlander <arvid... (diff)
downloadgentoo-2-988f8ac8f073be5a7a11708ee733957996a5ee6f.tar.gz
gentoo-2-988f8ac8f073be5a7a11708ee733957996a5ee6f.tar.bz2
gentoo-2-988f8ac8f073be5a7a11708ee733957996a5ee6f.zip
add sqlite, doc and nls USE flags; rework the patch so really all unnecessary CFLAGS are removed; prevent auto-detection of some programs
(Portage version: 2.1.3.19)
Diffstat (limited to 'dev-libs/qof')
-rw-r--r--dev-libs/qof/ChangeLog7
-rw-r--r--dev-libs/qof/files/qof-0.7.4-remove_spurious_CFLAGS.patch14
-rw-r--r--dev-libs/qof/qof-0.7.4.ebuild14
3 files changed, 26 insertions, 9 deletions
diff --git a/dev-libs/qof/ChangeLog b/dev-libs/qof/ChangeLog
index 73a0c9c21cec..c4d7a14a7148 100644
--- a/dev-libs/qof/ChangeLog
+++ b/dev-libs/qof/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/qof
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/qof/ChangeLog,v 1.12 2008/01/30 11:51:06 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/qof/ChangeLog,v 1.13 2008/01/30 12:09:51 opfer Exp $
+
+ 30 Jan 2008; Christian Faulhammer <opfer@gentoo.org>
+ files/qof-0.7.4-remove_spurious_CFLAGS.patch, qof-0.7.4.ebuild:
+ add sqlite, doc and nls USE flags; rework the patch so really all
+ unnecessary CFLAGS are removed; prevent auto-detection of some programs
*qof-0.7.4 (30 Jan 2008)
diff --git a/dev-libs/qof/files/qof-0.7.4-remove_spurious_CFLAGS.patch b/dev-libs/qof/files/qof-0.7.4-remove_spurious_CFLAGS.patch
index 263cf3ca61dc..eb7b2ecf06f4 100644
--- a/dev-libs/qof/files/qof-0.7.4-remove_spurious_CFLAGS.patch
+++ b/dev-libs/qof/files/qof-0.7.4-remove_spurious_CFLAGS.patch
@@ -1,6 +1,6 @@
---- configure.orig 2008-01-30 12:40:59.000000000 +0100
-+++ configure 2008-01-30 12:43:25.000000000 +0100
-@@ -26894,11 +26894,11 @@
+--- configure.orig 2008-01-30 13:06:35.000000000 +0100
++++ configure 2008-01-30 13:06:45.000000000 +0100
+@@ -26894,18 +26894,18 @@
echo $ECHO_N "checking what extra warning flags to pass to the C compiler... $ECHO_C" >&6; }
if test ${GCC}x = yesx; then
warnFLAGS=
@@ -14,6 +14,14 @@
no) ;;
*) { { echo "$as_me:$LINENO: error: bad value ${enableval} for --enable-error-on-warning" >&5
echo "$as_me: error: bad value ${enableval} for --enable-error-on-warning" >&2;}
+ { (exit 1); exit 1; }; } ;;
+ esac
+ else
+- warnFLAGS="${warnFLAGS} -Werror"
++ warnFLAGS="${warnFLAGS}"
+ fi
+
+ GCC_VERSION=`${CC} -dumpversion`
@@ -26913,10 +26913,10 @@
# This is gcc >= 3.x.x
if test `echo ${GCC_VERSION} | cut -d. -f2` -ge 4; then
diff --git a/dev-libs/qof/qof-0.7.4.ebuild b/dev-libs/qof/qof-0.7.4.ebuild
index 2b3d7727fea0..e997456c0321 100644
--- a/dev-libs/qof/qof-0.7.4.ebuild
+++ b/dev-libs/qof/qof-0.7.4.ebuild
@@ -1,6 +1,6 @@
- # Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/qof/qof-0.7.4.ebuild,v 1.1 2008/01/30 11:51:06 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/qof/qof-0.7.4.ebuild,v 1.2 2008/01/30 12:09:51 opfer Exp $
inherit eutils
@@ -13,20 +13,24 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc64 ~sparc ~x86"
-IUSE=""
+IUSE="doc nls sqlite"
+# Raise dependency to gnome-extra/libgda-3* once it is unmasked
DEPEND="gnome-extra/libgda
- =dev-db/sqlite-2*"
+ dev-libs/libxml2
+ sqlite? ( =dev-db/sqlite-2* )
+ doc? ( app-doc/doxygen )"
RDEPEND="${DEPEND}"
src_unpack() {
unpack ${A}
cd "${S}"
+ # Upstream not willing to remove those stupid flags...
epatch "${FILESDIR}/${P}-remove_spurious_CFLAGS.patch"
}
src_compile() {
- econf || die
+ econf $(use_enable doc html-docs) --disable-error-on-warning $(use_enable nls) $(use_enable sqlite) $(use_enable doc doxygen) --disable-dot || die
emake -j1 || die
}