summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-07-14 18:51:26 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-07-14 18:51:26 +0000
commit3c2c8b9304970be69af4b1d32810e348b4d0b66a (patch)
tree6376a7b0c9b7472a6b7417611067b3153ded054b /dev-libs/qoauth
parentVersion bump. (diff)
downloadgentoo-2-3c2c8b9304970be69af4b1d32810e348b4d0b66a.tar.gz
gentoo-2-3c2c8b9304970be69af4b1d32810e348b4d0b66a.tar.bz2
gentoo-2-3c2c8b9304970be69af4b1d32810e348b4d0b66a.zip
Initial commit of qoauth library
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/qoauth')
-rw-r--r--dev-libs/qoauth/ChangeLog10
-rw-r--r--dev-libs/qoauth/metadata.xml17
-rw-r--r--dev-libs/qoauth/qoauth-0.1.0.ebuild40
3 files changed, 67 insertions, 0 deletions
diff --git a/dev-libs/qoauth/ChangeLog b/dev-libs/qoauth/ChangeLog
new file mode 100644
index 000000000000..5fb7c0559d76
--- /dev/null
+++ b/dev-libs/qoauth/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-libs/qoauth
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/qoauth/ChangeLog,v 1.1 2009/07/14 18:51:26 hwoarang Exp $
+
+*qoauth-0.1.0 (14 Jul 2009)
+
+ 14 Jul 2009; Markos Chandras <hwoarang@gentoo.org> +qoauth-0.1.0.ebuild,
+ +metadata.xml:
+ Initial commit of qoauth library
+
diff --git a/dev-libs/qoauth/metadata.xml b/dev-libs/qoauth/metadata.xml
new file mode 100644
index 000000000000..34e8195998b4
--- /dev/null
+++ b/dev-libs/qoauth/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>qt</herd>
+<maintainer>
+<email>hwoarang@gentoo.org</email>
+<name>Markos Chandras</name>
+</maintainer>
+<maintainer>
+<email>d@ayoy.net</email>
+<name>Dominik Kapusta</name>
+<description>Proxy maintainer. Upstream developer. Please CC him on bugs</description>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+
diff --git a/dev-libs/qoauth/qoauth-0.1.0.ebuild b/dev-libs/qoauth/qoauth-0.1.0.ebuild
new file mode 100644
index 000000000000..5c9a0613bb39
--- /dev/null
+++ b/dev-libs/qoauth/qoauth-0.1.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/qoauth/qoauth-0.1.0.ebuild,v 1.1 2009/07/14 18:51:26 hwoarang Exp $
+
+EAPI="2"
+
+inherit qt4
+
+DESCRIPTION="A Qt-based library for OAuth support"
+HOMEPAGE="http://wiki.github.com/ayoy/qoauth"
+SRC_URI="http://files.ayoy.net/qoauth/release/${PV}/src/${P}-src.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc"
+
+DEPEND="app-crypt/qca:2[debug?]"
+RDEPEND="${DEPEND}
+ app-crypt/qca-ossl:2[debug?]"
+
+src_prepare() {
+ qt4_src_prepare
+ sed -i -e '/^ *docs \\$/d' \
+ -e "s!\(\$\${INSTALL_PREFIX}\)/lib!\1/$(get_libdir)!" ${PN}.pro
+ sed -i -e "s/\(.*\)lib$/\1$(get_libdir)/" pcfile.sh
+}
+
+src_configure() {
+ eqmake4
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die "emake install failed"
+ dodoc README CHANGELOG || die "dodoc failed"
+
+ if use doc; then
+ dohtml -r "${S}"/doc/html/* || die "Failed to install documentation"
+ fi
+}