summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Knoblich <stkn@gentoo.org>2005-02-03 19:57:59 +0000
committerStefan Knoblich <stkn@gentoo.org>2005-02-03 19:57:59 +0000
commitd7fe9e34a1e22f606cc6dae1987b2c4d958d430c (patch)
tree52a39ae5eeedcbb8784569c9e634d7dc66f1e34c /dev-libs/pwlib
parentnew upstream release. fixes #80374 (diff)
downloadgentoo-2-d7fe9e34a1e22f606cc6dae1987b2c4d958d430c.tar.gz
gentoo-2-d7fe9e34a1e22f606cc6dae1987b2c4d958d430c.tar.bz2
gentoo-2-d7fe9e34a1e22f606cc6dae1987b2c4d958d430c.zip
Small cleanups and important amd64 fixes
(Portage version: 2.0.51-r15)
Diffstat (limited to 'dev-libs/pwlib')
-rw-r--r--dev-libs/pwlib/ChangeLog8
-rw-r--r--dev-libs/pwlib/files/digest-pwlib-1.6.3-r31
-rw-r--r--dev-libs/pwlib/files/digest-pwlib-1.6.6-r21
-rw-r--r--dev-libs/pwlib/files/digest-pwlib-1.8.3-r11
-rw-r--r--dev-libs/pwlib/pwlib-1.6.3-r3.ebuild150
-rw-r--r--dev-libs/pwlib/pwlib-1.6.6-r2.ebuild159
-rw-r--r--dev-libs/pwlib/pwlib-1.8.3-r1.ebuild153
7 files changed, 472 insertions, 1 deletions
diff --git a/dev-libs/pwlib/ChangeLog b/dev-libs/pwlib/ChangeLog
index a2d0d3b75059..04fb58421cf8 100644
--- a/dev-libs/pwlib/ChangeLog
+++ b/dev-libs/pwlib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/pwlib
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/pwlib/ChangeLog,v 1.76 2005/01/14 17:04:12 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/pwlib/ChangeLog,v 1.77 2005/02/03 19:57:59 stkn Exp $
+
+*pwlib-1.8.3-r1 (03 Feb 2005)
+
+ 03 Feb 2005; Stefan Knoblich <stkn@gentoo.org> +pwlib-1.6.3-r3.ebuild,
+ +pwlib-1.6.6-r2.ebuild, +pwlib-1.8.3-r1.ebuild:
+ Small cleanups and important fixes for amd64.
14 Jan 2005; <avatar@gentoo.org> pwlib-1.8.3.ebuild:
Added to ~ppc.
diff --git a/dev-libs/pwlib/files/digest-pwlib-1.6.3-r3 b/dev-libs/pwlib/files/digest-pwlib-1.6.3-r3
new file mode 100644
index 000000000000..863433eb2e70
--- /dev/null
+++ b/dev-libs/pwlib/files/digest-pwlib-1.6.3-r3
@@ -0,0 +1 @@
+MD5 c190324ded05c349cf50b0d37fe0c8a1 pwlib-1.6.3.tar.gz 1158037
diff --git a/dev-libs/pwlib/files/digest-pwlib-1.6.6-r2 b/dev-libs/pwlib/files/digest-pwlib-1.6.6-r2
new file mode 100644
index 000000000000..82c17312183f
--- /dev/null
+++ b/dev-libs/pwlib/files/digest-pwlib-1.6.6-r2
@@ -0,0 +1 @@
+MD5 c3ae07b03cd48d57cd9d6ec346182ed4 pwlib-v1_6_6-src.tar.gz 1583087
diff --git a/dev-libs/pwlib/files/digest-pwlib-1.8.3-r1 b/dev-libs/pwlib/files/digest-pwlib-1.8.3-r1
new file mode 100644
index 000000000000..bd4b079020d8
--- /dev/null
+++ b/dev-libs/pwlib/files/digest-pwlib-1.8.3-r1
@@ -0,0 +1 @@
+MD5 082e0ca640c3dd81c637b6d6a3c9b4b3 pwlib-v1_8_3-src-tar.gz 1900922
diff --git a/dev-libs/pwlib/pwlib-1.6.3-r3.ebuild b/dev-libs/pwlib/pwlib-1.6.3-r3.ebuild
new file mode 100644
index 000000000000..eb65d8a34b4b
--- /dev/null
+++ b/dev-libs/pwlib/pwlib-1.6.3-r3.ebuild
@@ -0,0 +1,150 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/pwlib/pwlib-1.6.3-r3.ebuild,v 1.1 2005/02/03 19:57:59 stkn Exp $
+
+inherit multilib
+
+IUSE="ssl sdl ieee1394 alsa esd"
+
+DESCRIPTION="Portable Multiplatform Class Libraries for OpenH323"
+HOMEPAGE="http://www.openh323.org/"
+SRC_URI="http://www.gnomemeeting.org/admin/downloads/latest/sources/sources/${P}.tar.gz"
+
+LICENSE="MPL-1.1"
+SLOT="0"
+KEYWORDS="x86 sparc amd64 ppc alpha"
+
+DEPEND=">=sys-devel/bison-1.28
+ >=sys-devel/flex-2.5.4a
+ dev-libs/expat
+ >=sys-apps/sed-4
+ net-nds/openldap
+ sdl? ( media-libs/libsdl )
+ ssl? ( dev-libs/openssl )
+ alsa? ( media-libs/alsa-lib )
+ ieee1394? ( media-libs/libdv
+ sys-libs/libavc1394
+ sys-libs/libraw1394 )
+ esd? ( media-sound/esound )"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/make
+
+ # filter out -O3 and -mcpu embedded compiler flags
+ sed -i \
+ -e "s:-mcpu=\$(CPUTYPE)::" \
+ -e "s:-O3 -DNDEBUG:-DNDEBUG:" \
+ unix.mak
+}
+
+src_compile() {
+ local plugins
+ local myconf
+
+ if use ssl; then
+ export OPENSSLFLAG=1
+ export OPENSSLDIR="/usr"
+ export OPENSSLLIBS="-lssl -lcrypt"
+ fi
+
+ ## gnomemeeting-1.00 requires pwlib to be built w/ IPV6 support
+ ## (even if itself is built without...)
+ #use ipv6 \
+ # && myconf="${myconf} --enable-ipv6" \
+ # || myconf="${myconf} --disable-ipv6"
+ myconf="${myconf} --enable-ipv6"
+
+ # plugins, oss and v4l are default
+ plugins="oss v4l"
+
+ use ieee1394 \
+ && plugins="${plugins} avc"
+
+ use alsa \
+ && plugins="${plugins} alsa"
+
+ if use esd; then
+ # fixes bug #45059
+ export ESDDIR=/usr
+ fi
+
+ # merge plugin options (safe way if default = "")
+ plugins="`echo ${plugins} | sed -e "y: :,:"`"
+
+ econf ${myconf} \
+ --enable-plugins \
+ --with-plugins=${plugins} || die "configure failed"
+
+ # Horrible hack to strip out -L/usr/lib to allow upgrades
+ # problem is it adds -L/usr/lib before -L${S} when SSL is
+ # enabled. Same thing for -I/usr/include.
+ sed -i -e "s:^\(LDFLAGS.*\)-L/usr/lib:\1:" \
+ -e "s:^\(STDCCFLAGS.*\)-I/usr/include:\1:" \
+ ${S}/make/ptbuildopts.mak
+ sed -i -e "s:^\(LDFLAGS[\s]*=.*\) -L/usr/lib:\1:" \
+ -e "s:^\(LDFLAGS[\s]*=.*\) -I/usr/include:\1:" \
+ -e "s:^\(CCFLAGS[\s]*=.*\) -I/usr/include:\1:" \
+ ${S}/make/ptlib-config
+
+ # remove -fno-rtti, this breaks various things *grr*
+ sed -i -e "s:-fno-rtti::" \
+ make/ptbuildopts.mak
+ sed -i -e "s:-fno-rtti::" \
+ make/ptlib-config
+
+ emake -j1 opt || die "make failed"
+ emake -j1 PWLIBDIR=${S} -C plugins opt || die "make plugins failed"
+}
+
+src_install() {
+ # make these because the makefile isn't smart enough
+ dodir /usr/bin /usr/$(get_libdir) /usr/share /usr/include
+ make PREFIX=/usr DESTDIR=${D} install || die "install failed"
+
+ # these are for compiling openh323
+ # NOTE: symlinks don't work when upgrading
+ # FIXME: probably should fix this with ptlib-config
+ dodir /usr/share/pwlib/include
+ cp -r ${D}/usr/include/* ${D}/usr/share/pwlib/include
+
+ dodir /usr/share/pwlib/$(get_libdir)
+ for x in ${D}/usr/$(get_libdir)/*; do
+ dosym /usr/$(get_libdir)/`basename ${x}` /usr/share/pwlib/$(get_libdir)/`basename ${x}`
+ done
+
+ # just in case...
+ if [[ "$(get_libdir)" = "lib64" ]]; then
+ dosym /usr/share/pwlib/$(get_libdir) /usr/share/pwlib/lib
+ fi
+
+ # remove CVS dirs
+ find ${D} -name CVS -type d | xargs rm -rf
+
+ # fix symlink
+ # only amd64 needs special handling, afaics
+ rm ${D}/usr/$(get_libdir)/libpt.so
+ if [ ${ARCH} = "amd64" ] ; then
+ dosym /usr/$(get_libdir)/libpt_linux_x86_64_r.so.${PV} /usr/$(get_libdir)/libpt.so
+ else
+ dosym /usr/$(get_libdir)/libpt_linux_${ARCH}_r.so.${PV} /usr/$(get_libdir)/libpt.so
+ fi
+
+ # strip ${S} stuff
+ dosed "s:^PWLIBDIR.*:PWLIBDIR=/usr/share/pwlib:" /usr/bin/ptlib-config
+ dosed "s:^PWLIBDIR.*:PWLIBDIR=/usr/share/pwlib:" /usr/share/pwlib/make/ptbuildopts.mak
+
+ # dodgy configure/makefiles forget to expand this
+ dosed 's:${exec_prefix}:/usr:' /usr/bin/ptlib-config
+
+ # satisfy ptlib.mak's weird definition (should check if true for future versions)
+ cp ${D}/usr/bin/ptlib-config ${D}/usr/share/pwlib/make/ptlib-config
+
+ # copy version.h
+ insinto /usr/share/pwlib
+ doins version.h
+
+ dodoc ReadMe.txt History.txt
+}
diff --git a/dev-libs/pwlib/pwlib-1.6.6-r2.ebuild b/dev-libs/pwlib/pwlib-1.6.6-r2.ebuild
new file mode 100644
index 000000000000..78aa99b3699a
--- /dev/null
+++ b/dev-libs/pwlib/pwlib-1.6.6-r2.ebuild
@@ -0,0 +1,159 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/pwlib/pwlib-1.6.6-r2.ebuild,v 1.1 2005/02/03 19:57:59 stkn Exp $
+
+inherit eutils flag-o-matic multilib
+
+IUSE="ssl sdl ieee1394 alsa esd"
+
+MY_P="${PN}-v${PV//./_}"
+DESCRIPTION="Portable Multiplatform Class Libraries for OpenH323"
+HOMEPAGE="http://www.openh323.org/"
+SRC_URI="mirror://sourceforge/openh323/${MY_P}-src.tar.gz"
+
+LICENSE="MPL-1.1"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64 ~sparc ~alpha"
+
+DEPEND=">=sys-devel/bison-1.28
+ >=sys-devel/flex-2.5.4a
+ dev-libs/expat
+ >=sys-apps/sed-4
+ net-nds/openldap
+ sdl? ( media-libs/libsdl )
+ ssl? ( dev-libs/openssl )
+ alsa? ( media-libs/alsa-lib )
+ ieee1394? ( media-libs/libdv
+ sys-libs/libavc1394
+ sys-libs/libraw1394
+ media-plugins/libdc1394 )
+ esd? ( media-sound/esound )"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/make
+
+ # filter out -O3 and -mcpu embedded compiler flags
+ sed -i \
+ -e "s:-mcpu=\$(CPUTYPE)::" \
+ -e "s:-O3 -DNDEBUG:-DNDEBUG:" \
+ unix.mak
+
+ # small fix for firewire dc (camera) plugin
+ cd ${S}
+ epatch ${FILESDIR}/${P}-ieee1394dc-fix.diff
+
+ # dmix patch for alsa support (#68553)
+ epatch ${FILESDIR}/${P}-alsa_dmix.diff
+}
+
+src_compile() {
+ local plugins
+ local myconf
+
+ # may cause ICE (bug #70638)
+ filter-flags -fstack-protector
+
+ if use ssl; then
+ export OPENSSLFLAG=1
+ export OPENSSLDIR="/usr"
+ export OPENSSLLIBS="-lssl -lcrypt"
+ fi
+
+ ## gnomemeeting-1.00 requires pwlib to be built w/ IPV6 support
+ ## (even if itself is built without...)
+ #use ipv6 \
+ # && myconf="${myconf} --enable-ipv6" \
+ # || myconf="${myconf} --disable-ipv6"
+ myconf="${myconf} --enable-ipv6"
+
+ # plugins, oss and v4l are default
+ plugins="oss v4l"
+
+ use ieee1394 \
+ && plugins="${plugins} avc dc"
+
+ use alsa \
+ && plugins="${plugins} alsa"
+
+ if use esd; then
+ # fixes bug #45059
+ export ESDDIR=/usr
+ fi
+
+ # merge plugin options (safe way if default = "")
+ plugins="`echo ${plugins} | sed -e "y: :,:"`"
+
+ econf ${myconf} \
+ --enable-plugins \
+ --with-plugins=${plugins} || die "configure failed"
+
+ # Horrible hack to strip out -L/usr/lib to allow upgrades
+ # problem is it adds -L/usr/lib before -L${S} when SSL is
+ # enabled. Same thing for -I/usr/include.
+ sed -i -e "s:^\(LDFLAGS.*\)-L/usr/lib:\1:" \
+ -e "s:^\(STDCCFLAGS.*\)-I/usr/include:\1:" \
+ ${S}/make/ptbuildopts.mak
+ sed -i -e "s:^\(LDFLAGS[\s]*=.*\) -L/usr/lib:\1:" \
+ -e "s:^\(LDFLAGS[\s]*=.*\) -I/usr/include:\1:" \
+ -e "s:^\(CCFLAGS[\s]*=.*\) -I/usr/include:\1:" \
+ ${S}/make/ptlib-config
+
+ # remove -fno-rtti, this breaks various things *grr*
+ sed -i -e "s:-fno-rtti::" \
+ make/ptbuildopts.mak
+ sed -i -e "s:-fno-rtti::" \
+ make/ptlib-config
+
+ emake -j1 opt || die "make failed"
+ emake -j1 PWLIBDIR=${S} -C plugins opt || die "make plugins failed"
+}
+
+src_install() {
+ # make these because the makefile isn't smart enough
+ dodir /usr/bin /usr/$(get_libdir) /usr/share /usr/include
+ make PREFIX=/usr DESTDIR=${D} install || die "install failed"
+
+ # these are for compiling openh323
+ # NOTE: symlinks don't work when upgrading
+ # FIXME: probably should fix this with ptlib-config
+ dodir /usr/share/pwlib/include
+ cp -r ${D}/usr/include/* ${D}/usr/share/pwlib/include
+
+ dodir /usr/share/pwlib/$(get_libdir)
+ for x in ${D}/usr/$(get_libdir)/*; do
+ dosym /usr/$(get_libdir)/`basename ${x}` /usr/share/pwlib/$(get_libdir)/`basename ${x}`
+ done
+
+ # just in case...
+ if [[ "$(get_libdir)" = "lib64" ]]; then
+ dosym /usr/share/pwlib/$(get_libdir) /usr/share/pwlib/lib
+ fi
+
+ # fix symlink
+ # only amd64 needs special handling, afaics
+ rm ${D}/usr/$(get_libdir)/libpt.so
+ if use amd64; then
+ dosym /usr/$(get_libdir)/libpt_linux_x86_64_r.so.${PV} /usr/$(get_libdir)/libpt.so
+ else
+ dosym /usr/$(get_libdir)/libpt_linux_${ARCH}_r.so.${PV} /usr/$(get_libdir)/libpt.so
+ fi
+
+ # strip ${S} stuff
+ dosed "s:^PWLIBDIR.*:PWLIBDIR=/usr/share/pwlib:" /usr/bin/ptlib-config
+ dosed "s:^PWLIBDIR.*:PWLIBDIR=/usr/share/pwlib:" /usr/share/pwlib/make/ptbuildopts.mak
+
+ # dodgy configure/makefiles forget to expand this
+ dosed 's:${exec_prefix}:/usr:' /usr/bin/ptlib-config
+
+ # satisfy ptlib.mak's weird definition (should check if true for future versions)
+ cp ${D}/usr/bin/ptlib-config ${D}/usr/share/pwlib/make/ptlib-config
+
+ # copy version.h
+ insinto /usr/share/pwlib
+ doins version.h
+
+ dodoc ReadMe.txt History.txt
+}
diff --git a/dev-libs/pwlib/pwlib-1.8.3-r1.ebuild b/dev-libs/pwlib/pwlib-1.8.3-r1.ebuild
new file mode 100644
index 000000000000..0fe8739a17e3
--- /dev/null
+++ b/dev-libs/pwlib/pwlib-1.8.3-r1.ebuild
@@ -0,0 +1,153 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/pwlib/pwlib-1.8.3-r1.ebuild,v 1.1 2005/02/03 19:57:59 stkn Exp $
+
+inherit eutils flag-o-matic multilib
+
+IUSE="ssl sdl ieee1394 alsa esd"
+
+MY_P="${PN}-v${PV//./_}"
+DESCRIPTION="Portable Multiplatform Class Libraries for OpenH323"
+HOMEPAGE="http://www.openh323.org/"
+SRC_URI="mirror://sourceforge/openh323/${MY_P}-src-tar.gz"
+
+LICENSE="MPL-1.1"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~alpha ~ppc ~amd64"
+
+DEPEND=">=sys-devel/bison-1.28
+ >=sys-devel/flex-2.5.4a
+ dev-libs/expat
+ >=sys-apps/sed-4
+ net-nds/openldap
+ sdl? ( media-libs/libsdl )
+ ssl? ( dev-libs/openssl )
+ alsa? ( media-libs/alsa-lib )
+ ieee1394? ( media-libs/libdv
+ sys-libs/libavc1394
+ sys-libs/libraw1394
+ media-plugins/libdc1394 )
+ esd? ( media-sound/esound )"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ # currently complaining to upstream about new naming scheme
+ tar -C ${WORKDIR} -xzf ${DISTDIR}/${MY_P}-src-tar.gz || die "Unpacking of ${PF} failed"
+
+ cd ${S}/make
+
+ # filter out -O3 and -mcpu embedded compiler flags
+ sed -i \
+ -e "s:-mcpu=\$(CPUTYPE)::" \
+ -e "s:-O3 -DNDEBUG:-DNDEBUG:" \
+ unix.mak
+}
+
+src_compile() {
+ local plugins
+ local myconf
+
+ # may cause ICE (bug #70638)
+ filter-flags -fstack-protector
+
+ if use ssl; then
+ export OPENSSLFLAG=1
+ export OPENSSLDIR="/usr"
+ export OPENSSLLIBS="-lssl -lcrypt"
+ fi
+
+ ## gnomemeeting-1.00 requires pwlib to be built w/ IPV6 support
+ ## (even if itself is built without...)
+ #use ipv6 \
+ # && myconf="${myconf} --enable-ipv6" \
+ # || myconf="${myconf} --disable-ipv6"
+ myconf="${myconf} --enable-ipv6"
+
+ # plugins, oss and v4l are default
+ plugins="oss v4l"
+
+ use ieee1394 \
+ && plugins="${plugins} avc dc"
+
+ use alsa \
+ && plugins="${plugins} alsa"
+
+ if use esd; then
+ # fixes bug #45059
+ export ESDDIR=/usr
+
+ # ESD includes are in /usr/include?
+ # remove include path, bad things may happen if we leave it in there
+ sed -i -e "s:-I\$(ESDDIR)/include::" \
+ ${S}/make/unix.mak
+ fi
+
+ # merge plugin options (safe way if default = "")
+ plugins="$(echo ${plugins} | sed -e "y: :,:")"
+
+ econf ${myconf} \
+ --enable-plugins \
+ --with-plugins=${plugins} || die "configure failed"
+
+ # Horrible hack to strip out -L/usr/lib to allow upgrades
+ # problem is it adds -L/usr/lib before -L${S} when SSL is
+ # enabled. Same thing for -I/usr/include.
+ sed -i -e "s:^\(LDFLAGS.*\)-L/usr/lib:\1:" \
+ -e "s:^\(STDCCFLAGS.*\)-I/usr/include:\1:" \
+ ${S}/make/ptbuildopts.mak
+ sed -i -e "s:^\(LDFLAGS[\s]*=.*\) -L/usr/lib:\1:" \
+ -e "s:^\(LDFLAGS[\s]*=.*\) -I/usr/include:\1:" \
+ -e "s:^\(CCFLAGS[\s]*=.*\) -I/usr/include:\1:" \
+ ${S}/make/ptlib-config
+
+ emake -j1 opt || die "make failed"
+}
+
+src_install() {
+ # makefile doesn't create ${D}/usr/bin
+ dodir /usr/bin
+ make PREFIX=/usr DESTDIR=${D} install || die "install failed"
+
+ ## vv will try to fix the mess below, requires a lot of patching though...
+
+ # these are for compiling openh323
+ # NOTE: symlinks don't work when upgrading
+ # FIXME: probably should fix this with ptlib-config
+ dodir /usr/share/pwlib/include
+ cp -r ${D}/usr/include/* ${D}/usr/share/pwlib/include
+
+ dodir /usr/share/pwlib/$(get_libdir)
+ for x in ${D}/usr/$(get_libdir)/*; do
+ dosym /usr/$(get_libdir)/`basename ${x}` /usr/share/pwlib/$(get_libdir)/`basename ${x}`
+ done
+
+ # just in case...
+ if [[ "$(get_libdir)" = "lib64" ]]; then
+ dosym /usr/share/pwlib/$(get_libdir) /usr/share/pwlib/lib
+ fi
+
+ ## ^^ bad stuff
+
+ # fix symlink
+ # only amd64 needs special handling, afaics
+ rm ${D}/usr/$(get_libdir)/libpt.so
+ if use amd64; then
+ dosym /usr/$(get_libdir)/libpt_linux_x86_64_r.so.${PV} /usr/$(get_libdir)/libpt.so
+ else
+ dosym /usr/$(get_libdir)/libpt_linux_${ARCH}_r.so.${PV} /usr/$(get_libdir)/libpt.so
+ fi
+
+ # strip ${S} stuff
+ dosed "s:^PWLIBDIR.*:PWLIBDIR=/usr/share/pwlib:" /usr/bin/ptlib-config
+ dosed "s:^PWLIBDIR.*:PWLIBDIR=/usr/share/pwlib:" /usr/share/pwlib/make/ptbuildopts.mak
+
+ # dodgy configure/makefiles forget to expand this
+ dosed 's:${exec_prefix}:/usr:' /usr/bin/ptlib-config
+
+ # copy version.h
+ insinto /usr/share/pwlib
+ doins version.h
+
+ dodoc ReadMe.txt ReadMe_QOS.txt History.txt ChangeLog mpl-1.0.htm
+}