summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-07-30 12:22:18 +0000
committerDan Armak <danarmak@gentoo.org>2002-07-30 12:22:18 +0000
commit82d328ed59c186803c08582c90e59a610ca0c4f7 (patch)
treec8a9904a16710e7321ac82c2b5d667982b83b163 /dev-libs/pilot-link
parentrepoman'd (diff)
downloadgentoo-2-82d328ed59c186803c08582c90e59a610ca0c4f7.tar.gz
gentoo-2-82d328ed59c186803c08582c90e59a610ca0c4f7.tar.bz2
gentoo-2-82d328ed59c186803c08582c90e59a610ca0c4f7.zip
fix #5615 - headers installing into filesystem root
Diffstat (limited to 'dev-libs/pilot-link')
-rw-r--r--dev-libs/pilot-link/ChangeLog8
-rw-r--r--dev-libs/pilot-link/files/digest-pilot-link-0.11.1-r11
-rw-r--r--dev-libs/pilot-link/pilot-link-0.11.1-r1.ebuild51
3 files changed, 59 insertions, 1 deletions
diff --git a/dev-libs/pilot-link/ChangeLog b/dev-libs/pilot-link/ChangeLog
index d4af28a7ea9b..f2cd0beef776 100644
--- a/dev-libs/pilot-link/ChangeLog
+++ b/dev-libs/pilot-link/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/pilot-link
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/pilot-link/ChangeLog,v 1.6 2002/07/22 16:56:47 owen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/pilot-link/ChangeLog,v 1.7 2002/07/30 12:22:18 danarmak Exp $
+
+*pilot-link-0.11.1-r1 (30 Jul 2002)
+
+ 30 Jul 2002; Dan Armak <danarmak@gentoo.org> ChangeLog :
+
+ Fix bug #5615 (headers installing into the filesystem root).
22 Jul 2002; Owen Stampflee <owen@gentoo.org> :
diff --git a/dev-libs/pilot-link/files/digest-pilot-link-0.11.1-r1 b/dev-libs/pilot-link/files/digest-pilot-link-0.11.1-r1
new file mode 100644
index 000000000000..f74fe850d359
--- /dev/null
+++ b/dev-libs/pilot-link/files/digest-pilot-link-0.11.1-r1
@@ -0,0 +1 @@
+MD5 b7b7b00ff13fe4e499f02bdfb1785178 pilot-link-0.11.1.tar.bz2 640198
diff --git a/dev-libs/pilot-link/pilot-link-0.11.1-r1.ebuild b/dev-libs/pilot-link/pilot-link-0.11.1-r1.ebuild
new file mode 100644
index 000000000000..5c0c9449a2f2
--- /dev/null
+++ b/dev-libs/pilot-link/pilot-link-0.11.1-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/pilot-link/pilot-link-0.11.1-r1.ebuild,v 1.1 2002/07/30 12:22:18 danarmak Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A suite of tools contains a series of conduits for moving
+information to and from your Palm device and your desktop or workstation
+system."
+
+SRC_URI="http://pilot-link.org/source/${P}.tar.bz2"
+HOMEPAGE="http://www.pilot-link.org/"
+DEPEND="virtual/glibc"
+
+SLOT="0"
+LICENSE="GPL-2 | LGPL"
+KEYWORDS="x86"
+
+src_compile() {
+
+ local myconf
+
+ use perl || myconf="${myconf} --with-perl5=no"
+ use java || myconf="${myconf} --with-java=no"
+ use tcltk || myconf="${myconf} --with-tcl=no --with-itcl=no --with-tk=no"
+
+ econf \
+ --includedir=/usr/include/libpisock \
+ --with-perl5=no \
+ --with-python=no \
+ --with-java=no \
+ --with-tcl=no \
+ --with-itcl=no \
+ --with-tk=no || die
+
+ cd ${S}
+ emake || die
+
+
+}
+
+src_install() {
+
+ make \
+ DESTDIR=${D} \
+ install || die
+
+ mv ${D}/*.hxx ${D}/usr/include/libpisock/
+
+ dodoc ChangeLog README TODO NEWS AUTHORS
+
+}