summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-06-24 08:18:12 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-06-24 08:18:12 +0000
commit9e8dd8898db22e486cd90e392c91fddcd5623ceb (patch)
tree769c5ac428c4cbd9c8bd1d70001500999127ee02 /dev-libs/opensc/files
parentsci-chemistry/molsketch: Backport changes in order to fix some unknown build ... (diff)
downloadgentoo-2-9e8dd8898db22e486cd90e392c91fddcd5623ceb.tar.gz
gentoo-2-9e8dd8898db22e486cd90e392c91fddcd5623ceb.tar.bz2
gentoo-2-9e8dd8898db22e486cd90e392c91fddcd5623ceb.zip
Fix parallelinstall patch (update sent upstream), remove automake 1.11 restriction.
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/opensc/files')
-rw-r--r--dev-libs/opensc/files/opensc-0.12.2-parallelinstall.patch17
1 files changed, 10 insertions, 7 deletions
diff --git a/dev-libs/opensc/files/opensc-0.12.2-parallelinstall.patch b/dev-libs/opensc/files/opensc-0.12.2-parallelinstall.patch
index 823fa08c56db..3ef24ec3d254 100644
--- a/dev-libs/opensc/files/opensc-0.12.2-parallelinstall.patch
+++ b/dev-libs/opensc/files/opensc-0.12.2-parallelinstall.patch
@@ -1,4 +1,4 @@
-From 9e62ac20a1dc39e001875e57067ab7fa2389ae73 Mon Sep 17 00:00:00 2001
+From 4ede74dd803ddbc4d0686bec0749459f54854495 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Diego=20Elio=20Petten=C3=B2?= <flameeyes@flameeyes.eu>
Date: Sun, 13 May 2012 14:55:35 -0700
Subject: [PATCH] build: fix parallel install by creating directory in the
@@ -10,6 +10,9 @@ Content-Transfer-Encoding: 8bit
Relying on the rule that creates the directory is a bad idea to be
parallel safe.
+(Patch modified to use autoconf's MKDIR_P instead of automake's
+deprecated mkdir_p, allowing use of automake 1.12).
+
Signed-off-by: Diego Elio Pettenò <flameeyes@flameeyes.eu>
---
etc/Makefile.am | 4 ++--
@@ -17,7 +20,7 @@ Signed-off-by: Diego Elio Pettenò <flameeyes@flameeyes.eu>
2 files changed, 6 insertions(+), 5 deletions(-)
diff --git a/etc/Makefile.am b/etc/Makefile.am
-index 0ef546f..478a7bb 100644
+index 0ef546f..3b75995 100644
--- a/etc/Makefile.am
+++ b/etc/Makefile.am
@@ -18,8 +18,8 @@ opensc.conf: opensc.conf.in force
@@ -27,21 +30,21 @@ index 0ef546f..478a7bb 100644
-sysconf_DATA=#required in order to create dir
-install-exec-hook: install-sysconfDATA opensc.conf
+install-exec-hook: opensc.conf
-+ $(mkdir_p) "$(DESTDIR)$(sysconfdir)"
++ $(MKDIR_P) "$(DESTDIR)$(sysconfdir)"
if [ -f "$(DESTDIR)$(sysconfdir)/opensc.conf" ]; then \
$(INSTALL_DATA) opensc.conf "$(DESTDIR)$(sysconfdir)/opensc.conf.new"; \
else \
diff --git a/src/pkcs11/Makefile.am b/src/pkcs11/Makefile.am
-index ba5e70d..742c5fb 100644
+index 8ff9abc..211055b 100644
--- a/src/pkcs11/Makefile.am
+++ b/src/pkcs11/Makefile.am
-@@ -52,19 +52,20 @@ pkcs11-jar: jar-dir
+@@ -53,19 +53,20 @@ pkcs11-jar: jar-dir
-k"testcert" jar-dir
if WIN32
-install-exec-hook: install-pkcs11DATA
+install-exec-hook:
-+ $(mkdir_p) "$(DESTDIR)$(libdir)"
++ $(MKDIR_P) "$(DESTDIR)$(libdir)"
for l in opensc-pkcs11.dll onepin-opensc-pkcs11.dll pkcs11-spy.dll; do \
mv "$(DESTDIR)$(libdir)/$$l" "$(DESTDIR)$(bindir)/$$l"; \
done
@@ -55,7 +58,7 @@ index ba5e70d..742c5fb 100644
endif
-install-exec-hook: install-pkcs11DATA
+install-exec-hook:
-+ $(mkdir_p) "$(DESTDIR)$(pkcs11dir)"
++ $(MKDIR_P) "$(DESTDIR)$(pkcs11dir)"
for l in opensc-pkcs11$(PKCS11_SUFFIX) onepin-opensc-pkcs11$(PKCS11_SUFFIX) pkcs11-spy$(PKCS11_SUFFIX); do \
rm -f "$(DESTDIR)$(pkcs11dir)/$$l"; \
$(LN_S) ../$$l "$(DESTDIR)$(pkcs11dir)/$$l"; \