summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2006-06-02 23:54:17 +0000
committerJory Pratt <anarchy@gentoo.org>2006-06-02 23:54:17 +0000
commitd91e63f88acf80526486ffbe14959df710dd7570 (patch)
treeafc0be6088207c1b83617636fe0e8a6cf17d76c6 /dev-libs/nss
parentrevision bump (diff)
downloadgentoo-2-d91e63f88acf80526486ffbe14959df710dd7570.tar.gz
gentoo-2-d91e63f88acf80526486ffbe14959df710dd7570.tar.bz2
gentoo-2-d91e63f88acf80526486ffbe14959df710dd7570.zip
revision bump
(Portage version: 2.1_rc3-r4)
Diffstat (limited to 'dev-libs/nss')
-rw-r--r--dev-libs/nss/ChangeLog8
-rw-r--r--dev-libs/nss/files/digest-nss-3.11.13
-rw-r--r--dev-libs/nss/files/nss-3.11.1-zdefs.patch16
-rw-r--r--dev-libs/nss/nss-3.11.1.ebuild109
4 files changed, 135 insertions, 1 deletions
diff --git a/dev-libs/nss/ChangeLog b/dev-libs/nss/ChangeLog
index 06bf73039c61..e48bcd6d9230 100644
--- a/dev-libs/nss/ChangeLog
+++ b/dev-libs/nss/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/nss
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/nss/ChangeLog,v 1.55 2006/05/30 15:36:29 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nss/ChangeLog,v 1.56 2006/06/02 23:54:17 anarchy Exp $
+
+*nss-3.11.1 (02 Jun 2006)
+
+ 02 Jun 2006; Jory A. Pratt <anarchy@gentoo.org>
+ +files/nss-3.11.1-zdefs.patch, +nss-3.11.1.ebuild:
+ revision bump
30 May 2006; Chris Gianelloni <wolf31o2@gentoo.org> nss-3.11-r1.ebuild:
Stable on x86 wrt bug #134798.
diff --git a/dev-libs/nss/files/digest-nss-3.11.1 b/dev-libs/nss/files/digest-nss-3.11.1
new file mode 100644
index 000000000000..ae13c9b2bb79
--- /dev/null
+++ b/dev-libs/nss/files/digest-nss-3.11.1
@@ -0,0 +1,3 @@
+MD5 5cb32527df232a62a7aed61336c8c373 nss-3.11.1.tar.gz 3650552
+RMD160 e6569ab941b08a59d2a459014389fd4581460aac nss-3.11.1.tar.gz 3650552
+SHA256 3f29d1f77f8f4fb9dc59d3a2fd13587e9be373a1cc8528e39c5d17f30807dc50 nss-3.11.1.tar.gz 3650552
diff --git a/dev-libs/nss/files/nss-3.11.1-zdefs.patch b/dev-libs/nss/files/nss-3.11.1-zdefs.patch
new file mode 100644
index 000000000000..b814364048b5
--- /dev/null
+++ b/dev-libs/nss/files/nss-3.11.1-zdefs.patch
@@ -0,0 +1,16 @@
+Index: mozilla/security/coreconf/Linux.mk
+===================================================================
+RCS file: /cvsroot/mozilla/security/coreconf/Linux.mk,v
+retrieving revision 1.27
+diff -u -r1.27 Linux.mk
+--- mozilla/security/coreconf/Linux.mk 16 Sep 2005 17:09:23 -0000 1.27
++++ mozilla/security/coreconf/Linux.mk 15 Dec 2005 21:25:00 -0000
+@@ -165,7 +165,7 @@
+ ARCH = linux
+
+ DSO_CFLAGS = -fPIC
+-DSO_LDOPTS = -shared $(ARCHFLAG)
++DSO_LDOPTS = -shared $(ARCHFLAG) -Wl,-z,defs
+ DSO_LDFLAGS =
+ LDFLAGS += $(ARCHFLAG)
+
diff --git a/dev-libs/nss/nss-3.11.1.ebuild b/dev-libs/nss/nss-3.11.1.ebuild
new file mode 100644
index 000000000000..ca11a4c41977
--- /dev/null
+++ b/dev-libs/nss/nss-3.11.1.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nss/nss-3.11.1.ebuild,v 1.1 2006/06/02 23:54:17 anarchy Exp $
+
+inherit eutils
+
+NSPR_VER="4.6.2"
+RTM_NAME="NSS_${PV//./_}_RTM"
+DESCRIPTION="Mozilla's Netscape Security Services Library that implements PKI support"
+HOMEPAGE="http://www.mozilla.org/projects/security/pki/nss/"
+SRC_URI="ftp://ftp.mozilla.org/pub/mozilla.org/security/nss/releases/${RTM_NAME}/src/${P}.tar.gz"
+
+LICENSE="MPL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="virtual/libc
+ app-arch/zip
+ >=dev-libs/nspr-${NSPR_VER}"
+
+src_unpack() {
+ unpack ${A}
+
+ # hack nspr paths
+ echo 'INCLUDES += -I${ROOT}/usr/include/nspr -I$(DIST)/include/dbm' \
+ >> ${S}/mozilla/security/coreconf/headers.mk || die "failed to append include"
+
+ # cope with nspr being in /usr/$(get_libdir)/nspr
+ sed -e 's:$(DIST)/lib:${ROOT}/usr/'"$(get_libdir)"/nspr':' \
+ -i ${S}/mozilla/security/coreconf/location.mk
+
+ # modify install path
+ sed -e 's:SOURCE_PREFIX = $(CORE_DEPTH)/\.\./dist:SOURCE_PREFIX = $(CORE_DEPTH)/dist:' \
+ -i ${S}/mozilla/security/coreconf/source.mk
+
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-${PV}-zdefs.patch
+ epatch ${FILESDIR}/${PN}-3.11-config.patch
+ epatch ${FILESDIR}/${PN}-3.11-config-1.patch
+ epatch ${FILESDIR}/${PN}-mips64.patch
+}
+
+src_compile() {
+ if use amd64 || use ppc64 || use ia64 || use s390; then
+ export USE_64=1
+ fi
+ export NSDISTMODE=copy
+ cd ${S}/mozilla/security/coreconf
+ emake -j1 BUILD_OPT=1 || die "coreconf make failed"
+ cd ${S}/mozilla/security/dbm
+ emake -j1 BUILD_OPT=1 || die "dbm make failed"
+ cd ${S}/mozilla/security/nss
+ emake -j1 BUILD_OPT=1 || die "nss make failed"
+}
+
+src_install () {
+ MINOR_VERSION=11
+ cd ${S}/mozilla/security/dist
+
+ # put all *.a files in /usr/lib/nss (because some have conflicting names
+ # with existing libraries)
+ dodir /usr/$(get_libdir)/nss
+ cp -L */lib/*.so ${D}/usr/$(get_libdir)/nss || die "copying shared libs failed"
+ cp -L */lib/*.chk ${D}/usr/$(get_libdir)/nss || die "copying chk files failed"
+ cp -L */lib/*.a ${D}/usr/$(get_libdir)/nss || die "copying libs failed"
+
+ # all the include files
+ insinto /usr/include/nss
+ doins private/nss/*.h
+ doins public/nss/*.h
+ cd ${D}/usr/$(get_libdir)/nss
+ for file in *.so; do
+ mv ${file} ${file}.${MINOR_VERSION}
+ ln -s ${file}.${MINOR_VERSION} ${file}
+ done
+
+ # coping with nss being in a different path. We move up priority to
+ # ensure that nss/nspr are used specifically before searching elsewhere.
+ dodir /etc/env.d
+ echo "LDPATH=/usr/$(get_libdir)/nss" > ${D}/etc/env.d/08nss
+
+ dodir /usr/bin
+ dodir /usr/$(get_libdir)/pkgconfig
+ cp ${FILESDIR}/nss-config.in ${D}/usr/bin/nss-config
+ cp ${FILESDIR}/nss.pc.in ${D}/usr/$(get_libdir)/pkgconfig/nss.pc
+ NSS_VMAJOR=`cat ${S}/mozilla/security/nss/lib/nss/nss.h | grep "#define.*NSS_VMAJOR" | awk '{print $3}'`
+ NSS_VMINOR=`cat ${S}/mozilla/security/nss/lib/nss/nss.h | grep "#define.*NSS_VMINOR" | awk '{print $3}'`
+ NSS_VPATCH=`cat ${S}/mozilla/security/nss/lib/nss/nss.h | grep "#define.*NSS_VPATCH" | awk '{print $3}'`
+
+ sed -e "s,@libdir@,/usr/"$(get_libdir)"/nss,g" \
+ -e "s,@prefix@,/usr,g" \
+ -e "s,@exec_prefix@,\$\{prefix},g" \
+ -e "s,@includedir@,\$\{prefix}/include/nss,g" \
+ -e "s,@MOD_MAJOR_VERSION@,$NSS_VMAJOR,g" \
+ -e "s,@MOD_MINOR_VERSION@,$NSS_VMINOR,g" \
+ -e "s,@MOD_PATCH_VERSION@,$NSS_VPATCH,g" \
+ -i ${D}/usr/bin/nss-config
+ chmod 755 ${D}/usr/bin/nss-config
+
+ sed -e "s,@libdir@,/usr/"$(get_libdir)"/nss,g" \
+ -e "s,@prefix@,/usr,g" \
+ -e "s,@exec_prefix@,\$\{prefix},g" \
+ -e "s,@includedir@,\$\{prefix}/include/nss," \
+ -e "s,@NSPR_VERSION@,`nspr-config --version`,g" \
+ -e "s,@NSS_VERSION@,$NSS_VMAJOR.$NSS_VMINOR.$NSS_VPATCH,g" \
+ -i ${D}/usr/$(get_libdir)/pkgconfig/nss.pc
+ chmod 644 ${D}/usr/$(get_libdir)/pkgconfig/nss.pc
+}