summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2012-06-06 12:50:51 +0000
committerJory Pratt <anarchy@gentoo.org>2012-06-06 12:50:51 +0000
commit6d4bac9a414746f9a837b4483add006febb874bf (patch)
tree8d4915eff83af4e55fdb50ac6a66242fa4d93eb6 /dev-libs/nspr
parentRemove separate mask for =x11-plugins/replytolist-0.3.0 from 2007 since it's ... (diff)
downloadgentoo-2-6d4bac9a414746f9a837b4483add006febb874bf.tar.gz
gentoo-2-6d4bac9a414746f9a837b4483add006febb874bf.tar.bz2
gentoo-2-6d4bac9a414746f9a837b4483add006febb874bf.zip
Version bump for security on nss-3.13.5
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/nspr')
-rw-r--r--dev-libs/nspr/ChangeLog7
-rw-r--r--dev-libs/nspr/nspr-4.9.1.ebuild107
2 files changed, 113 insertions, 1 deletions
diff --git a/dev-libs/nspr/ChangeLog b/dev-libs/nspr/ChangeLog
index 160e7703b994..175138c62337 100644
--- a/dev-libs/nspr/ChangeLog
+++ b/dev-libs/nspr/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/nspr
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/nspr/ChangeLog,v 1.185 2012/05/28 14:26:12 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nspr/ChangeLog,v 1.186 2012/06/06 12:50:51 anarchy Exp $
+
+*nspr-4.9.1 (06 Jun 2012)
+
+ 06 Jun 2012; Jory A. Pratt <anarchy@gentoo.org> +nspr-4.9.1.ebuild:
+ Version bump for security release of nss-3.13.5
28 May 2012; Raúl Porcel <armin76@gentoo.org> nspr-4.9.ebuild:
sparc stable
diff --git a/dev-libs/nspr/nspr-4.9.1.ebuild b/dev-libs/nspr/nspr-4.9.1.ebuild
new file mode 100644
index 000000000000..3021259504fb
--- /dev/null
+++ b/dev-libs/nspr/nspr-4.9.1.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nspr/nspr-4.9.1.ebuild,v 1.1 2012/06/06 12:50:51 anarchy Exp $
+
+EAPI=3
+WANT_AUTOCONF="2.1"
+
+inherit autotools eutils multilib toolchain-funcs versionator
+
+MIN_PV="$(get_version_component_range 2)"
+
+DESCRIPTION="Netscape Portable Runtime"
+HOMEPAGE="http://www.mozilla.org/projects/nspr/"
+SRC_URI="ftp://ftp.mozilla.org/pub/mozilla.org/nspr/releases/v${PV}/src/${P}.tar.gz"
+
+LICENSE="|| ( MPL-1.1 GPL-2 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="debug"
+
+src_prepare() {
+ mkdir build inst
+ epatch "${FILESDIR}"/${PN}-4.8-config.patch
+ epatch "${FILESDIR}"/${PN}-4.6.1-config-1.patch
+ epatch "${FILESDIR}"/${PN}-4.6.1-lang.patch
+ epatch "${FILESDIR}"/${PN}-4.7.0-prtime.patch
+ epatch "${FILESDIR}"/${PN}-4.7.1-solaris.patch
+ epatch "${FILESDIR}"/${PN}-4.7.4-solaris.patch
+ epatch "${FILESDIR}"/${PN}-4.8.3-aix-gcc.patch
+ # Patch needs updating
+ #epatch "${FILESDIR}"/${PN}-4.8.3-aix-soname.patch
+ epatch "${FILESDIR}"/${PN}-4.8.4-darwin-install_name.patch
+ epatch "${FILESDIR}"/${PN}-4.8.9-link-flags.patch
+
+ # We must run eautoconf to regenerate configure
+ cd "${S}"/mozilla/nsprpub
+ eautoconf
+
+ # make sure it won't find Perl out of Prefix
+ sed -i -e "s/perl5//g" "${S}"/mozilla/nsprpub/configure || die
+
+ # Respect LDFLAGS
+ sed -i -e 's/\$(MKSHLIB) \$(OBJS)/\$(MKSHLIB) \$(LDFLAGS) \$(OBJS)/g' \
+ "${S}"/mozilla/nsprpub/config/rules.mk || die
+}
+
+src_configure() {
+ cd "${S}"/build
+
+ echo > "${T}"/test.c
+ $(tc-getCC) -c "${T}"/test.c -o "${T}"/test.o
+ case $(scanelf -BF'%M' "${T}"/test.o)$(scanmacho -BF'%M' "${T}"/test.o) in
+ ELFCLASS64*|POWERPC64*|X86_64*) myconf="${myconf} --enable-64bit";;
+ ELFCLASS32*|POWERPC*|I386*|ARM*) ;;
+ *) die "Failed to detect whether your arch is 64bits or 32bits, disable distcc if you're using it, please";;
+ esac
+
+ myconf="${myconf} --libdir=${EPREFIX}/usr/$(get_libdir)"
+
+ LC_ALL="C" ECONF_SOURCE="../mozilla/nsprpub" econf \
+ $(use_enable debug) \
+ $(use_enable !debug optimize) \
+ ${myconf} || die "econf failed"
+}
+
+src_compile() {
+ cd "${S}"/build
+ if tc-is-cross-compiler; then
+ emake CC="$(tc-getBUILD_CC)" CXX="$(tc-getBUILD_CXX)" \
+ -C config nsinstall || die "failed to build"
+ mv config/{,native-}nsinstall
+ sed -s 's#/nsinstall$#/native-nsinstall#' -i config/autoconf.mk
+ rm config/nsinstall.o
+ fi
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" || die "failed to build"
+}
+
+src_install () {
+ # Their build system is royally confusing, as usual
+ MINOR_VERSION=${MIN_PV} # Used for .so version
+ cd "${S}"/build
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ cd "${ED}"/usr/$(get_libdir)
+ for file in *.a; do
+ einfo "removing static libraries as upstream has requested!"
+ rm -f ${file} || die "failed to remove static libraries."
+ done
+
+ local n=
+ # aix-soname.patch does this already
+ [[ ${CHOST} == *-aix* ]] ||
+ for file in *$(get_libname); do
+ n=${file%$(get_libname)}$(get_libname ${MINOR_VERSION})
+ mv ${file} ${n} || die "failed to mv files around"
+ ln -s ${n} ${file} || die "failed to symlink files."
+ if [[ ${CHOST} == *-darwin* ]]; then
+ install_name_tool -id "${EPREFIX}/usr/$(get_libdir)/${n}" ${n} || die
+ fi
+ done
+
+ # install nspr-config
+ dobin "${S}"/build/config/nspr-config || die "failed to install nspr-config"
+
+ # Remove stupid files in /usr/bin
+ rm -f "${ED}"/usr/bin/prerr.properties || die "failed to cleanup unneeded files"
+}