summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFederico Ferri <mescalinum@gentoo.org>2009-10-07 18:15:26 +0000
committerFederico Ferri <mescalinum@gentoo.org>2009-10-07 18:15:26 +0000
commitdfe4c593701a7842a14dbf218329996ade524ff4 (patch)
treef8a221cef619d32b390c15cab233d3cbfdfdd594 /dev-libs/newt
parentppc stable #287642 (diff)
downloadgentoo-2-dfe4c593701a7842a14dbf218329996ade524ff4.tar.gz
gentoo-2-dfe4c593701a7842a14dbf218329996ade524ff4.tar.bz2
gentoo-2-dfe4c593701a7842a14dbf218329996ade524ff4.zip
CVE-2009-2905, bug #285854
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/newt')
-rw-r--r--dev-libs/newt/ChangeLog10
-rw-r--r--dev-libs/newt/newt-0.52.10-r1.ebuild75
-rw-r--r--dev-libs/newt/newt-0.52.10.ebuild5
-rw-r--r--dev-libs/newt/newt-0.52.2-r1.ebuild87
-rw-r--r--dev-libs/newt/newt-0.52.2.ebuild5
5 files changed, 171 insertions, 11 deletions
diff --git a/dev-libs/newt/ChangeLog b/dev-libs/newt/ChangeLog
index af4ec9c727de..ff102197c8cb 100644
--- a/dev-libs/newt/ChangeLog
+++ b/dev-libs/newt/ChangeLog
@@ -1,9 +1,13 @@
# ChangeLog for dev-libs/newt
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/newt/ChangeLog,v 1.54 2009/10/07 17:25:09 mescalinum Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/newt/ChangeLog,v 1.55 2009/10/07 18:15:26 mescalinum Exp $
- 07 Oct 2009; Federico Ferri <mescalinum@gentoo.org> newt-0.52.2.ebuild,
- -newt-0.52.8.ebuild, newt-0.52.10.ebuild, +files/newt-CVE-2009-2905.patch:
+*newt-0.52.10-r1 (07 Oct 2009)
+*newt-0.52.2-r1 (07 Oct 2009)
+
+ 07 Oct 2009; Federico Ferri <mescalinum@gentoo.org> +newt-0.52.2-r1.ebuild,
+ -newt-0.52.8.ebuild, +newt-0.52.10-r1.ebuild,
+ +files/newt-CVE-2009-2905.patch:
CVE-2009-2905, bug #285854
04 Oct 2009; Markus Meier <maekke@gentoo.org> newt-0.52.10.ebuild:
diff --git a/dev-libs/newt/newt-0.52.10-r1.ebuild b/dev-libs/newt/newt-0.52.10-r1.ebuild
new file mode 100644
index 000000000000..301806e60f30
--- /dev/null
+++ b/dev-libs/newt/newt-0.52.10-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/newt/newt-0.52.10-r1.ebuild,v 1.1 2009/10/07 18:15:26 mescalinum Exp $
+
+inherit python toolchain-funcs eutils rpm
+
+DESCRIPTION="Redhat's Newt windowing toolkit development files"
+HOMEPAGE="https://fedorahosted.org/newt/"
+SRC_URI="https://fedorahosted.org/releases/n/e/newt/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="gpm tcl nls"
+
+RDEPEND="=sys-libs/slang-2*
+ >=dev-libs/popt-1.6
+ dev-lang/python
+ elibc_uclibc? ( sys-libs/ncurses )
+ gpm? ( sys-libs/gpm )
+ tcl? ( =dev-lang/tcl-8.5* )
+ "
+
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ #rpm_src_unpack
+ cd "${S}"
+
+ # bug 73850
+ if use elibc_uclibc; then
+ sed -i -e 's:-lslang:-lslang -lncurses:g' "${S}"/Makefile.in
+ fi
+
+ # bug 212676
+ sed -i -e 's:-ltcl8.4:-ltcl8.5:g' "${S}"/Makefile.in
+
+ sed -i -e 's:instroot:DESTDIR:g' "${S}"/Makefile.in || die
+
+ # bug 285854
+ epatch "${FILESDIR}"/newt-CVE-2009-2905.patch
+}
+
+src_compile() {
+ python_version
+
+ econf \
+ $(use_with gpm gpm-support) \
+ $(use_with tcl) \
+ $(use_enable nls)
+
+ # not parallel safe
+ emake -j1 \
+ CC="$(tc-getCC)" \
+ PYTHONVERS="python${PYVER}" \
+ RPM_OPT_FLAGS="${CFLAGS}" \
+ || die "emake failed"
+}
+
+src_install () {
+ python_version
+ # the RPM_OPT_FLAGS="ERROR" is there to catch a build error
+ # if it fails, that means something in src_compile() didn't build properly
+ # not parallel safe
+ emake \
+ DESTDIR="${D}" \
+ prefix="/usr" \
+ libdir="/usr/$(get_libdir)" \
+ PYTHONVERS="python${PYVER}" \
+ RPM_OPT_FLAGS="ERROR" \
+ install || die "make install failed"
+ dodoc peanuts.py popcorn.py tutorial.sgml
+ doman whiptail.1
+}
diff --git a/dev-libs/newt/newt-0.52.10.ebuild b/dev-libs/newt/newt-0.52.10.ebuild
index 46acdb4939e8..3fb19b7a9ea5 100644
--- a/dev-libs/newt/newt-0.52.10.ebuild
+++ b/dev-libs/newt/newt-0.52.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/newt/newt-0.52.10.ebuild,v 1.10 2009/10/07 17:25:09 mescalinum Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/newt/newt-0.52.10.ebuild,v 1.11 2009/10/07 18:15:26 mescalinum Exp $
inherit python toolchain-funcs eutils rpm
@@ -37,9 +37,6 @@ src_unpack() {
sed -i -e 's:-ltcl8.4:-ltcl8.5:g' "${S}"/Makefile.in
sed -i -e 's:instroot:DESTDIR:g' "${S}"/Makefile.in || die
-
- # bug 285854
- epatch "${FILESDIR}"/newt-CVE-2009-2905.patch
}
src_compile() {
diff --git a/dev-libs/newt/newt-0.52.2-r1.ebuild b/dev-libs/newt/newt-0.52.2-r1.ebuild
new file mode 100644
index 000000000000..7946c803267c
--- /dev/null
+++ b/dev-libs/newt/newt-0.52.2-r1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/newt/newt-0.52.2-r1.ebuild,v 1.1 2009/10/07 18:15:26 mescalinum Exp $
+
+inherit python toolchain-funcs eutils rpm
+
+# Revision of the RPM. Shouldn't affect us, as we're just grabbing the source
+# tarball out of it
+RPMREV="9"
+
+DESCRIPTION="Redhat's Newt windowing toolkit development files"
+HOMEPAGE="http://www.redhat.com/"
+SRC_URI="mirror://fedora/development/source/SRPMS/${P}-${RPMREV}.src.rpm"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="gpm tcl"
+
+RDEPEND=">=sys-libs/slang-1.4
+ >=dev-libs/popt-1.6
+ dev-lang/python
+ elibc_uclibc? ( sys-libs/ncurses )
+ gpm? ( sys-libs/gpm )
+ tcl? ( =dev-lang/tcl-8.4* )"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ rpm_src_unpack
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-scrollbars.patch
+ epatch "${FILESDIR}"/${P}-pgupdown-crash.patch
+ epatch "${FILESDIR}"/${P}-screensize.patch
+ epatch "${FILESDIR}"/${P}-cbtpos.patch
+ epatch "${FILESDIR}"/${P}-focus.patch
+ epatch "${FILESDIR}"/${P}-cursor.patch
+ epatch "${FILESDIR}"/${P}-colors.patch
+ epatch "${FILESDIR}"/${P}-pyexample.patch
+ epatch "${FILESDIR}"/${P}-dwchar.patch
+
+ if ! use tcl; then
+ epatch "${FILESDIR}"/${P}-notcl.patch
+ fi
+
+ # bug 73850
+ if use elibc_uclibc; then
+ sed -i -e 's:-lslang:-lslang -lncurses:g' "${S}"/Makefile.in
+ fi
+
+ sed -i -e 's:0.52.1:0.52.2:g' "${S}"/configure || die
+
+ # bug 285854
+ epatch "${FILESDIR}"/newt-CVE-2009-2905.patch
+}
+
+src_compile() {
+ python_version
+
+ econf \
+ $(use_with gpm gpm-support)
+
+ # not parallel safe
+ emake \
+ CC="$(tc-getCC)" \
+ PYTHONVERS="python${PYVER}" \
+ RPM_OPT_FLAGS="${CFLAGS}" \
+ || die "emake failed"
+}
+
+src_install () {
+ python_version
+ # the RPM_OPT_FLAGS="ERROR" is there to catch a build error
+ # if it fails, that means something in src_compile() didn't build properly
+ # not parallel safe
+ emake \
+ prefix="${D}/usr" \
+ libdir="${D}/usr/$(get_libdir)" \
+ PYTHONVERS="python${PYVER}" \
+ RPM_OPT_FLAGS="ERROR" \
+ install || die "make install failed"
+ dodoc peanuts.py popcorn.py tutorial.sgml
+ doman whiptail.1
+
+ # Don't know if it's needed but it was here before so leaving /peper
+ dosym libnewt.so.0.52.2 /usr/$(get_libdir)/libnewt.so.0.52
+}
diff --git a/dev-libs/newt/newt-0.52.2.ebuild b/dev-libs/newt/newt-0.52.2.ebuild
index 0e41865a7ccd..5dcb775c76a1 100644
--- a/dev-libs/newt/newt-0.52.2.ebuild
+++ b/dev-libs/newt/newt-0.52.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/newt/newt-0.52.2.ebuild,v 1.15 2009/10/07 17:25:09 mescalinum Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/newt/newt-0.52.2.ebuild,v 1.16 2009/10/07 18:15:26 mescalinum Exp $
inherit python toolchain-funcs eutils rpm
@@ -49,9 +49,6 @@ src_unpack() {
fi
sed -i -e 's:0.52.1:0.52.2:g' "${S}"/configure || die
-
- # bug 285854
- epatch "${FILESDIR}"/newt-CVE-2009-2905.patch
}
src_compile() {