summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFederico Ferri <mescalinum@gentoo.org>2009-10-07 17:25:10 +0000
committerFederico Ferri <mescalinum@gentoo.org>2009-10-07 17:25:10 +0000
commita662cbfd261151a8c85cfbad62b53e9551673b49 (patch)
tree56a38f80ab1f5888008e38af14c61eee5b8a4ebf /dev-libs/newt
parentppc stable #287572 (diff)
downloadgentoo-2-a662cbfd261151a8c85cfbad62b53e9551673b49.tar.gz
gentoo-2-a662cbfd261151a8c85cfbad62b53e9551673b49.tar.bz2
gentoo-2-a662cbfd261151a8c85cfbad62b53e9551673b49.zip
CVE-2009-2905, bug #285854
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/newt')
-rw-r--r--dev-libs/newt/ChangeLog6
-rw-r--r--dev-libs/newt/files/newt-CVE-2009-2905.patch11
-rw-r--r--dev-libs/newt/newt-0.52.10.ebuild5
-rw-r--r--dev-libs/newt/newt-0.52.2.ebuild7
-rw-r--r--dev-libs/newt/newt-0.52.8.ebuild74
5 files changed, 25 insertions, 78 deletions
diff --git a/dev-libs/newt/ChangeLog b/dev-libs/newt/ChangeLog
index 50c15e6dddb8..af4ec9c727de 100644
--- a/dev-libs/newt/ChangeLog
+++ b/dev-libs/newt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/newt
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/newt/ChangeLog,v 1.53 2009/10/04 20:42:10 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/newt/ChangeLog,v 1.54 2009/10/07 17:25:09 mescalinum Exp $
+
+ 07 Oct 2009; Federico Ferri <mescalinum@gentoo.org> newt-0.52.2.ebuild,
+ -newt-0.52.8.ebuild, newt-0.52.10.ebuild, +files/newt-CVE-2009-2905.patch:
+ CVE-2009-2905, bug #285854
04 Oct 2009; Markus Meier <maekke@gentoo.org> newt-0.52.10.ebuild:
arm stable, bug #281402
diff --git a/dev-libs/newt/files/newt-CVE-2009-2905.patch b/dev-libs/newt/files/newt-CVE-2009-2905.patch
new file mode 100644
index 000000000000..1e45af836519
--- /dev/null
+++ b/dev-libs/newt/files/newt-CVE-2009-2905.patch
@@ -0,0 +1,11 @@
+diff -up newt-0.52.10/textbox.c.orig newt-0.52.10/textbox.c
+--- newt-0.52.10/textbox.c.orig 2008-07-30 14:42:55.000000000 +0200
++++ newt-0.52.10/textbox.c 2009-09-21 14:59:24.000000000 +0200
+@@ -179,7 +179,7 @@ static void doReflow(const char * text,
+
+ if (resultPtr) {
+ /* XXX I think this will work */
+- result = malloc(strlen(text) + (strlen(text) / width) + 2);
++ result = malloc(strlen(text) + (strlen(text) / (width - 1)) + 2);
+ *result = '\0';
+ }
diff --git a/dev-libs/newt/newt-0.52.10.ebuild b/dev-libs/newt/newt-0.52.10.ebuild
index f245f63a85fe..46acdb4939e8 100644
--- a/dev-libs/newt/newt-0.52.10.ebuild
+++ b/dev-libs/newt/newt-0.52.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/newt/newt-0.52.10.ebuild,v 1.9 2009/10/04 20:42:10 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/newt/newt-0.52.10.ebuild,v 1.10 2009/10/07 17:25:09 mescalinum Exp $
inherit python toolchain-funcs eutils rpm
@@ -37,6 +37,9 @@ src_unpack() {
sed -i -e 's:-ltcl8.4:-ltcl8.5:g' "${S}"/Makefile.in
sed -i -e 's:instroot:DESTDIR:g' "${S}"/Makefile.in || die
+
+ # bug 285854
+ epatch "${FILESDIR}"/newt-CVE-2009-2905.patch
}
src_compile() {
diff --git a/dev-libs/newt/newt-0.52.2.ebuild b/dev-libs/newt/newt-0.52.2.ebuild
index a55525186291..0e41865a7ccd 100644
--- a/dev-libs/newt/newt-0.52.2.ebuild
+++ b/dev-libs/newt/newt-0.52.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/newt/newt-0.52.2.ebuild,v 1.14 2008/06/15 09:48:50 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/newt/newt-0.52.2.ebuild,v 1.15 2009/10/07 17:25:09 mescalinum Exp $
inherit python toolchain-funcs eutils rpm
@@ -49,6 +49,9 @@ src_unpack() {
fi
sed -i -e 's:0.52.1:0.52.2:g' "${S}"/configure || die
+
+ # bug 285854
+ epatch "${FILESDIR}"/newt-CVE-2009-2905.patch
}
src_compile() {
diff --git a/dev-libs/newt/newt-0.52.8.ebuild b/dev-libs/newt/newt-0.52.8.ebuild
deleted file mode 100644
index 9cfc9a0f54ce..000000000000
--- a/dev-libs/newt/newt-0.52.8.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/newt/newt-0.52.8.ebuild,v 1.3 2008/06/15 09:48:50 drac Exp $
-
-inherit python toolchain-funcs eutils rpm
-
-DESCRIPTION="Redhat's Newt windowing toolkit development files"
-HOMEPAGE="http://www.redhat.com/"
-SRC_URI="mirror://gentoo/${P}.tar.gz
- http://dev.gentoo.org/~xmerlin/misc/${P}.tar.gz"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="gpm tcl nls"
-
-RDEPEND="=sys-libs/slang-2*
- >=dev-libs/popt-1.6
- dev-lang/python
- elibc_uclibc? ( sys-libs/ncurses )
- gpm? ( sys-libs/gpm )
- tcl? ( =dev-lang/tcl-8.4* )
- "
-
-DEPEND="${RDEPEND}"
-
-src_unpack() {
- unpack ${A}
- #rpm_src_unpack
- cd "${S}"
-
- if ! use tcl; then
- epatch "${FILESDIR}"/${PN}-0.52.7-notcl.patch || die
- fi
-
- # bug 73850
- if use elibc_uclibc; then
- sed -i -e 's:-lslang:-lslang -lncurses:g' "${S}"/Makefile.in
- fi
-
- sed -i -e 's:instroot:DESTDIR:g' "${S}"/Makefile.in || die
-}
-
-src_compile() {
- python_version
-
- econf \
- $(use_with gpm gpm-support) \
- $(use_enable nls)
-
- # not parallel safe
- emake -j1 \
- CC="$(tc-getCC)" \
- PYTHONVERS="python${PYVER}" \
- RPM_OPT_FLAGS="${CFLAGS}" \
- || die "emake failed"
-}
-
-src_install () {
- python_version
- # the RPM_OPT_FLAGS="ERROR" is there to catch a build error
- # if it fails, that means something in src_compile() didn't build properly
- # not parallel safe
- emake \
- DESTDIR="${D}" \
- prefix="/usr" \
- libdir="/usr/$(get_libdir)" \
- PYTHONVERS="python${PYVER}" \
- RPM_OPT_FLAGS="ERROR" \
- install || die "make install failed"
- dodoc peanuts.py popcorn.py tutorial.sgml
- doman whiptail.1
-
-}