summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2013-01-12 05:57:16 +0000
committerNaohiro Aota <naota@gentoo.org>2013-01-12 05:57:16 +0000
commit46ff8f0f9e013da32aad1414304fd00f2a010ac5 (patch)
tree7e23b6c0c73dd01b2eb008dcd6d05727c45fb9c2 /dev-libs/newt
parentNo longer keepdir /var/run/saku. #451418 ; Fix doc path. (diff)
downloadgentoo-2-46ff8f0f9e013da32aad1414304fd00f2a010ac5.tar.gz
gentoo-2-46ff8f0f9e013da32aad1414304fd00f2a010ac5.tar.bz2
gentoo-2-46ff8f0f9e013da32aad1414304fd00f2a010ac5.zip
Add patch to deal with tcl change #451356
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key F8551514)
Diffstat (limited to 'dev-libs/newt')
-rw-r--r--dev-libs/newt/ChangeLog9
-rw-r--r--dev-libs/newt/files/newt-0.52.12-tcl.patch108
-rw-r--r--dev-libs/newt/files/newt-0.52.14-tcl.patch108
-rw-r--r--dev-libs/newt/newt-0.52.12.ebuild11
-rw-r--r--dev-libs/newt/newt-0.52.13.ebuild9
-rw-r--r--dev-libs/newt/newt-0.52.14-r1.ebuild11
-rw-r--r--dev-libs/newt/newt-0.52.14-r2.ebuild11
7 files changed, 246 insertions, 21 deletions
diff --git a/dev-libs/newt/ChangeLog b/dev-libs/newt/ChangeLog
index e2dc5b4e6bc6..fb1a23599de8 100644
--- a/dev-libs/newt/ChangeLog
+++ b/dev-libs/newt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/newt
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/newt/ChangeLog,v 1.80 2012/05/16 13:32:27 naota Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/newt/ChangeLog,v 1.81 2013/01/12 05:57:16 naota Exp $
+
+ 12 Jan 2013; Naohiro Aota <naota@gentoo.org> +files/newt-0.52.12-tcl.patch,
+ +files/newt-0.52.14-tcl.patch, newt-0.52.12.ebuild, newt-0.52.13.ebuild,
+ newt-0.52.14-r1.ebuild, newt-0.52.14-r2.ebuild:
+ Add patch to deal with tcl change #451356
*newt-0.52.14-r2 (16 May 2012)
diff --git a/dev-libs/newt/files/newt-0.52.12-tcl.patch b/dev-libs/newt/files/newt-0.52.12-tcl.patch
new file mode 100644
index 000000000000..e1a910910f77
--- /dev/null
+++ b/dev-libs/newt/files/newt-0.52.12-tcl.patch
@@ -0,0 +1,108 @@
+diff --git a/whiptcl.c b/whiptcl.c
+index 82c12ab..dfe1aeb 100644
+--- a/whiptcl.c
++++ b/whiptcl.c
+@@ -137,45 +137,45 @@ static int wtCmd(ClientData clientData, Tcl_Interp * interp, int argc,
+
+ if (arg < -1) {
+ /* this could buffer oveflow, bug we're not setuid so I don't care */
+- interp->result = malloc(200);
+- interp->freeProc = TCL_DYNAMIC;
+- sprintf(interp->result, "%s: %s\n",
++ char *tmp = malloc(200);
++ sprintf(tmp, "%s: %s\n",
+ poptBadOption(optCon, POPT_BADOPTION_NOALIAS),
+ poptStrerror(arg));
++ Tcl_SetResult(interp, tmp, TCL_DYNAMIC);
+
+ return TCL_ERROR;
+ }
+
+ if (mode == MODE_NONE) {
+- interp->result = "no dialog mode was specified";
++ Tcl_SetResultString(interp, "no dialog mode was specified");
+ return TCL_ERROR;
+ } else if (rc) {
+- interp->result = "multiple modes were specified";
++ Tcl_SetResultString(interp, "multiple modes were specified");
+ return TCL_ERROR;
+ }
+
+ if (!(text = poptGetArg(optCon))) {
+- interp->result = "missing text parameter";
++ Tcl_SetResultString(interp, "missing text parameter");
+ return TCL_ERROR;
+ }
+
+ if (!(nextArg = poptGetArg(optCon))) {
+- interp->result = "height missing";
++ Tcl_SetResultString(interp, "height missing");
+ return TCL_ERROR;
+ }
+ height = strtoul(nextArg, &end, 10);
+ if (*end) {
+- interp->result = "height is not a number";
++ Tcl_SetResultString(interp, "height is not a number");
+ return TCL_ERROR;
+ }
+
+ if (!(nextArg = poptGetArg(optCon))) {
+- interp->result = "width missing";
++ Tcl_SetResultString(interp, "width missing");
+ return TCL_ERROR;
+ }
+ width = strtoul(nextArg, &end, 10);
+ if (*end) {
+- interp->result = "width is not a number";
++ Tcl_SetResultString(interp, "width is not a number");
+ return TCL_ERROR;
+ }
+
+@@ -196,33 +196,30 @@ static int wtCmd(ClientData clientData, Tcl_Interp * interp, int argc,
+ case MODE_YESNO:
+ rc = messageBox(text, height, width, MSGBOX_YESNO, flags);
+ if (rc == DLG_OKAY)
+- interp->result = "yes";
++ Tcl_SetResultString(interp, "yes");
+ else
+- interp->result = "no";
++ Tcl_SetResultString(interp, "no");
+ if (rc == DLG_ERROR) rc = 0;
+ break;
+
+ case MODE_INPUTBOX:
+ rc = inputBox(text, height, width, optCon, flags, &result);
+ if (rc ==DLG_OKAY) {
+- interp->result = strdup(result);
+- interp->freeProc = TCL_DYNAMIC;
++ Tcl_SetResult(interp, strdup(result), TCL_DYNAMIC);
+ }
+ break;
+
+ case MODE_MENU:
+ rc = listBox(text, height, width, optCon, flags, default_item, &result);
+ if (rc==DLG_OKAY) {
+- interp->result = strdup(result);
+- interp->freeProc = TCL_DYNAMIC;
++ Tcl_SetResult(interp, strdup(result), TCL_DYNAMIC);
+ }
+ break;
+
+ case MODE_RADIOLIST:
+ rc = checkList(text, height, width, optCon, 1, flags, &selections);
+ if (rc==DLG_OKAY) {
+- interp->result = strdup(selections[0]);
+- interp->freeProc = TCL_DYNAMIC;
++ Tcl_SetResultString(interp, strdup(selections[0]), TCL_DYNAMIC);
+ }
+ break;
+
+@@ -245,7 +242,7 @@ static int wtCmd(ClientData clientData, Tcl_Interp * interp, int argc,
+ newtPopWindow();
+
+ if (rc == DLG_ERROR) {
+- interp->result = "bad paramter for whiptcl dialog box";
++ Tcl_SetResultString(interp, "bad paramter for whiptcl dialog box");
+ return TCL_ERROR;
+ }
+
diff --git a/dev-libs/newt/files/newt-0.52.14-tcl.patch b/dev-libs/newt/files/newt-0.52.14-tcl.patch
new file mode 100644
index 000000000000..4e10d2baae9e
--- /dev/null
+++ b/dev-libs/newt/files/newt-0.52.14-tcl.patch
@@ -0,0 +1,108 @@
+diff --git a/whiptcl.c b/whiptcl.c
+index 8688780..7219911 100644
+--- a/whiptcl.c
++++ b/whiptcl.c
+@@ -137,45 +137,45 @@ static int wtCmd(ClientData clientData, Tcl_Interp * interp, int argc,
+
+ if (arg < -1) {
+ /* this could buffer oveflow, bug we're not setuid so I don't care */
+- interp->result = malloc(200);
+- interp->freeProc = TCL_DYNAMIC;
+- sprintf(interp->result, "%s: %s\n",
++ char *tmp = malloc(200);
++ sprintf(tmp, "%s: %s\n",
+ poptBadOption(optCon, POPT_BADOPTION_NOALIAS),
+ poptStrerror(arg));
++ Tcl_SetResult(interp, tmp, TCL_DYNAMIC);
+
+ return TCL_ERROR;
+ }
+
+ if (mode == MODE_NONE) {
+- interp->result = "no dialog mode was specified";
++ Tcl_SetResultString(interp, "no dialog mode was specified");
+ return TCL_ERROR;
+ } else if (rc) {
+- interp->result = "multiple modes were specified";
++ Tcl_SetResultString(interp, "multiple modes were specified");
+ return TCL_ERROR;
+ }
+
+ if (!(text = poptGetArg(optCon))) {
+- interp->result = "missing text parameter";
++ Tcl_SetResultString(interp, "missing text parameter");
+ return TCL_ERROR;
+ }
+
+ if (!(nextArg = poptGetArg(optCon))) {
+- interp->result = "height missing";
++ Tcl_SetResultString(interp, "height missing");
+ return TCL_ERROR;
+ }
+ height = strtoul(nextArg, &end, 10);
+ if (*end) {
+- interp->result = "height is not a number";
++ Tcl_SetResultString(interp, "height is not a number");
+ return TCL_ERROR;
+ }
+
+ if (!(nextArg = poptGetArg(optCon))) {
+- interp->result = "width missing";
++ Tcl_SetResultString(interp, "width missing");
+ return TCL_ERROR;
+ }
+ width = strtoul(nextArg, &end, 10);
+ if (*end) {
+- interp->result = "width is not a number";
++ Tcl_SetResultString(interp, "width is not a number");
+ return TCL_ERROR;
+ }
+
+@@ -196,33 +196,30 @@ static int wtCmd(ClientData clientData, Tcl_Interp * interp, int argc,
+ case MODE_YESNO:
+ rc = messageBox(text, height, width, MSGBOX_YESNO, flags);
+ if (rc == DLG_OKAY)
+- interp->result = "yes";
++ Tcl_SetResultString(interp, "yes");
+ else
+- interp->result = "no";
++ Tcl_SetResultString(interp, "no");
+ if (rc == DLG_ERROR) rc = 0;
+ break;
+
+ case MODE_INPUTBOX:
+ rc = inputBox(text, height, width, optCon, flags, &result);
+ if (rc ==DLG_OKAY) {
+- interp->result = result;
+- interp->freeProc = TCL_DYNAMIC;
++ Tcl_SetResult(interp, result, TCL_DYNAMIC);
+ }
+ break;
+
+ case MODE_MENU:
+ rc = listBox(text, height, width, optCon, flags, default_item, &result);
+ if (rc==DLG_OKAY) {
+- interp->result = result;
+- interp->freeProc = TCL_DYNAMIC;
++ Tcl_SetResult(interp, result, TCL_DYNAMIC);
+ }
+ break;
+
+ case MODE_RADIOLIST:
+ rc = checkList(text, height, width, optCon, 1, flags, &selections);
+ if (rc==DLG_OKAY) {
+- interp->result = selections[0];
+- interp->freeProc = TCL_DYNAMIC;
++ Tcl_SetResult(interp, selections[0], TCL_DYNAMIC);
+
+ free(selections);
+ }
+@@ -247,7 +244,7 @@ static int wtCmd(ClientData clientData, Tcl_Interp * interp, int argc,
+ newtPopWindow();
+
+ if (rc == DLG_ERROR) {
+- interp->result = "bad paramter for whiptcl dialog box";
++ Tcl_SetResultString(interp, "bad paramter for whiptcl dialog box");
+ return TCL_ERROR;
+ }
+
diff --git a/dev-libs/newt/newt-0.52.12.ebuild b/dev-libs/newt/newt-0.52.12.ebuild
index e0cf4941f208..5cfc3b44a53c 100644
--- a/dev-libs/newt/newt-0.52.12.ebuild
+++ b/dev-libs/newt/newt-0.52.12.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/newt/newt-0.52.12.ebuild,v 1.10 2011/10/14 03:12:38 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/newt/newt-0.52.12.ebuild,v 1.11 2013/01/12 05:57:16 naota Exp $
EAPI="3"
PYTHON_DEPEND="2"
@@ -20,7 +20,7 @@ RDEPEND="=sys-libs/slang-2*
>=dev-libs/popt-1.6
elibc_uclibc? ( sys-libs/ncurses )
gpm? ( sys-libs/gpm )
- tcl? ( =dev-lang/tcl-8.5* )
+ tcl? ( >=dev-lang/tcl-8.5 )
"
DEPEND="${RDEPEND}"
@@ -37,7 +37,7 @@ src_prepare() {
fi
sed -i Makefile.in \
- -e 's|-ltcl8.4|-ltcl8.5|g' \
+ -e 's|-ltcl8.4|-ltcl|g' \
-e 's|$(SHCFLAGS) -o|$(LDFLAGS) &|g' \
-e 's|-g -o|$(CFLAGS) $(LDFLAGS) -o|g' \
-e 's|-shared -o|$(CFLAGS) $(LDFLAGS) &|g' \
@@ -46,7 +46,8 @@ src_prepare() {
|| die "sed Makefile.in"
epatch "${FILESDIR}"/${P}-whiptail.patch \
- "${FILESDIR}"/${P}-install.patch
+ "${FILESDIR}"/${P}-install.patch \
+ "${FILESDIR}"/${P}-tcl.patch
}
src_configure() {
diff --git a/dev-libs/newt/newt-0.52.13.ebuild b/dev-libs/newt/newt-0.52.13.ebuild
index 6cd460fd2e37..60da24a1a00f 100644
--- a/dev-libs/newt/newt-0.52.13.ebuild
+++ b/dev-libs/newt/newt-0.52.13.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/newt/newt-0.52.13.ebuild,v 1.1 2011/11/17 04:45:44 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/newt/newt-0.52.13.ebuild,v 1.2 2013/01/12 05:57:16 naota Exp $
EAPI="3"
PYTHON_DEPEND="2"
@@ -20,7 +20,7 @@ RDEPEND="=sys-libs/slang-2*
>=dev-libs/popt-1.6
elibc_uclibc? ( sys-libs/ncurses )
gpm? ( sys-libs/gpm )
- tcl? ( =dev-lang/tcl-8.5* )
+ tcl? ( >=dev-lang/tcl-8.5 )
"
DEPEND="${RDEPEND}"
@@ -37,7 +37,7 @@ src_prepare() {
fi
sed -i Makefile.in \
- -e 's|-ltcl8.4|-ltcl8.5|g' \
+ -e 's|-ltcl8.4|-ltcl|g' \
-e 's|$(SHCFLAGS) -o|$(LDFLAGS) &|g' \
-e 's|-g -o|$(CFLAGS) $(LDFLAGS) -o|g' \
-e 's|-shared -o|$(CFLAGS) $(LDFLAGS) &|g' \
@@ -47,6 +47,7 @@ src_prepare() {
epatch "${FILESDIR}"/${P}-python.patch
epatch "${FILESDIR}"/${P}-gold.patch
+ epatch "${FILESDIR}"/${PN}-0.52.12-tcl.patch
eautoreconf
}
diff --git a/dev-libs/newt/newt-0.52.14-r1.ebuild b/dev-libs/newt/newt-0.52.14-r1.ebuild
index d37e53546b9d..67e467a6f920 100644
--- a/dev-libs/newt/newt-0.52.14-r1.ebuild
+++ b/dev-libs/newt/newt-0.52.14-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/newt/newt-0.52.14-r1.ebuild,v 1.1 2012/03/19 07:24:58 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/newt/newt-0.52.14-r1.ebuild,v 1.2 2013/01/12 05:57:16 naota Exp $
EAPI="3"
PYTHON_DEPEND="2"
@@ -20,7 +20,7 @@ RDEPEND="=sys-libs/slang-2*
>=dev-libs/popt-1.6
elibc_uclibc? ( sys-libs/ncurses )
gpm? ( sys-libs/gpm )
- tcl? ( =dev-lang/tcl-8.5* )
+ tcl? ( >=dev-lang/tcl-8.5 )
"
DEPEND="${RDEPEND}"
@@ -37,7 +37,7 @@ src_prepare() {
fi
sed -i Makefile.in \
- -e 's|-ltcl8.4|-ltcl8.5|g' \
+ -e 's|-ltcl8.4|-ltcl|g' \
-e 's|$(SHCFLAGS) -o|$(LDFLAGS) &|g' \
-e 's|-g -o|$(CFLAGS) $(LDFLAGS) -o|g' \
-e 's|-shared -o|$(CFLAGS) $(LDFLAGS) &|g' \
@@ -46,7 +46,8 @@ src_prepare() {
|| die "sed Makefile.in"
epatch "${FILESDIR}"/${PN}-0.52.13-gold.patch \
- "${FILESDIR}"/${P}-snack.patch
+ "${FILESDIR}"/${P}-snack.patch \
+ "${FILESDIR}"/${P}-tcl.patch
eautoreconf
}
diff --git a/dev-libs/newt/newt-0.52.14-r2.ebuild b/dev-libs/newt/newt-0.52.14-r2.ebuild
index 49a2e2c236ee..6b606485d74e 100644
--- a/dev-libs/newt/newt-0.52.14-r2.ebuild
+++ b/dev-libs/newt/newt-0.52.14-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/newt/newt-0.52.14-r2.ebuild,v 1.1 2012/05/16 13:32:27 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/newt/newt-0.52.14-r2.ebuild,v 1.2 2013/01/12 05:57:16 naota Exp $
EAPI="3"
PYTHON_DEPEND="2"
@@ -20,7 +20,7 @@ RDEPEND="=sys-libs/slang-2*
>=dev-libs/popt-1.6
elibc_uclibc? ( sys-libs/ncurses )
gpm? ( sys-libs/gpm )
- tcl? ( =dev-lang/tcl-8.5* )
+ tcl? ( >=dev-lang/tcl-8.5 )
"
DEPEND="${RDEPEND}"
@@ -37,7 +37,7 @@ src_prepare() {
fi
sed -i Makefile.in \
- -e 's|-ltcl8.4|-ltcl8.5|g' \
+ -e 's|-ltcl8.4|-ltcl|g' \
-e 's|$(SHCFLAGS) -o|$(LDFLAGS) &|g' \
-e 's|-g -o|$(CFLAGS) $(LDFLAGS) -o|g' \
-e 's|-shared -o|$(CFLAGS) $(LDFLAGS) &|g' \
@@ -56,7 +56,8 @@ src_prepare() {
fi
epatch "${FILESDIR}"/${PN}-0.52.13-gold.patch \
- "${FILESDIR}"/${P}-snack.patch
+ "${FILESDIR}"/${P}-snack.patch \
+ "${FILESDIR}"/${P}-tcl.patch
eautoreconf
}