summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-07-12 22:03:33 +0000
committerTim Harder <radhermit@gentoo.org>2012-07-12 22:03:33 +0000
commitf65707cea5871b72f648b42c1900ad293162a306 (patch)
treef263e6e110a443c9982377afece96a244957797c /dev-libs/nettle
parentUpdate SRC_URI to new domain (diff)
downloadgentoo-2-f65707cea5871b72f648b42c1900ad293162a306.tar.gz
gentoo-2-f65707cea5871b72f648b42c1900ad293162a306.tar.bz2
gentoo-2-f65707cea5871b72f648b42c1900ad293162a306.zip
Version bump.
(Portage version: 2.2.0_alpha116/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/nettle')
-rw-r--r--dev-libs/nettle/ChangeLog8
-rw-r--r--dev-libs/nettle/files/nettle-2.5-missing-libm-link.patch11
-rw-r--r--dev-libs/nettle/nettle-2.5.ebuild34
3 files changed, 52 insertions, 1 deletions
diff --git a/dev-libs/nettle/ChangeLog b/dev-libs/nettle/ChangeLog
index 65dc655a8c71..b73ce023503f 100644
--- a/dev-libs/nettle/ChangeLog
+++ b/dev-libs/nettle/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/nettle
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/nettle/ChangeLog,v 1.60 2012/07/06 02:44:16 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nettle/ChangeLog,v 1.61 2012/07/12 22:03:33 radhermit Exp $
+
+*nettle-2.5 (12 Jul 2012)
+
+ 12 Jul 2012; Tim Harder <radhermit@gentoo.org> +nettle-2.5.ebuild,
+ +files/nettle-2.5-missing-libm-link.patch:
+ Version bump.
06 Jul 2012; Rick Farina <zerochaos@gentoo.org>
+files/nettle-2.4-missing-libm-link.patch, nettle-2.4.ebuild:
diff --git a/dev-libs/nettle/files/nettle-2.5-missing-libm-link.patch b/dev-libs/nettle/files/nettle-2.5-missing-libm-link.patch
new file mode 100644
index 000000000000..193c21a2920b
--- /dev/null
+++ b/dev-libs/nettle/files/nettle-2.5-missing-libm-link.patch
@@ -0,0 +1,11 @@
+--- a/examples/Makefile.in
++++ b/examples/Makefile.in
+@@ -11,7 +11,7 @@ PRE_CPPFLAGS = -I.. -I$(top_srcdir)
+ PRE_LDFLAGS = -L..
+
+ OPENSSL_LIBFLAGS = @OPENSSL_LIBFLAGS@
+-BENCH_LIBS = @BENCH_LIBS@
++BENCH_LIBS = @BENCH_LIBS@ -lm
+
+ RSA_TARGETS = rsa-keygen$(EXEEXT) rsa-sign$(EXEEXT) \
+ rsa-verify$(EXEEXT) rsa-encrypt$(EXEEXT) rsa-decrypt$(EXEEXT)
diff --git a/dev-libs/nettle/nettle-2.5.ebuild b/dev-libs/nettle/nettle-2.5.ebuild
new file mode 100644
index 000000000000..0002db72acbe
--- /dev/null
+++ b/dev-libs/nettle/nettle-2.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nettle/nettle-2.5.ebuild,v 1.1 2012/07/12 22:03:33 radhermit Exp $
+
+EAPI="4"
+
+inherit eutils autotools
+
+DESCRIPTION="Low-level cryptographic library"
+HOMEPAGE="http://www.lysator.liu.se/~nisse/nettle/"
+SRC_URI="http://www.lysator.liu.se/~nisse/archive/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-3 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="+gmp ssl"
+
+DEPEND="gmp? ( dev-libs/gmp )
+ ssl? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -e "/CFLAGS=/s: -ggdb3::" -i configure.ac || die
+ epatch "${FILESDIR}"/${PN}-2.5-missing-libm-link.patch
+ sed -i -e 's/solaris\*)/sunldsolaris*)/' configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ $(use_enable gmp public-key) \
+ $(use_enable ssl openssl)
+}