summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-08-10 22:17:20 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-08-10 22:17:20 +0000
commit8a2066c503579aa95633c622a434a92c4c19a263 (patch)
treef9c877730e74d0baddfabcdfaf9359bd28b1c20a /dev-libs/nettle
parentFixed for guile and multiple python, bug #331347 (diff)
downloadgentoo-2-8a2066c503579aa95633c622a434a92c4c19a263.tar.gz
gentoo-2-8a2066c503579aa95633c622a434a92c4c19a263.tar.bz2
gentoo-2-8a2066c503579aa95633c622a434a92c4c19a263.zip
Version bump. Bug #332129. Thanks to Dane Smith <smithdanea@gmail.com> for the patch and the testing
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/nettle')
-rw-r--r--dev-libs/nettle/ChangeLog8
-rw-r--r--dev-libs/nettle/nettle-2.1.ebuild39
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-libs/nettle/ChangeLog b/dev-libs/nettle/ChangeLog
index 3227e31faed1..554b8a7eef45 100644
--- a/dev-libs/nettle/ChangeLog
+++ b/dev-libs/nettle/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/nettle
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/nettle/ChangeLog,v 1.29 2010/03/29 10:52:52 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nettle/ChangeLog,v 1.30 2010/08/10 22:17:20 hwoarang Exp $
+
+*nettle-2.1 (10 Aug 2010)
+
+ 10 Aug 2010; Markos Chandras <hwoarang@gentoo.org> +nettle-2.1.ebuild:
+ Version bump. Bug #332129. Thanks to Dane Smith <smithdanea@gmail.com> for
+ the patch and the testing
29 Mar 2010; Samuli Suominen <ssuominen@gentoo.org> nettle-2.0.ebuild,
+files/nettle-2.0-asneeded.patch:
diff --git a/dev-libs/nettle/nettle-2.1.ebuild b/dev-libs/nettle/nettle-2.1.ebuild
new file mode 100644
index 000000000000..eeaec55e091b
--- /dev/null
+++ b/dev-libs/nettle/nettle-2.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nettle/nettle-2.1.ebuild,v 1.1 2010/08/10 22:17:20 hwoarang Exp $
+
+EAPI=2
+inherit autotools eutils
+
+DESCRIPTION="cryptographic library that is designed to fit easily in any context"
+HOMEPAGE="http://www.lysator.liu.se/~nisse/nettle/"
+SRC_URI="http://www.lysator.liu.se/~nisse/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~s390 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="gmp ssl"
+
+DEPEND="gmp? ( dev-libs/gmp )
+ ssl? ( dev-libs/openssl )
+ !<dev-libs/lsh-1.4.3-r1"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i \
+ -e '/CFLAGS/s:-ggdb3::' \
+ configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ $(use_enable gmp public-key) \
+ $(use_enable ssl openssl)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README
+}