summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-07-24 15:08:38 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-07-24 15:08:38 +0000
commit3aa991f31ebba4784a1726216847645476e18bf4 (patch)
tree2a5562ec1457ceafb6ea12fe27552201ceced21c /dev-libs/nettle
parentAdd ipv6 (depends on net-server-2 with ipv6 USE) and syslog (depends on Sys::... (diff)
downloadgentoo-2-3aa991f31ebba4784a1726216847645476e18bf4.tar.gz
gentoo-2-3aa991f31ebba4784a1726216847645476e18bf4.tar.bz2
gentoo-2-3aa991f31ebba4784a1726216847645476e18bf4.zip
Disable openssl dependency (which was also wrong, it wasn't RDEPEND), and avoid using it altogether. Thanks to Maxim Kammerer in bug #427526.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/nettle')
-rw-r--r--dev-libs/nettle/ChangeLog7
-rw-r--r--dev-libs/nettle/nettle-1.15.ebuild44
-rw-r--r--dev-libs/nettle/nettle-2.4.ebuild10
-rw-r--r--dev-libs/nettle/nettle-2.5.ebuild10
4 files changed, 16 insertions, 55 deletions
diff --git a/dev-libs/nettle/ChangeLog b/dev-libs/nettle/ChangeLog
index b73ce023503f..5779ea8199db 100644
--- a/dev-libs/nettle/ChangeLog
+++ b/dev-libs/nettle/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/nettle
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/nettle/ChangeLog,v 1.61 2012/07/12 22:03:33 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nettle/ChangeLog,v 1.62 2012/07/24 15:08:38 flameeyes Exp $
+
+ 24 Jul 2012; Diego E. Pettenò <flameeyes@gentoo.org> -nettle-1.15.ebuild,
+ nettle-2.4.ebuild, nettle-2.5.ebuild:
+ Disable openssl dependency (which was also wrong, it wasn't RDEPEND), and
+ avoid using it altogether. Thanks to Maxim Kammerer in bug #427526.
*nettle-2.5 (12 Jul 2012)
diff --git a/dev-libs/nettle/nettle-1.15.ebuild b/dev-libs/nettle/nettle-1.15.ebuild
deleted file mode 100644
index ab283d1d1c76..000000000000
--- a/dev-libs/nettle/nettle-1.15.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/nettle/nettle-1.15.ebuild,v 1.8 2012/01/01 16:13:42 slyfox Exp $
-
-inherit eutils autotools
-
-DESCRIPTION="cryptographic library that is designed to fit easily in any context"
-HOMEPAGE="http://www.lysator.liu.se/~nisse/nettle/"
-SRC_URI="http://www.lysator.liu.se/~nisse/archive/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~hppa ~ia64 ppc s390 sparc x86 ~x86-fbsd"
-IUSE="gmp ssl"
-
-DEPEND="gmp? ( dev-libs/gmp )
- ssl? ( dev-libs/openssl )
- "
-RDEPEND="${DEPEND}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${PN}-1.14-make-as-needed.patch"
- epatch "${FILESDIR}"/${PN}-2.0-binutils-2.22.patch #bug 396659
- sed -i \
- -e '/CFLAGS/s:-ggdb3::' \
- configure.ac || die
- eautoreconf
-}
-
-src_compile() {
- econf \
- --enable-shared \
- $(use_enable ssl openssl) \
- $(use_enable gmp public-key) \
- || die
- emake || die
-}
-
-src_install() {
- make DESTDIR="${D}" install || die
- dodoc AUTHORS ChangeLog NEWS README
-}
diff --git a/dev-libs/nettle/nettle-2.4.ebuild b/dev-libs/nettle/nettle-2.4.ebuild
index 60e770eb72ea..bb3920606de2 100644
--- a/dev-libs/nettle/nettle-2.4.ebuild
+++ b/dev-libs/nettle/nettle-2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/nettle/nettle-2.4.ebuild,v 1.14 2012/07/06 02:44:16 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nettle/nettle-2.4.ebuild,v 1.15 2012/07/24 15:08:38 flameeyes Exp $
EAPI="4"
@@ -13,10 +13,9 @@ SRC_URI="http://www.lysator.liu.se/~nisse/archive/${P}.tar.gz"
LICENSE="|| ( LGPL-3 LGPL-2.1 )"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE="+gmp ssl"
+IUSE="+gmp"
-DEPEND="gmp? ( dev-libs/gmp )
- ssl? ( dev-libs/openssl )"
+DEPEND="gmp? ( dev-libs/gmp )"
RDEPEND="${DEPEND}"
src_prepare() {
@@ -28,8 +27,9 @@ src_prepare() {
}
src_configure() {
+ # --disable-openssl bug #427526
econf \
--enable-shared \
$(use_enable gmp public-key) \
- $(use_enable ssl openssl)
+ --disable-openssl
}
diff --git a/dev-libs/nettle/nettle-2.5.ebuild b/dev-libs/nettle/nettle-2.5.ebuild
index 0002db72acbe..71f24eafc570 100644
--- a/dev-libs/nettle/nettle-2.5.ebuild
+++ b/dev-libs/nettle/nettle-2.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/nettle/nettle-2.5.ebuild,v 1.1 2012/07/12 22:03:33 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nettle/nettle-2.5.ebuild,v 1.2 2012/07/24 15:08:38 flameeyes Exp $
EAPI="4"
@@ -13,10 +13,9 @@ SRC_URI="http://www.lysator.liu.se/~nisse/archive/${P}.tar.gz"
LICENSE="|| ( LGPL-3 LGPL-2.1 )"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE="+gmp ssl"
+IUSE="+gmp"
-DEPEND="gmp? ( dev-libs/gmp )
- ssl? ( dev-libs/openssl )"
+DEPEND="gmp? ( dev-libs/gmp )"
RDEPEND="${DEPEND}"
src_prepare() {
@@ -27,8 +26,9 @@ src_prepare() {
}
src_configure() {
+ # --disable-openssl bug #427526
econf \
--enable-shared \
$(use_enable gmp public-key) \
- $(use_enable ssl openssl)
+ --disable-openssl
}