summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-12-22 10:32:21 +0000
committerMike Frysinger <vapier@gentoo.org>2006-12-22 10:32:21 +0000
commit918aec789f6606695a003364e6734373860f5719 (patch)
tree17e047a175d138ea134e2a74982d8af8487ef6d7 /dev-libs/mpfr
parentproperly fix autotool logic (diff)
downloadgentoo-2-918aec789f6606695a003364e6734373860f5719.tar.gz
gentoo-2-918aec789f6606695a003364e6734373860f5719.tar.bz2
gentoo-2-918aec789f6606695a003364e6734373860f5719.zip
cleanup
(Portage version: 2.1.2_rc3-r9)
Diffstat (limited to 'dev-libs/mpfr')
-rw-r--r--dev-libs/mpfr/mpfr-2.2.1.ebuild49
1 files changed, 25 insertions, 24 deletions
diff --git a/dev-libs/mpfr/mpfr-2.2.1.ebuild b/dev-libs/mpfr/mpfr-2.2.1.ebuild
index 523248b21fd3..f5818af63bcb 100644
--- a/dev-libs/mpfr/mpfr-2.2.1.ebuild
+++ b/dev-libs/mpfr/mpfr-2.2.1.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/mpfr/mpfr-2.2.1.ebuild,v 1.1 2006/12/22 09:41:59 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/mpfr/mpfr-2.2.1.ebuild,v 1.2 2006/12/22 10:32:21 vapier Exp $
-inherit eutils flag-o-matic autotools
+# NOTE: we cannot depend on autotools here starting with gcc-4.3.x
-MY_PV=${PV/_p*}
+MY_PV=${PV##_p*}
MY_P=${PN}-${MY_PV}
-PLEVEL=${PV/*p}
+PLEVEL=${PV##*p}
DESCRIPTION="library for multiple-precision floating-point computations with exact rounding"
HOMEPAGE="http://www.mpfr.org/"
SRC_URI="http://www.mpfr.org/mpfr-current/${MY_P}.tar.bz2"
@@ -16,25 +16,26 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
IUSE=""
-RDEPEND=">=dev-libs/gmp-4.1.4-r2"
-
-S="${WORKDIR}"/${MY_P}
-
-#src_unpack() {
-# unpack "${MY_P}.tar.bz2"
-# cd "${S}"
-# for ((i=1; i<=PLEVEL; ++i)) ; do
-# patch=patch$(printf '%02d' ${i})
-# if [[ -f ${FILESDIR}/${MY_PV}/${patch} ]] ; then
-# epatch "${FILESDIR}"/${MY_PV}/${patch}
-# elif [[ -f ${DISTDIR}/${PN}-${MY_PV}_p${i} ]] ; then
-# epatch "${DISTDIR}"/${PN}-${MY_PV}_p${i}
-# else
-# ewarn "${DISTDIR}/${PN}-${MY_PV}_p${i}"
-# die "patch ${i} missing - please report to bugs.gentoo.org"
-# fi
-# done
-#}
+DEPEND=">=dev-libs/gmp-4.1.4-r2"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack "${MY_P}.tar.bz2"
+ cd "${S}"
+ [[ ${PLEVEL} == ${PV} ]] && return 0
+ for ((i=1; i<=PLEVEL; ++i)) ; do
+ patch=patch$(printf '%02d' ${i})
+ if [[ -f ${FILESDIR}/${MY_PV}/${patch} ]] ; then
+ epatch "${FILESDIR}"/${MY_PV}/${patch}
+ elif [[ -f ${DISTDIR}/${PN}-${MY_PV}_p${i} ]] ; then
+ epatch "${DISTDIR}"/${PN}-${MY_PV}_p${i}
+ else
+ ewarn "${DISTDIR}/${PN}-${MY_PV}_p${i}"
+ die "patch ${i} missing - please report to bugs.gentoo.org"
+ fi
+ done
+}
src_compile() {
econf \
@@ -45,7 +46,7 @@ src_compile() {
}
src_install() {
- make install DESTDIR="${D}" || die
+ emake install DESTDIR="${D}" || die
dodoc AUTHORS BUGS ChangeLog NEWS README TODO
dohtml *.html
}