summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-12-11 19:53:15 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-12-11 19:53:15 +0000
commite0d3eba2789d4f16d869cfe1db6c4c63a6c52d61 (patch)
treed40d655ad617f92cb2fa2b24b7f28e4eb2e7ec1d /dev-libs/mini-xml/mini-xml-2.7.ebuild
parentUpdate git repository. Bug #446874 (diff)
downloadgentoo-2-e0d3eba2789d4f16d869cfe1db6c4c63a6c52d61.tar.gz
gentoo-2-e0d3eba2789d4f16d869cfe1db6c4c63a6c52d61.tar.bz2
gentoo-2-e0d3eba2789d4f16d869cfe1db6c4c63a6c52d61.zip
Version bump. Bug #446348. Add Rüpel <ruepel@gmx.li> as proxy-maintainer
(Portage version: 2.1.11.34/cvs/Linux x86_64, signed Manifest commit with key B4AFF2C2)
Diffstat (limited to 'dev-libs/mini-xml/mini-xml-2.7.ebuild')
-rw-r--r--dev-libs/mini-xml/mini-xml-2.7.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/dev-libs/mini-xml/mini-xml-2.7.ebuild b/dev-libs/mini-xml/mini-xml-2.7.ebuild
new file mode 100644
index 000000000000..b0b974de71ca
--- /dev/null
+++ b/dev-libs/mini-xml/mini-xml-2.7.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/mini-xml/mini-xml-2.7.ebuild,v 1.1 2012/12/11 19:53:15 hwoarang Exp $
+
+EAPI=4
+
+inherit autotools multilib
+
+MY_P="${P/mini-xml/mxml}"
+
+DESCRIPTION="Small XML parsing library to read XML and XML-like data files"
+HOMEPAGE="http://www.easysw.com/~mike/mxml"
+SRC_URI="mirror://easysw/mxml/${PV}/${MY_P}.tar.gz"
+
+LICENSE="Mini-XML"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="threads"
+
+DEPEND="virtual/pkgconfig"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ sed -i -e "s:755 -s:755:" Makefile.in || die "sed failed"
+ sed -i "/^TARGETS/s: testmxml::" Makefile.in || die "sed failed"
+ sed -i -e 's:$(DSO) $(DSOFLAGS) -o libmxml.so.1.5 $(LIBOBJS):$(DSO) $(DSOFLAGS) $(LDFLAGS) -o libmxml.so.1.5 $(LIBOBJS):' \
+ Makefile.in || die "sed failed"
+ sed -i -e 's:OPTIM="-Os -g":OPTIM="":' configure.in || die "sed failed"
+ rm configure
+# eautoreconf
+ eautoconf
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ --libdir="/usr/$(get_libdir)" \
+ --with-docdir="/usr/share/doc/${PF}/html" \
+ $(use_enable threads)
+}
+
+src_compile() {
+ emake libmxml.a libmxml.so.1.5 mxmldoc doc/mxml.man || die "make failed"
+}
+
+src_install() {
+ emake DSTROOT="${D}" install || die "install failed"
+ dodoc ANNOUNCEMENT CHANGES README
+ rm "${D}/usr/share/doc/${PF}/html/"{CHANGES,COPYING,README}
+}
+
+src_test() {
+ emake testmxml || die "make testmxml failed"
+}