summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2010-01-12 04:24:06 +0000
committerMarkus Dittrich <markusle@gentoo.org>2010-01-12 04:24:06 +0000
commit376786feb50d456ec63c42bf82c7e50aad85ae74 (patch)
treebd1cc263ca4722957e73a5e4b0a98358e0046245 /dev-libs/maloc
parentRemove old. (diff)
downloadgentoo-2-376786feb50d456ec63c42bf82c7e50aad85ae74.tar.gz
gentoo-2-376786feb50d456ec63c42bf82c7e50aad85ae74.tar.bz2
gentoo-2-376786feb50d456ec63c42bf82c7e50aad85ae74.zip
Version bump. Also fixed emake QA issues (fixes bug #298738).
(Portage version: 2.1.7.16/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/maloc')
-rw-r--r--dev-libs/maloc/ChangeLog7
-rw-r--r--dev-libs/maloc/maloc-0.1.2.ebuild4
-rw-r--r--dev-libs/maloc/maloc-0.2.1.ebuild44
3 files changed, 52 insertions, 3 deletions
diff --git a/dev-libs/maloc/ChangeLog b/dev-libs/maloc/ChangeLog
index 445fe8803f0f..d1cd331f4c42 100644
--- a/dev-libs/maloc/ChangeLog
+++ b/dev-libs/maloc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/maloc
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/maloc/ChangeLog,v 1.8 2010/01/06 17:56:46 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/maloc/ChangeLog,v 1.9 2010/01/12 04:24:06 markusle Exp $
+
+*maloc-0.2.1 (12 Jan 2010)
+
+ 12 Jan 2010; Markus Dittrich <markusle@gentoo.org> +maloc-0.2.1.ebuild:
+ Version bump. Also fixed emake QA issues (fixes bug #298738).
06 Jan 2010; Jeremy Olexa <darkside@gentoo.org> maloc-0.1.3.ebuild:
Add prefix keywords, bug 298739
diff --git a/dev-libs/maloc/maloc-0.1.2.ebuild b/dev-libs/maloc/maloc-0.1.2.ebuild
index aeae26509779..3da0225eb5a8 100644
--- a/dev-libs/maloc/maloc-0.1.2.ebuild
+++ b/dev-libs/maloc/maloc-0.1.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/maloc/maloc-0.1.2.ebuild,v 1.2 2007/06/26 01:54:13 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/maloc/maloc-0.1.2.ebuild,v 1.3 2010/01/12 04:24:06 markusle Exp $
inherit eutils
diff --git a/dev-libs/maloc/maloc-0.2.1.ebuild b/dev-libs/maloc/maloc-0.2.1.ebuild
new file mode 100644
index 000000000000..c6cd639d3ba8
--- /dev/null
+++ b/dev-libs/maloc/maloc-0.2.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/maloc/maloc-0.2.1.ebuild,v 1.1 2010/01/12 04:24:06 markusle Exp $
+
+inherit eutils
+
+MY_PV="0.2-1"
+
+DESCRIPTION="MALOC is a small, portable, abstract C environment library for object-oriented C programming"
+LICENSE="GPL-2"
+HOMEPAGE="http://scicomp.ucsd.edu/~mholst/codes/maloc/index.html#overview"
+SRC_URI=" http://cam.ucsd.edu/~mholst/codes/${PN}/${PN}-${MY_PV}.tar.gz"
+
+SLOT="0"
+IUSE="mpi"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="sys-libs/readline
+ mpi? ( virtual/mpi )"
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ # fix install location of libs in Makefile
+ sed -e "s|libdir = \${prefix}/lib/\${fetk_cpu_vendor_os}|libdir = \${prefix}/$(get_libdir)/|" \
+ -i src/aaa_lib/Makefile.in || \
+ die "failed to patch lib Makefile"
+
+ # configure
+ econf $(use_enable mpi) \
+ || die "configure failed"
+
+ # build
+ emake || die "make failed"
+}
+
+src_install() {
+
+ # install libs and headers
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ # install doc
+ dohtml doc/index.html || die "failed to install html docs"
+}